disco79stu

Massive FPS drop with autogen

Recommended Posts

Hi,

is it normal that I get a drop in fps of 50% with autogen on? (P3d v4)

for example, sitting at gate on justsims eddl, fsl a320x, orbx global, lc_europe, orbx hd trees, i get 15-20 fps wirh autogen set to sparse and 40-50 fps with all autogen deactivated. 

I know autogen affects performance, but THIS much and when sitting on an airport????

it‘s similar when I‘m airborne, without autogen everything is supersmooth, but even the lowest autogen settings will kill my frames. 

is there a way to reduce autogen resolution or can I somehow improve it? I only want to see some trees on final, otherwise the terrain looks flat and unrealistic...

bg

stu

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi Stu,

in first place, i´m no expert but i´d suggest you to check your "Autogen draw distance"-slider. Just reduce it a bit and check results. In my case, doing so gave me a significant increase in performance, also those annoying stutters are gone, very noticeable especially with "heavy iron" aka FSLABS, PMDG.

Obviously what i mentioned above is highly depending on your hardware and other graphic / terrain / lighting options you might run on your P3D-setup.

So, long story short: experiment with different options, try to find the best balance between "eye-candy" and performance.

Please, all you P3D-Gurus chime in and correct me if i´m wrong. 🙂

(You´ll find a lot of useful information, tips and tricks to get the most out of your simulator here on the avsim forum, just do a quick search).

Good luck !

Lars

 

Share this post


Link to post

On my system I get micro stutters from autogen no matter what setting unless I completely disable autogen buildings. Then I get smooth panning with everything else to my liking at 30fps internally limited. I have tried experimenting with settings of TBM, TML, FFTF to move cpu priority to smoother fps than scenery/texture loading but couldn't produce noticeable difference, fps drops to 25 for fraction of second and sometimes longer on changing view angle, which then gradually stabilizes back to 30, or 40-45 when unlimited.

Share this post


Link to post

Your system is not capable of running smooth with your too high settings. Simple as that.

You are using very performance using addons, so you have to lower your settings.

Lock your FPS to 20 , set your LOD radius 1 notch lower, water off. No Vsync, no TB. Monitors at 60 hrtz.

Your system needs breathing air..

Share this post


Link to post

I tweaked everything there is to tweak, believe me, and the sim is running at its optimum for my system. But even the minimum settings of autogen (draw distance included) reduces my performance significantly. 

I expect a drop, don‘t get me wrong, but by over 20 fps? That seems extreme. But maybe that‘s the case....

Does anyone know if the „autogen per cell“ tweak in the cfg file works for p3d? 

Does orbx HD trees improve or reduce performance? 

Stu

Share this post


Link to post

In my opinion, it is not normal to see a reduction in framerates from 40-50 to 15-20 when switching between no autogen at all, and autogen set to Sparse. That sounds completely ridiculous to me.....unless there is a huge amount of autogen that has not been optimised for different Autogen Density settings.

Share this post


Link to post
2 hours ago, disco79stu said:

I tweaked everything there is to tweak, believe me, and the sim is running at its optimum for my system. But even the minimum settings of autogen (draw distance included) reduces my performance significantly. 

I expect a drop, don‘t get me wrong, but by over 20 fps? That seems extreme. But maybe that‘s the case....

Does anyone know if the „autogen per cell“ tweak in the cfg file works for p3d? 

Does orbx HD trees improve or reduce performance? 

Stu

Try disabling pop free autogen in p3d cfg, that gave me some more fps.

Share this post


Link to post

Without infos about Stu's hardware there is only reading tea leaves possible ...

Share this post


Link to post
3 minutes ago, JoeFackel said:

Without infos about Stu's hardware there is only reading tea leaves possible ...

You're absolutely right.

My rig: i7 2600k (OC to 4.2 GHz), GTX 1070, 16 GB DDR3 RAM, Win10. 
ActiveSky (2 cloud layers) with ASCA (lowest tex size for everything), ENVTEX (set to lowest possible), OrbX FTX Global + Open LC Europe + Trees HD  
Settings in P3D all "in the mid" with shadows to low (not cloud, autogen or terrain shadows), water low, no AI, no dynamix lighting, no vol. fog. 4x MSAA.

Nvidia settings are pretty standard with anitrosophic filtering to "application controled", transparent AA set to multisampling and Vsync to "fast". 

As I said, all in all the performance is great with 30-40 fps in the FSL A320. I would expect the performance to go down with autogen (as it did with FSX) but the impact shocks me and makes me wonder if something isn't right here. 

 

BG and thanks for all the replies,
Stu

 

Share this post


Link to post

I have my autogen set to normal, do not forget that prepar3d v4 runs much better with 20 fps than Fsx, have ever done.

in pmdg 747 on runway in Heatrow i have 22 fps with fairly high setting and it runs great.

 

my pc is a i7 6850 4,3 ghz

gtx 1080ti

16 gb 2666 MHz memory.

ssd disk.

 

I love prepar3d v4 thinks it runs great, much more smooth than FSX, i never go back to FSX

Share this post


Link to post

To be perfectly honest, I never understood those "lock at 30 fps"- or "smooth performance is not high fps"-comments.

Of course I tried and tested those concepts, but i think it looks just "unfluent" and strange if I have my frames locked at 20 or 30. Higher framerates always look better, smoother, more fluent to me. 40, 50 or even 60 fps, the more the better, not only in flightsim but also in other games.
I get a very very noticeable "stu-tt-er" when I change views inside the cockpit with only 20 fps. It looks awful in my opinion.

Many say that locking fps will give you a better over-all performance because the system can use the saved ressources for other things but I never experienced that. And setting the monitor to 30Htz (with 30fps locked) didnt give me a "smooth" expierience but just a headdache.

But that's just me, maybe I got use to fluent 60+ fps that I can't stand everything below 40 anymore 🙂

 

 

 

 

 

Share this post


Link to post
12 minutes ago, disco79stu said:

To be perfectly honest, I never understood those "lock at 30 fps"- or "smooth performance is not high fps"-comments.

Of course I tried and tested those concepts, but i think it looks just "unfluent" and strange if I have my frames locked at 20 or 30. Higher framerates always look better, smoother, more fluent to me. 40, 50 or even 60 fps, the more the better, not only in flightsim but also in other games.
I get a very very noticeable "stu-tt-er" when I change views inside the cockpit with only 20 fps. It looks awful in my opinion.

Many say that locking fps will give you a better over-all performance because the system can use the saved ressources for other things but I never experienced that. And setting the monitor to 30Htz (with 30fps locked) didnt give me a "smooth" expierience but just a headdache.

But that's just me, maybe I got use to fluent 60+ fps that I can't stand everything below 40 anymore 🙂

 

 

 

 

 

The best compromise between smoothness and performance is 30hz/30fps.  But u have to make sure your settings will not allow the frame rate to drop below 30 or u will get horrible stutters.  I still don’t understand how any one can claim “smoothness” under 30 fps.  

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now