Mace

dreaded "multiple objects with same file name"

Recommended Posts

I'm getting the annoying "multiple objects with the same file name" popup on P3D splash start.  Googling and the LM forums suggested this was a duplicate entry in the simobject.cfg file, but, I have no duplicate entries in said file.  

What did I do to deserve this annoyance, you ask?  I'm really not sure, and am hoping one of you might know.  I did recently add UPS repaints and models to my UTLive.  Since I didn't have all the models I needed, I also installed the FLAI models, but disabled the FLAI add-on as soon as I figured out FLAI only works with VATSIM.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Thats when in the aircraft.cfg are repaints that have the same "title=" entries. Each repaint that is added to the aircraft.cfg must have an unique name.

Share this post


Link to post
6 hours ago, Mace said:

I'm getting the annoying "multiple objects with the same file name" popup on P3D splash start.  Googling and the LM forums suggested this was a duplicate entry in the simobject.cfg file, but, I have no duplicate entries in said file.  

What did I do to deserve this annoyance, you ask?  I'm really not sure, and am hoping one of you might know.  I did recently add UPS repaints and models to my UTLive.  Since I didn't have all the models I needed, I also installed the FLAI models, but disabled the FLAI add-on as soon as I figured out FLAI only works with VATSIM.

Yeah its not dreaded. I custom built my AI and military AI, happens all the time.  Just jot down the name of the offending file.  Find the folder and aircraft.cfg and delete.  

Most likely the FLAI had UPS models and repaints already.   So its just a duplicate.  

Edited by jason99vmi

Share this post


Link to post
Just now, jason99vmi said:

Find the folder and aircraft.cfg and delete

Or, go into the aircraft.cfg and change the "Title" line, if you want to keep the aircraft in question.

 

Russ

Share this post


Link to post
1 minute ago, b1bmsgt said:

Or, go into the aircraft.cfg and change the "Title" line, if you want to keep the aircraft in question.

 

Russ

Right you could.  But i don't think the traffic file would find it since you changed its name.  But maybe it does since i don't know how UTL works.  I would have to go into AIFP and make sure the traffic file is fixed to match the aircraft with its flightplan.  

Share this post


Link to post

I encountered this over the weekend, and it was because I had accidentally saved one aircraft.cfg file in the folder of a different aircraft type. That resulted in having two folders with the same aircraft.cfg file in them. Fortunately, I keep regular backups of my AI aircraft folders, and I could identify the source of the problem from the error messages that appeared when P3D loaded.

Share this post


Link to post

Hmm.. Surprised I got any responses at all -- thanks.  But...

....I have to figure out where the duplicate is.  The offending file shown in the error message is the one that I must keep (D:\FSTOOLS\Ultimate Traffic Live\simobjects), because that's the folder UTlive uses for it's aircraft...

Share this post


Link to post

FLAI also doesn't work only with vatsim/ivao, it works great as AI. Check your simobjects.cfg for the UTL aircraft as well as for any UTLive folder within your Documents\Prepar3D v4 Add-ons folder.

Share this post


Link to post
15 hours ago, jason99vmi said:

Yeah its not dreaded. I custom built my AI and military AI, happens all the time.  Just jot down the name of the offending file.  Find the folder and aircraft.cfg and delete.  

Most likely the FLAI had UPS models and repaints already.   So its just a duplicate.  

Haha.  Well, it's dreaded to me, because I've had this error in the past, and it was always a bear trying to find the offending flightsim.xx section.  This time was no  different.

13 hours ago, Christopher Low said:

I encountered this over the weekend, and it was because I had accidentally saved one aircraft.cfg file in the folder of a different aircraft type. That resulted in having two folders with the same aircraft.cfg file in them. Fortunately, I keep regular backups of my AI aircraft folders, and I could identify the source of the problem from the error messages that appeared when P3D loaded.

Yes -- once I get my AI set up properly, I plan to back the whole thing up.  I did manage to fix the problem -- something had moved several of my flightsim.xx sections to the END of the aircraft.cfg file.  I didn't look there.  I looked at the beginning of the file, where I like to keep them...

It's possible that UTLive moved those sections, but I'm not sure if it does that.  Possibly pressing its repaint button (under the Configuration tab) does that, but I'm not sure yet.

Share this post


Link to post

 UTL won't move or even touch aircraft.cfg's once it's installed. But it's fixed now so you're good.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now