joepoway

Flightbeam KPHX Airport with P3Dv4.4 Performance Question?

Recommended Posts

I was wondering if anyone has noticed a performance issue in terms of frames and therefore micro stutters with Flighbeam's KPHX since upgrading to P3Dv4.4? 

I have all the Flightbeam airports and have had no issues with holding in excess of 30 fps for my Vsync'd 30 Hz monitor including KPHX. However since I have upgraded to P3Dv4.4 which I am very happy with I can no longer maintain the 30 fps with only this one airport. All my Orbx and other FB airports are working as well or better then they did in v4.3 but this one particular airport is now not behaving as it did. As a note I run Orbx Global and Base with this airport but not Vectors. As I said it used to be fine and all the other FB airports still perform well.

Has anyone else noticed a frames drop with FB KPHX in P3D v4.4?

Thanks in advance

Joe

Edited by joepoway

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

3 hours ago, joepoway said:

Has anyone else noticed a frames drop with FB KPHX in P3D v4.4?

Yes, I have. But I didn't realize it was a problem with KPHX only. Since I updated, I haven't had a chance to go flying. I just happened to quickly spawn at KPHX a few days ago. That's when I noticed a drop in FPS from 4.3. I was disappointed after having seen so many reports of performance gains from others, so I was going to troubleshoot tomorrow when I have a bit more time. Now it seems it's something not unique to my system. I'll be trying out other airports to see whether it is indeed only affecting KPHX on my side as well.

Share this post


Link to post

I have not noticed any performance drop in any of the Flightbeam sceneries that I have installed with v4.4, and that includes KPHX, KIAD, and KDEN. On the contrary, i'm seeing a slight increase in performance, on the order of 5 to 7 FPS on average, and it's ultra smooth, no stuttering, pausing, or hesitation of any kind. To put this in perspective, I ran all my scenery sliders to the max after installing v4.4 (they were already maxed, or very near) just to see what would happen, and was pleasantly surprised to see no degradation in performance, and in many cases a slight increase. I should also note that I run UT Live for AI airline traffic set @ 100% (AI traffic can be a notorious frame rate killer) and can see no dramatic effect on performance. Turning AI down to say 75 or 80% will give me a few more frames to be sure, but I have enough "headroom" that it's hardly ever necessary.

To say that i'm tickled with the performance in v4.4 would be a fair statement, and I love Flightbeam sceneries, I just wish they would do some more, and i'd like to see them do more of the mid-size airports like Wichita Mid-Continent (KICT) or Hollywood-Ft. Lauderdale (KFLL) for example, but almost anything they would do would be well received by most people I think.

Do either of you guys have Flightbeam's KSFO HD, and if so how does it perform. I'm thinking seriously about adding it and it's always nice to hear from others that actually use something before buying.

Edited by SunDevil56
spelling

Share this post


Link to post
14 hours ago, joepoway said:

I was wondering if anyone has noticed a performance issue in terms of frames and therefore micro stutters with Flighbeam's KPHX since upgrading to P3Dv4.4? 

I have all the Flightbeam airports and have had no issues with holding in excess of 30 fps for my Vsync'd 30 Hz monitor including KPHX. However since I have upgraded to P3Dv4.4 which I am very happy with I can no longer maintain the 30 fps with only this one airport. All my Orbx and other FB airports are working as well or better then they did in v4.3 but this one particular airport is now not behaving as it did. As a note I run Orbx Global and Base with this airport but not Vectors. As I said it used to be fine and all the other FB airports still perform well.

Has anyone else noticed a frames drop with FB KPHX in P3D v4.4?

Thanks in advance

Joe

No issues with fps in v4.4.

qIfbKJJ.jpg

Share this post


Link to post
1 hour ago, SunDevil56 said:

Do either of you guys have Flightbeam's KSFO HD, and if so how does it perform. I'm thinking seriously about adding it and it's always nice to hear from others that actually use something before buying.

Yes I do and it runs very well, it’s my default go to airport!

I still can’t figure out why only KPHX is having issues for me?

Joe

Share this post


Link to post
1 hour ago, joepoway said:

Yes I do and it runs very well, it’s my default go to airport!

I still can’t figure out why only KPHX is having issues for me?

Joe

Hi Joe,

This sounds a little odd. I haven't noticed any performance issues myself. Actually saw the opposite. 

Jump over to our forums and we will be able to investigate.

Cheers.

Share this post


Link to post
2 hours ago, joepoway said:

Yes I do and it runs very well, it’s my default go to airport!

I still can’t figure out why only KPHX is having issues for me?

Joe

Clear your Shaders folder.

Cheers,

Mark

Share this post


Link to post
1 hour ago, Tino said:

Hi Joe,

This sounds a little odd. I haven't noticed any performance issues myself. Actually saw the opposite. 

Jump over to our forums and we will be able to investigate.

Cheers.

Hey Tino, I just downloaded and installed KMSP and like KIAD, KPHX, and KDEN I can see no performance drop in v4.4, which is great, and i'll probably add KSFO here in the very near future.

Do you guys have other sceneries in the mill. and if so what..??

Edited by SunDevil56

Share this post


Link to post

Hey Sundevil56 -- KPDX is next and my experience with PHX and other FB airports is the same as yours. Love their products!

Happy Holidays....

P. 

Share this post


Link to post
6 hours ago, DJJose said:

No issues with fps in v4.4.

qIfbKJJ.jpg

Gotta love FB sceneries and then you look outside their product and ah yes the rolling green land of Arizona. I wish ORBX could come up with a fix for that. I have noticed only a small drop off of FPS after initial install of the client but after deleting shaders and CFG everything seems back to normal. 

Share this post


Link to post
2 hours ago, pgde said:

KPDX is next

No, NZWN is next then KPDX

Share this post


Link to post
18 minutes ago, Shylock_35 said:

Gotta love FB sceneries and then you look outside their product and ah yes the rolling green land of Arizona. I wish ORBX could come up with a fix for that. I have noticed only a small drop off of FPS after initial install of the client but after deleting shaders and CFG everything seems back to normal. 

I agree. The ftx colors are way off.

Share this post


Link to post

I believe FB's new control panel interface has a troubleshooter section that will scan for conflicts, might want to use that to check for issues.

Cheers, Rob.

Share this post


Link to post
22 minutes ago, DJJose said:

I agree. The ftx colors are way off.

I don't know guys.... I have FTX, as well as all the ORBX landclass sceneries and vector running with Flightbeam KPHX, and the textures look ok to me. The screenies below will illustrate my point. 

Now granted, the small patches of heavily forested areas look out of place in the Phoenix metro area compared to "real world" (I grew up in the area and have flown over it dozens of times) but overall the textures look fine to me.

https://imgur.com/kshCnNI

https://imgur.com/8gin9fC

Share this post


Link to post
30 minutes ago, SunDevil56 said:

I don't know guys.... I have FTX, as well as all the ORBX landclass sceneries and vector running with Flightbeam KPHX, and the textures look ok to me. The screenies below will illustrate my point. 

Now granted, the small patches of heavily forested areas look out of place in the Phoenix metro area compared to "real world" (I grew up in the area and have flown over it dozens of times) but overall the textures look fine to me.

https://imgur.com/kshCnNI

https://imgur.com/8gin9fC

The ground colors should be more toward the brown side and not green. The airport displays the right colors, but you can clearly see that FTXG & LC combo fail to blend well with this wonderful airport. This should have been addressed by ORBX a long tie ago.

Share this post


Link to post

They look fine to me, at least in my pics, your's are another matter. I guess we'll just have to agree to disagree.

Share this post


Link to post

I posted my observation on the Flightbeam forum and this was a response I received from one of the FB staff members:

That is completely understandable. The v2 of Phoenix mainly was done to optimize some of its features like Dynamic Lighting, Flood Lamp Glow, and most important was having it added to our Flightbeam Manager and getting away from the FSDT Manager/Coutl.

When it was released we made sure we were very clear that v2 was NOT a redo of PHX by any means. PHX needs to be updated; but with current projects on the table it is not doable at the moment. PHX will get the love it deserves in due time just like all the rest of our airports. Only difference is LM P3D does updates at a constant rate with a TEAM of people while we are trying to do new scenery products, and keep the updates flowing with for the most part ONE scenery person. Big difference.

Share this post


Link to post
6 hours ago, joepoway said:

I posted my observation on the Flightbeam forum and this was a response I received from one of the FB staff members:

That is completely understandable. The v2 of Phoenix mainly was done to optimize some of its features like Dynamic Lighting, Flood Lamp Glow, and most important was having it added to our Flightbeam Manager and getting away from the FSDT Manager/Coutl.

When it was released we made sure we were very clear that v2 was NOT a redo of PHX by any means. PHX needs to be updated; but with current projects on the table it is not doable at the moment. PHX will get the love it deserves in due time just like all the rest of our airports. Only difference is LM P3D does updates at a constant rate with a TEAM of people while we are trying to do new scenery products, and keep the updates flowing with for the most part ONE scenery person. Big difference.

Joe, have you tried clearing the shaders folder as newtie suggested..??

Might be worth a shot.

Share this post


Link to post
7 hours ago, SunDevil56 said:

Joe, have you tried clearing the shaders folder as newtie suggested..??

Might be worth a shot.

Oh yes I always make sure I do that when changes occur, but thanks for the suggestion. I will try uninstalling and reinstalling next.

Joe

Share this post


Link to post
14 minutes ago, joepoway said:

Oh yes I always make sure I do that when changes occur, but thanks for the suggestion. I will try uninstalling and reinstalling next.

Joe

OK Joe, well good luck, hope you get it straightened out.

Share this post


Link to post
22 hours ago, Shylock_35 said:

Gotta love FB sceneries and then you look outside their product and ah yes the rolling green land of Arizona. I wish ORBX could come up with a fix for that. I have noticed only a small drop off of FPS after initial install of the client but after deleting shaders and CFG everything seems back to normal. 

Uo'd be surprised how much greenery is here😁

 

Share this post


Link to post
21 hours ago, Rob Ainscough said:

I believe FB's new control panel interface has a troubleshooter section that will scan for conflicts, might want to use that to check for issues.

Cheers, Rob.

Thanks Rob but it doesn't have a repair function. I did an uninstall and re-install but no difference.

The one knob I was able to reduce and show a rather significant effect was the AG and Scenery Draw distance. If I reduce it one notch to Very High I'm OK but the increased draw distance seems to be only an issue around FB KPHX. I think FB placed a lot of surrounding Phoenix scenery in this airport that is not optimized and now with the new "Scenery Distance" added to this slider in v4.4 my old system can't handle it.

So my options are to use the Extremely High setting and live with frames less than 30 hence my micro stutters on my Vsync'd 30 Hz 4K TV monitor at this one airport add-on I use or pull back the slider one notch and all is well. I'm going to experiment more to see if pulling back the setting is noticeable regarding the benefits I am seeing with airport scenery not popping in late or disappearing when panning around in v4.4. BTW I also have deployed your suggestion on the Max_Texture_Request_Distance=320000 and added Enable_Memory_Optimization=0 since my 8Gb of memory is still fine with lots to spare.

Thanks

Joe

Share this post


Link to post
1 hour ago, FireRx said:

 

Not that green. I’ve been there and I know northern Arizona is very green. But in and around the airport, not so much 

wFDNFWI.jpg

Edited by Shylock_35

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now