Recommended Posts

Hi, i can´t believe i dont find it with google, but:

I replaced my 4 GB GTX 980 with an 8 GB 1070 Ti. 

Question: How do i teach P3D that there is a new GPU with doubled RAM?

Even at EDDF P3D wont use more than the 4 GB limit of the old GPU. All settings maxed out, with a 3840x2160 resolution, with ORBX Global, LC Europe and vector and REX HD Airports in a PMDG 737. Dedicated Vram used at 3.5-3.6 GB at rural environment, 3.9/4.0 at EDDF / Frankfurt City. Other users experience 6/7/8 GB at EDDF 

For violating P3D i included the "TEXTURE_SIZE_EXP=10" in the .cfg. Result: 5.7 GB dedicated VRAM used (Ups, more than 4?) , but also 3 GB shared video memory. 

So i think P3D does not aknowledge the additional VRAM.

I remember that with a new installation there is a message like "At first time startup P3D will inspect your hardware and make some settings". How can i get P3D to do this again? Uninstalling and reinstalling  the Client does not bring up this message again.

Any help appreciated, thanks!

Thomas

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Suggest clean out your old video drivers with DDU uninstaller and reinstall with latest drivers for your card. Delete P3D.cfg and shaders and let P3D rebuild them. P3D should automatically know how much vram you have there is no hardware inspection you need to do.

Share this post


Link to post
5 hours ago, ThomasEDDL said:

Hi, i can´t believe i dont find it with google, but:

I replaced my 4 GB GTX 980 with an 8 GB 1070 Ti. 

Question: How do i teach P3D that there is a new GPU with doubled RAM?

Even at EDDF P3D wont use more than the 4 GB limit of the old GPU. All settings maxed out, with a 3840x2160 resolution, with ORBX Global, LC Europe and vector and REX HD Airports in a PMDG 737. Dedicated Vram used at 3.5-3.6 GB at rural environment, 3.9/4.0 at EDDF / Frankfurt City. Other users experience 6/7/8 GB at EDDF 

For violating P3D i included the "TEXTURE_SIZE_EXP=10" in the .cfg. Result: 5.7 GB dedicated VRAM used (Ups, more than 4?) , but also 3 GB shared video memory. 

So i think P3D does not aknowledge the additional VRAM.

I remember that with a new installation there is a message like "At first time startup P3D will inspect your hardware and make some settings". How can i get P3D to do this again? Uninstalling and reinstalling  the Client does not bring up this message again.

Any help appreciated, thanks!

Thomas

 

Are you using 4096 textures ? I usually get around 5-7gb VRAM around EDDF,EDDK (ORBX GES) with EXP=9

With Overcast and dynamic lights , 4096 shadows its around 7gb

Thanks

Michael Moe

Edited by Michael Moe

Share this post


Link to post
6 hours ago, ThomasEDDL said:

For violating P3D i included the "TEXTURE_SIZE_EXP=10" in the .cfg. Result: 5.7 GB dedicated VRAM used (Ups, more than 4?) , but also 3 GB shared video memory. 

So i think P3D does not aknowledge the additional VRAM.

Ehhhm, you increase the settings to the max and P3D uses 5.7GB of VRAM and yet you conclude "P3D does not acknowledge the additional VRAM"? It obviously does. And why should it hammer the VRAM full with 8GB if not needed?

Don't look for an issue when there is absolutely none. Everything fine as you describe.

Share this post


Link to post

@glider1: thanks, does not work.

 

AnkH:

My system obviously avoids going above 4 GB. With all maxed out, 4096 textures, 4096 Clouds and 3840x2160, heavy overcast and 100 % airline traffic it is at 4 GB. 

Even with TEXTURE_SIZE_EXP=9 i stay at 4 GB!! 

Only with TEXTURE_SIZE_EXP=10 i can get it using more than 4 GB VRAM, but P3D uses shared graphics memory instead of the VRAM on the graphic card. 

 

3 hours ago, AnkH said:

And why should it hammer the VRAM full with 8GB if not needed?

It only uses 5,7 GB VRAM, and needed are obviously 8,7 GB, as 3 GB shared video memory is allocated.

In a similar situation, see graphic below: 8,1 GB needed, 2.9 GB shared memory used, but 2,8 GB VRAM free? This cant be normal, or?

As you can see in Michael Moes post (thanks) he has in a similar situation (TEXTURE_SIZE_EXP=9) 7 GB VRAM usage. Mine is 4 GB in this case.

 

2018-12-21_111528.gif

 

Thanks, greetings Thomas

Edited by ThomasEDDL

Share this post


Link to post

Ok, i´m very confused, because after a complete uninstallation, i have the same result. 

Is the intensive usage of the shared memory normal? Does someone else has similar values like in the graphic above? 3 GB GPU VRAM free and 3 GB shared memory used??

Thanks Thomas

Share this post


Link to post

Strange, might it be a simple readout error by Windows? Did you check by other tools like GPU-Z how much VRAM is used? If I am not wrong, you should have no shared memory when using a GPU such as the 1070Ti.

Did you once install the nVIDIA criver completely new after switching GPUs? Might be that something went wrong there... because it tells "GPU-Speicher: 8.1/16" and you do not have 16GB VRAM...

Edited by AnkH

Share this post


Link to post

Did again a driver uninstall and install. And an older driver install. No effect. GPU-Z has same readings as Windows.

Checked GPU and Windows behaviour in PlanetCoaster: Filled with zooming and panning 6,6 GB of VRAM, shared memory at 0.3 GB. That is like expected.

What is wrong with me 🙂 ? Clean install, this time only pure P3D with no addons, maxed settings and TEXTURE_SIZE_EXP=10. Graphic above still shows the abnormal situation.

Any ideas?

THANKS!

Edited by ThomasEDDL

Share this post


Link to post
23 minutes ago, ThomasEDDL said:

Did again a driver uninstall and install. And an older driver install. No effect. GPU-Z has same readings as Windows.

Checked GPU and Windows beaviour in PlanetCoaster: Filled with zooming and panning 6,6 GB of VRAM, shared memory at 0.3 GB. That is like expected.

What is wrong with me 🙂 ? Clean install, this time only pure P3D with no addons, maxed settings and TEXTURE_SIZE_EXP=10. Graphic above still shows the abnormal situation.

Any ideas?

THANKS!

Hi Thomas,

You're not alone. I also changed to a 1070Ti  a few months ago, and  have the same "problem". The amount of VRAM never goes higher then 4Gb ...

Nico

Share this post


Link to post

Oh, thanks for this info Nico!

Yes, that was the start of the problem, me seeing that i dont get P3D use more than 4 GB. With all settings maxed out and Active SKY and REX Skyforce maxed settings. Only with  TEXTURE_SIZE_EXP=10 i get it above 4 GB, and then it uses shared memory massively.

Is yours a Gigabyte Windforce too?

Thanks Thomas

Share this post


Link to post

No,it is a MSI GeForce® GTX 1070 Ti Gaming 8G

 

Share this post


Link to post

long shot

There isn't any BIOS setting sharing system memory as VRAM? Or some on-board VGA activated

Share this post


Link to post

@kand checked and no 😞. And IGPU deactivated. And planet coaster can make use of 7 GB RAM with no shared memory usage...

Thanks!

  • Upvote 1

Share this post


Link to post
46 minutes ago, ThomasEDDL said:

Oh, thanks for this info Nico!

Yes, that was the start of the problem, me seeing that i dont get P3D use more than 4 GB. With all settings maxed out and Active SKY and REX Skyforce maxed settings. Only with  TEXTURE_SIZE_EXP=10 i get it above 4 GB, and then it uses shared memory massively.

Is yours a Gigabyte Windforce too?

Thanks Thomas

I'll have a look at my system tonight as I've had the Gigabyte Windforce OC 8GB for a week now with an i7-4770 processor...

Its not a ti model but the moment I switched from my old Graphics card (Radeon R9 270X) the whole system felt slower and less responsive when doing anything, let alone P3D v4.4

To be honest what I didnt do at the time though was use the DDU Uninstaller (hadnt even heard of it until I searched on google for the issues that I was having); In the end I used that, yet also decided to format the drive that had my Operating System on it... I also completely removed and re-installed P3D v4 along with the basics addons (FTX Global / FTX OpenLC / REX Skyforce / TomatoShade / AS4 / PMDG737), in terms of how the system feels it certainly seems quicker yet havent checked the GPU stats to make sure I'm not having the same VRAM issues as yourself.

In a way I hope I am was taking off from the P3D Atlanta (I then tested with ImagineSim's version) yet getting around the 20 FPS mark with settings that arent that much greater than what I had for my Radeon

Share this post


Link to post

May sound crazy ...but I'll throw this out there anyway: had a similar problem awhile back, turned out to be a bad display port cable.

Share this post


Link to post

whilst TEXTURE_SIZE_EXP=9 can use about 4GB, TEXTURE_SIZE_EXP=10 is 4x the size and could theoretically use 16GB. from experience (with my not quite max settings in P3D) a couple of sky textures set outside P3D to 4096k will use all the RAM on a 1080 and spit me out to the desktop. in my experience active sky will give a warning and rex will not before you are dumped out (CTD).
I removed TEXTURE_SIZE_EXP=anything and although textures more obviously 'come into focus' as I progress across the landscape, I'm satisfied with the compromise.

 

the point I'm aluding to is that a card with 4GB at 9 will handle everything but going to 10 and depending on the requirements of the enviroment you're flying in and what texture settings are; you can use more ram than is available.
oh, and monitor resolution is a factor.

Edited by jpf

Share this post


Link to post

Problem solved! Now VRAM / shared memory usage as expected (and normal!) 🙂

@EastFB72 

Was all ok at your system?

@kiek You still have the problem? 

As im not totally sure what was the real last successful step: I was fiddeling around in the Nvidia Profile Inspector, cause it was obviously a problem in the graphic region of my PC. But after success, i cant reproduce the problem by putting settings back. I think the successful option was: 

2018-12-23_124826.gif

I have to mention that I had activated the internal GPU for my fourth monitor 3-4 months ago in my actual windows installation, but not with the current P3D installation, nor with the new GPU. Also the internal GPU was disabled in BIOS the last months. kiek, please try the other two options, maybe followed by returning to your currently selected option and tell me if your real VRAM memory is used at demanding settings (without shared memory usage going high too! now i have 5-6-7 GB used, with shared memory at 0.2-0.4 GB) Dont forget to press the apply button in inspector! 🙂

Addendum: I before uninstalled nvidia driver with DDU, activated iGPU, uninstalled intel driver with DDU, pressed (tried) p3d to run on the iGPU intel-monitor. No success until i changed the multi-montor/rendering option in inspector.

Greetings from happy Thomas 

Share this post


Link to post
15 minutes ago, ThomasEDDL said:

@kiek You still have the problem? 

Yes I have. But I have only one monitor and I'm not using Nvidia inspector ...

Share this post


Link to post
4 hours ago, ThomasEDDL said:

@kiek Never used iGPU?

No, not that I am aware off. I had a GTX970 before.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now