Gandalf

Weird flickering

Recommended Posts

Hi All

Had to format and re-install everything (long story, my foul up 😒). Anyway after many many hours all up and running as before, or so I thought...

I’m now getting black flickering every 10secs or so, yet when I alt/enter into full screen it disappears and I have a stable image. 

Anyone any ideas?

Regards

Alan

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I had the same exact problem. Do you use PTA or TomatoShade? If so revert back to original shadders and apply your tweaks again. 

Share this post


Link to post

Hi, thanks for the reply. No, don’t have any shader add ons at all.

Have noticed it must be something to do with “windows” ( not the operating system...) I’m currently flying an Aerosoft bus and when I resized the pop up window the flashing started, as soon as I stopped resizing the flashing stopped.

In windowed mode the flashing is almost continuous  however...

Share this post


Link to post

Ok problem solved 😀. Disable full screen optimisation. 

I really need to improve my searching skills!! 🙄

Topic closed

Regards

Alan

Share this post


Link to post
1 hour ago, Gandalf said:

Ok problem solved 😀. Disable full screen optimisation. 

I really need to improve my searching skills!! 🙄

Topic closed

Regards

Alan

You can also resolve this by enabling triple buffering and VSync.

Regards 

Simbol 

Share this post


Link to post

Hi Simbol

Thanks for the reply, did see your solution in the other thread I found 😊

Just out of interest what exactly does full screen optimisation do?

Regards

Alan

Share this post


Link to post
23 minutes ago, Gandalf said:

Just out of interest what exactly does full screen optimisation do?

There is a big debate about if it is worth to have it enabled or not.

Each game / software seems to react different to it depending on many factors, experimentation is required to determine if it is better to have it enabled or not for each person for P3D.

This article gives good information about this subject: https://community.amd.com/thread/226321

Regards 

Simbol 

Share this post


Link to post

Thanks for the link 👍 I have to say just disabling it did the trick for me 😀

Share this post


Link to post
1 hour ago, simbol said:

There is a big debate about if it is worth to have it enabled or not.

Each game / software seems to react different to it depending on many factors, experimentation is required to determine if it is better to have it enabled or not for each person for P3D.

This article gives good information about this subject: https://community.amd.com/thread/226321

Regards 

Simbol 

Interesting topic.

I knew about the "disable full screen optimizations" setting in the P3D program properties/compatibility tab, but I never messed with it, i've always just left it at the default value, which is "enabled" on my system.

On the subject of flickering....  With ORBX HD Trees installed I get occasional flickering of a few trees in some locations. It's by no means widespread, and in most areas it's absent altogether, or scarcely noticeable.

At any rate, I never found it annoying enough to worry about, since pretty much everything else is working splendidly in P3D on my system, so i've never bothered with looking for a solution, but I tried disabling FSO's for P3D to see if it would make any difference.... It didn't, but it was worth a try anyway, so thanks for the suggestion guys....😎

Share this post


Link to post

It wasn’t so much flickering as a black flash about every 10secs, difficult to describe but imagine the whole image disappearing momentarily then returning.

Anyways disabling FSO sorted it for me 🙂

Share this post


Link to post
10 minutes ago, Gandalf said:

It wasn’t so much flickering as a black flash about every 10secs, difficult to describe but imagine the whole image disappearing momentarily then returning.

Anyways disabling FSO sorted it for me 🙂

YIKES...!!! 

Nope, nothing like that for me, thankfully....😁

Share this post


Link to post

The sad thing is if you have fsl a319 or a320 you can not disable it, because they put it back to active anytime you start the sim. 

Will be fixed with the next update as far as i know.

Share this post


Link to post
24 minutes ago, 331BK said:

The sad thing is if you have fsl a319 or a320 you can not disable it, because they put it back to active anytime you start the sim. 

Will be fixed with the next update as far as i know.

Apparently that’s true although I don’t have that aircraft.

But even without FSO NOT being disabled I had no problem in full screen, only windowed mode

Regards

Alan

Edited by Gandalf
Change of meaning

Share this post


Link to post
55 minutes ago, 331BK said:

The sad thing is if you have fsl a319 or a320 you can not disable it, because they put it back to active anytime you start the sim. 

Will be fixed with the next update as far as i know.

I saw that. Hope they fix it soon. For now I removed the labs from my system until the next update. Been wait over a month for this next update. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now