ols500

Regular stutters every minute.

Recommended Posts

Hi I have decent FPS in P3D, but get regular stutters every minute. I monitor my FPS on MSI afterburner and literally every 60 seconds my FPS drops and I get a freeze in the sim. I have gone back to no overclock, but still, get stutters, any ideas?

If you need any details please ask, Ollie.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I'm using FSUIPC but already disabled autosaves as I know it causes stutters.

Share this post


Link to post

got the latest  version  of  fsuipc

Share this post


Link to post

No, I'll go an update FSUIPC, maybe it will remove the stutter.

Edited by ols500

Share this post


Link to post

Highly unlikely it is FSUIPC. Stutters are a pain to track down. Do you notice any disk thrashing (or unusually high disk activity) when you experience them?

Share this post


Link to post

How could I take high disk activity? Through task manager?

 

-Ollie

Share this post


Link to post

Through the Task Manager, yes, (or even Process Explorer) but also by simply eyeballing the disk activity LED. On my machine I notice the LED being very active during stutters. I have yet to track down what is causing it but they seem to be tied together. More than likely system processes going on in the background. It could be a plethora of things including AV activity (although I have excluded my FS drive and other relevant folders). It also could be that since I have a lot of scenery loaded and accessed from an external drive (to save space on my FSX dedicated SSD) that could be causing pauses and therefore stuttering. I really do not know.  It will take a lot of time and effort to try tracking it down, neither of which I have the luxury of at the present time due to RL commitments.

Share this post


Link to post

This one may be off from your situation but I traced my stutters down to a conflict between my windows 10 sound drivers and my amd rtx sound drivers

Share this post


Link to post

Thought of that and uninstalled the nVidia sound drivers (just the default Realteks now) but still no joy. It's a complex issue that cropped up about a month and a half ago with no real changes in my FSX setup.

Share this post


Link to post

How many monitors do you have and how are they connected, DVD-I HDMI DP ?

Share this post


Link to post

Ok, I think I will just re-install P3D as it seems easier to do than tracking down the actual cause.

 

-Ollie

Share this post


Link to post

Try deleting the shaders first. Let the sim rebuild them. Maybe even the cfg. file

Last shot before you go through the process of un-install / re-install?

Share this post


Link to post
27 minutes ago, speedyTC said:

deleting the shaders

Sound advice. I did that recently and the FPS improved.

Share this post


Link to post

Already tried that, just gonna spend my afternoon re-installing 😞 I appreciate the help anyway.

Share this post


Link to post
1 hour ago, ols500 said:

Already tried that, just gonna spend my afternoon re-installing 😞 I appreciate the help anyway.

Are you reinstalling just the sim or a new fresh partition drop and windows reinstall. 

Are you running in 4k?

Do you have ai on? 

Does it happen everywhere or only in an orbx area? 

What are you texture size settings 

What is your autogen settings 

Do you have latest version of sode

Do you have latest version of fsuipc 

What gfx card 

What cpu?? 

Do you have hyper threading on or off

 

Absolutly every single one of those things I mentioned above will cause stutters if you don't set it up correctly on your system. 

As infuriating 'every one system is is different' is it is even more infuriatly true. 

For example on my rig I have to have hyper threading on with an affinity mask. It took 6 weeks to get 4.4  to run smoothly. And a heap of tweaking.  

Please don't think deleting shaders is the magic bullet and by just uninstalling and reinstalling P3Dv4 is going to solve all your problems. 

You need to start from scratch and systematically work through the issues. 

Edited by tooting

Share this post


Link to post

Ok, re-installed P3D. Sadly the issue still persists every 2nd second of every minute a stutter occurs.

 

I have not overclocked anything, but here are my specs:

i5 8600K

16GB RAM

GTX 1060 

9 minutes ago, tooting said:

Do you have hyper threading on or off

Don't think the i5 8600K has hyperthreading.

 

9 minutes ago, tooting said:

Are you running in 4k?

No, 1080p.

Share this post


Link to post

Plus I have not used any affinity mask tweak, or use Nvidia inspector.

Share this post


Link to post
12 hours ago, madhouse1616 said:

This one may be off from your situation but I traced my stutters down to a conflict between my windows 10 sound drivers and my amd rtx sound drivers

How did you track the conflict?

Edited by ols500

Share this post


Link to post

Ah, it's not just in P3D, with other games I get the same stutter every minute.

Share this post


Link to post
6 hours ago, ols500 said:

Ah, it's not just in P3D, with other games I get the same stutter every minute.

Points to a hardware issue then, rather than software.

Overheating? If you are comfortable with hardware I'd take it all apart, give it a good clean and re-seat everything, just to make sure. After that go into your BIOS and make sure everything is set correctly. Don't rely on default or auto settings. There is a LOT of information out there that could help with your specific issue.

Hope you get it sorted. These faults are a real pain to isolate.

Share this post


Link to post

when  did it  start  the  stutters  since  you  must  have  changed  some thing  to  have  it, or  did you  have  it  from day  one   when  you  first installed  p3d

Share this post


Link to post
45 minutes ago, speedyTC said:

Hope you get it sorted. These faults are a real pain to isolate.

Thanks 😄

I'm gonna give my PC a good clean, but in game, the CPU runs at 70c, so should be fine.

Share this post


Link to post

====================SOLUTION=======================

I found out that the windows 1809 update turned on "Game Mode" which causes windows to search through the game and try to optimise windows every 60 seconds... Turned it off and it was fixed!! NEVER turn this on! 😄

 

-Ollie

Share this post


Link to post

Thanks for posting the solution 😊 far too many threads just end with “sorted” with no clue as to how.

Regards

Alan

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now