Cruachan

Saitek X52 Pro - Hat Switch Issue

Recommended Posts

Hi guys,

Got myself the Logitech Saitek X52 Pro Stick and Throttle combo. Nice!

Installed without any issues in Windows 7 and 10 using the latest drivers. Everthing is working fine bar one notable exception: The hat switch on the stick won’t pan in the virtual cockpit whereas it operates normally outside the vehicle.

Have any owners of this device come across this issue and found a solution? The hat switch is assigned to only the one function in Prepar3D v4.4 and that is View (Pan). Resetting defaults has had no effect.

Thanks.

Mike

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi Mike,

 

I have the same controller and my setting is view (pan) using hatswitch 1.

Try this and let me know if it works for you.

 

kind regards,

 

Bouwe

Share this post


Link to post
8 hours ago, bbking said:

Hi Mike,

I have the same controller and my setting is view (pan) using hatswitch 1.

Try this and let me know if it works for you.

kind regards,

Bouwe

Hi Bouwe,

Welcome to the AVSIM forums! 

I note your forum Avatar and am wondering whether you have heard of Griff Hamlin and ‘Blues Guitar Unleashed’? He has to be one of the best online tutors out there and has a huge following of aspiring blues guitar players. Recently we suffered the premature heart-wrenching loss of our beloved 11year old Burmese ‘Layla’ to large cell lymphoma, so it’s possible we may be kindred spirits and I can certainly empathise with your choice of cover photo 👍

What I find puzzling about the Hat Switch problem is the fact that it appears to be assigned correctly in the sim to View (pan) and yet only works outside the vehicle. Inside the Virtual Cockpit Hat Switch 1 remains stubbornly unresponsive. There has to be a solution. So far, I’m just not seeing it 😢

Kind regards,

Mike

 

Share this post


Link to post

Hi Mike,

Sorry it didn,t work out for you. I can use my hatswitch 1 for panning inside the virtual cockpit. Also using it outside for panning around my helicopter/plane. It is strange that your hatswitch is doing just fine outside but not inside.. I am using X52_HOTAS_x64_8_0_213_0.exe driver. Maybe it's the software driver thats causing this. If you cannot find the driver let me know i will sent you a pm.

 

Regards,

 

Bouwe

btw thx for your explanation about my avatar name!!

  • Upvote 1

Share this post


Link to post

I’m guessing a conflict of assignments is involved. The question which is/are the likely candidates....because it ain’t obvious to me?

Mike

Share this post


Link to post

Did you delete your previous controller (both in Windows and the sim)?

Greg

Share this post


Link to post

Hi Bouwe,

Yes, I’ve checked and the driver installer filename is: X52_Professional_HOTAS_x64_8_0_213_0.exe

I run Prepar3D under Windows 7 Pro 64bit. Looking at the Properties of the Device X52 Professional Space/Flight H.O.T.A.S. I am seeing:

X52 Professional H.O.T.A.S. (USB)

Driver Provider: Logitech

Driver Date: 20/04/2017

Driver Version: 8.0.121.0

X52 Professional H.O.T.A.S. (HID)

Same details as above

Also downloaded and installed from the same source as the driver file: Prepar3Dv4_Plugin_x64_Software_8.0.150.0.exe

Regards,

Mike

Share this post


Link to post
51 minutes ago, lownslo said:

Did you delete your previous controller (both in Windows and the sim)?

Greg

Hi Greg,

That would be hard to do as, believe it or not, I’ve been flying for the last 3 years with a mouse! In fact, got quite good at it 😀 When I built my rig the darn thing was just too heavy to carry up two flights of stairs to its final destination so I left it on a bench in the basement of the house where I could service it with ease. There was no bench room for any bespoke controllers.

However, I have been persuaded by the lady of the house that it was now time to stop this silliness and make the effort. So, one rainy, windy day recently while she was holidaying in New Zealand I girded my loins and managed to achieve the unachievable....without managing to break my back! No regrets, just wishing now I had done it sooner. Now simming happily in a well padded comfy high-backed chair (previously sat on a wooden stool) with plenty desk real estate around me. Also, a set of Cambridge 4+1 speakers have reawakened from the dead and are, once again, pumping out some glorious noises to complement my flight simming ecstasy! You should hear the raw power from those 4 Rolls-Royce Olympus 201 engines powering Just Flight’s amazingly detailed and accurate Avro Vulcan XH558 simulation!!

Regards,

Mike

Share this post


Link to post

Perhaps I should have mentioned that everything works correctly while testing functionality of the Saitek X52 Pro under the Device’s Controller Settings - Properties. So, and despite resetting to defaults, it is looking more like the ‘problem’ lies with the key assignments in Prepar3D v4.4 on my setup. 

There might be a quick way to resolve this. Can I ask one of you to export your working key and axis Prepar3D assignments (with the Saitek X52 Pro attached) and make these available to me for testing? That way I can confirm my configuration is incorrect and, hopefully, I should be able to identify the cause.

Thanks.

Regards,

Mike

Edit: Just checked and everything is working well in X-Plane 11.30 and FSW so there’s nought wrong with the X52 Pro.

Share this post


Link to post

Hi Mike, Thought I would try my X52 controllers, managed to locate them in the loft, Got the same result as you, however I solved it by entering the EZdoc joystick settings and calling up the x52 controller. so the hat switch on both my controllers (ch yoke and pedals ) work fine.

can't remember if you have EZdoc or Chaseplane.

 

regards bob

  • Upvote 1

Share this post


Link to post

@Cruachan what a coincidence...I just got my Logitech X56 yesterday...:).

I also had issues setting the controls up. I found that I needed to go in Logitechs HOTAS SW under Programming and touch every single button, switch or axis. Afterwards I had to calibrate all under P3D (of course after calibrating the device under Logitechs SW).

Only after doing above steps, P3D recognized all the axes and buttons.

Gues No. 2 would be that you use EZCA (or another camera program)...you have to set your HAT SW in there also (and delete the HAT in P3D...)

  • Upvote 1

Share this post


Link to post

Hi Bob, Gerald

Thanks very much for your contributions. A light is dawning and I believe it has something to do with ChasePlane. I was using it for a while in its infant days of development, but decided to abandon it for a spell in favour of using the mouse...as explained in my previous post. However, I have been keeping it up to date in the expectation that I would start using it again. I think that time has now arrived and I need to reacquaint myself with its functionality.

Having read your helpful posts I am reminded that, despite the fact that I have not been using ChasePlane, the default virtual cockpit view is the one configured previously by ChasePlane. That may be why Hat Switch 1 (POV 1 on the X52 Pro) is not working in the virtual cockpit. So, as Gerald has stated, the answer could be a simple matter of reconfiguring the Hat in ChasePlane and deleting the conflicting assignment in Prepar3D. I’ll try later once I get up to speed again with ChasePlane.

Regards,

Mike

Edit: I too have the CH Products Yoke and Pedals (from USB 2 days) which exhibit the same issue. Hopefully the above solution will prove to be equally effective for both the Saitek and CH Controller devices.

Share this post


Link to post
Posted (edited)

Have you checked Options /Controls and panned down to Views /Hat switch and checked slider for Hat switch is not fully to the left. Set it at half way or fully right and see if that fixes the problem.

 

noels7

Edited by noels7

Share this post


Link to post
1 hour ago, noels7 said:

Have you checked Options /Controls and panned down to Views /Hat switch and checked slider for Hat switch is not fully to the left. Set it at half way or fully right and see if that fixes the problem.

noels7

@noels7 thanks for the suggestion, but sadly I'm afraid that doesn't work. In fact, the slider was full right already. Moving it to the left just chokes any movement when used outside the vehicle.

Regards,

Mike

Share this post


Link to post

Hi guys,

Found the solution: ChasePlane!

Didn't need to change anything in the Prepar3D controller assignments.

Read through the ChasePlane pdf and found the answer under Preferences - Control Assignments:

Under Controls - Buttons, I assigned Tilt Up, Tilt Down, Pan Left, Pan Right to the corresponding switch positions of POV 1 on the Saitek X52 Pro.

Problem solved!! Now works perfectly both inside the virtual cockpit and, as before, continues to function correctly outside the vehicle.

Confirmed the cause of the 'problem' was the default Cockpit View = On-Board (ChasePlane)

Selecting any of the other Cockpit View options allows correct panning in all directions.

So, in fact there never really was an issue.Groan!

Thanks everyone for your contributions. That's score one to the sim and zero to its hapless user...LOL!

Regards,

Mike

  • Upvote 2

Share this post


Link to post

Glad you got it sorted Mike. 

I have this same stick and throttle setup as you do, and I just love it, I can't say enough good things about it...

  • Upvote 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now