warbirds

P3D on the blink?

Recommended Posts

All of a sudden my version, v4, is blinking. Momentary black screens blinking on and off...what?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Clear your shaders cache and try again.

Share this post


Link to post

Are you using Win 10? Didn't a recent Win 10 update induce this effect?

Share this post


Link to post

Could be the update as it just started recently. I find that if I check the V sync box it stops it.

Share this post


Link to post

Odd that you mention this...I saw the same this morning.  It appears to be related to the low sun angle (early morning)...over the course of several minutes it slowed down and then stopped.

Regards

 

Share this post


Link to post

Does this happen if full-screen mode, too? I experienced it one day in windowed mode (scared the #$% out of me as I thought my GPU was failing), and I googled it only to find out that it's a known issue, but supposedly only affecting windowed mode (switching to full screen cured it for me).

Share this post


Link to post
1 hour ago, warbirds said:

Could be the update as it just started recently. I find that if I check the V sync box it stops it.

IIRC that was the solution until a more permanent solution arrived.

Share this post


Link to post
4 hours ago, tymk said:

Does this happen if full-screen mode, too? I experienced it one day in windowed mode (scared the #$% out of me as I thought my GPU was failing), and I googled it only to find out that it's a known issue, but supposedly only affecting windowed mode (switching to full screen cured it for me).

All modes in P3D are windowed mode...one has a border, the other not, but P3D does not run in exclusive full-screen mode like FSX did.

Regards

 

Share this post


Link to post

Same problem here, I thought Windows update as well since I wiped P3D and went to an older video driver, nothing fixes it except Vsync. I was testing a beta aircraft and thought that was the cause. The only other thing that changed was a Windows update..no other games/sims seem to be impacted except P3DV4

Share this post


Link to post

Disable fullscreen optimizations under the application settings and Compatibility.

  • Like 1

Share this post


Link to post

And where would that be?

Share this post


Link to post
Posted (edited)

Right click on either a shortcut or the prepar3d executable and hit properties. It will be under there.

Edited by JasonPC

Share this post


Link to post

That setting does seem to fix the flashing but then the sim is very stuttery and choppy now(used to run unlimited / no vsync). With that enabled + vsync+ triple buffering its smooth again. Good find though, thanks for sharing JasonPC.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now