Jump to content

Sign in to follow this  
ninerwhiskey9W

Which Prepa3d version should I install ?

Recommended Posts

Hello,

I've built myself a new PC, and held off on installing P3D due to the issues with the 4.5 update. I've been flying X-Plane in the meanwhile, but I miss the Majestic Q400, and the Maddog MD-82. Is 4.5 with the hotfix the final version for 4.5 or is there another version due out ? I remember reading the issue where core 0 was at 100% all the time even with the hotfix.

Is is safe to install v4.5 or should I install v4.4 until problems are resolved ?

Cheers 

9W

Share this post


Link to post
1 hour ago, ninerwhiskey9W said:

Is is safe to install v4.5 or should I install v4.4 until problems are resolved ?

4.5.12.30293 (includes HF1) all the way.  Works like a champ!  Problem was resolved a month ago.



Doug Miannay

M1mhPJG.png 1BV5Kt7.jpg

PC Specs: i7-8700K (OC 5.0GHz - HT Off) | ASUS Maximus X Hero Z370 | Corsair Hydro H150i Pro Cooler | ASUS STRIX-RTX2080TI-11G | 32GB G.Skill DDR4 TridentZ RGB 4000Hz  | Samsung 960 Pro 512GB M.2 (OS/Apps) | Samsung 960 Pro 1TB M.2 (Sim/Games) | Corsair H1000i PSU | Fractal Design Define R6 Blackout Case | Win10 Pro x64

Addons: Many Orbx Products | Many FSD/FB/FT/PacS/LatinV/Aerosoft Airports | ASP4/ASCA | UTL at 35% | ChasePlane | PMDG/FSL/A2A Aircraft

Share this post


Link to post
2 hours ago, dmiannay said:

4.5.12.30293 (includes HF1) all the way.  Works like a champ!  Problem was resolved a month ago.

Could not agree more. As close to flawless as it can get, in my opinion.


Mario Di Lauro

Share this post


Link to post

Yep. 4.5. I had no problems with the original release.


Vic green

Share this post


Link to post

No problems with 4.5 or the hotfix, you could install that. Also, Lockheed Martin doesn't have older installers on their website anyways.


Aaron Kim

i9-7980XE @ 4.0Ghz, RTX 2080 Ti, 32 GB RAM, Samsung EVO Pro 970 1TB M.2 (two of them)

FSDT, FlightBeam, PMDG 747, 777, 737, QW 787, A2A C172 & C182, Carenado Piper Warrior, Aerosoft CRJ, TFDI 717, CaptainSim 737, FsLabs A320 & A319, Xtreme Prototypes

그래요!! 

Share this post


Link to post
1 hour ago, arwasairl said:

No problems with 4.5 or the hotfix, you could install that. Also, Lockheed Martin doesn't have older installers on their website anyways.

Actually.. they do.. :wink:

  • Like 1

Bert

Share this post


Link to post

Actually they have posted only the client for earlier versions.


Gigabyte Z97X-UD5H-BK, Blk Ed MB; Intel I7-4790K CPU (@4.5 Ghz); 16 Gb G.Skill RAM (F3-2400); Win7 Pro; 2 Samsung 1Tb SSDs;Toshiba 3Tb hard drive; Gigabyte Aorus Extreme 1080ti 11Gb VRAM; Toshiba 43" LED TV @ 4k; P3D v4.5 HF2

 

Share this post


Link to post
10 hours ago, Bert Pieke said:

Actually.. they do.. :wink:

Are you able to run the client of v4.4 or under whilst still having the scenery and content of v4.5? Not sure about this one actually.


Aaron Kim

i9-7980XE @ 4.0Ghz, RTX 2080 Ti, 32 GB RAM, Samsung EVO Pro 970 1TB M.2 (two of them)

FSDT, FlightBeam, PMDG 747, 777, 737, QW 787, A2A C172 & C182, Carenado Piper Warrior, Aerosoft CRJ, TFDI 717, CaptainSim 737, FsLabs A320 & A319, Xtreme Prototypes

그래요!! 

Share this post


Link to post
2 hours ago, arwasairl said:

Are you able to run the client of v4.4 or under whilst still having the scenery and content of v4.5? Not sure about this one actually.

I believe you can..

  • Upvote 1

Bert

Share this post


Link to post

Thanks, I'll give 4.5 HF1 a try. I have the old v4.4 installers from my old PC, so I'll revert back in case something goes wrong.

Share this post


Link to post

Quick question,

I'm coming from 4.3 to 4.5.  Do I need to update the client, then do the HF separately ?

LM's website says the HF is incorporated into the full download but I can't tell about the client

 

Cheers,  Jeff

Share this post


Link to post
21 minutes ago, FLNG said:

Quick question,

I'm coming from 4.3 to 4.5.  Do I need to update the client, then do the HF separately ?

LM's website says the HF is incorporated into the full download but I can't tell about the client

 

Cheers,  Jeff

The Client will include the HF too. Install the Client, delete the contents of the shaders folder and optionally, delete Prepar3d.cfg. That's all that is needed for a point update of the Client.

The other reason you should update is because 4.5 is the only version L-M will support.


Ray (Cheshire, England).
System: P3D v4.5, Intel i7-8086K o/c to 4.6Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” UHD monitor.
Cheadle Hulme Weather

Share this post


Link to post

Thanks for clearing that up Ray.

I'm on it as soon as I get a little time free.

Jeff

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×
×
  • Create New...