Jump to content

Sign in to follow this  
TurboKen

Windows 10 Random "PAUSE" ???

Recommended Posts

So I just built a new computer and everything is working fine, except in P3d as you fly randomly its like I reach down and press the (P) pause button. Yes I can simply un-pause it but its annoying. Any ideas as to why it randomly pauses the game? 


Flight Simulator - P3D V4 | Operating System - WINDOWS 10 | Main Board - GIGABYTE Z390 AORUS PRO | CPU - INTEL 9600k ALL 6-Core's 5.0Ghz @ 1.37v | RAM - CORSAIR 16Gig DDR4 3400Mhz | Video Card - GIGABYTE RTX2080 OC Monitor - DELL 38" ULTRAWIDE | Case - CORSAIR 750D FULL TOWER W/RGB | CPU Cooling - CORSAIR H115i CUSTOM LOOP W/ DUAL 280MM RADIATORS | Case Cooling - (5) 140MM, (1) 120MM, (1) 80MM CASE FANS | Power Supply - EVGA 1000+ 

 

Share this post


Link to post
Share on other sites

Not likely anything to do with Win 10 -- there is a setting in P3D called "Pause on task switch", be certain that is unchecked.

Share this post


Link to post
Share on other sites
15 hours ago, pracines said:

Not likely anything to do with Win 10 -- there is a setting in P3D called "Pause on task switch", be certain that is unchecked.

Thanks.. I will look into that and report back.


Flight Simulator - P3D V4 | Operating System - WINDOWS 10 | Main Board - GIGABYTE Z390 AORUS PRO | CPU - INTEL 9600k ALL 6-Core's 5.0Ghz @ 1.37v | RAM - CORSAIR 16Gig DDR4 3400Mhz | Video Card - GIGABYTE RTX2080 OC Monitor - DELL 38" ULTRAWIDE | Case - CORSAIR 750D FULL TOWER W/RGB | CPU Cooling - CORSAIR H115i CUSTOM LOOP W/ DUAL 280MM RADIATORS | Case Cooling - (5) 140MM, (1) 120MM, (1) 80MM CASE FANS | Power Supply - EVGA 1000+ 

 

Share this post


Link to post
Share on other sites

So I have unchecked that setting and have not had any more pause effects. So thanks for the tip... Still not sure why it was pausing as no other task should have been running.. But then again it is win10, which stands for must check for updates like 10 times a min. LOL...

How do I add to the title "Solved"?


Flight Simulator - P3D V4 | Operating System - WINDOWS 10 | Main Board - GIGABYTE Z390 AORUS PRO | CPU - INTEL 9600k ALL 6-Core's 5.0Ghz @ 1.37v | RAM - CORSAIR 16Gig DDR4 3400Mhz | Video Card - GIGABYTE RTX2080 OC Monitor - DELL 38" ULTRAWIDE | Case - CORSAIR 750D FULL TOWER W/RGB | CPU Cooling - CORSAIR H115i CUSTOM LOOP W/ DUAL 280MM RADIATORS | Case Cooling - (5) 140MM, (1) 120MM, (1) 80MM CASE FANS | Power Supply - EVGA 1000+ 

 

Share this post


Link to post
Share on other sites
4 hours ago, turboken said:

But then again it is win10, which stands for must check for updates like 10 times a min. LOL...

Something is wrong with your system if it's checking that much. Mine checks once a day at the most and sometimes only once every few days.


 i7-6700k | Asus Maximus VIII Hero | 16GB RAM | MSI GTX 1080 Gaming X Plus | Samsung Evo 500GB & 1TB | WD Blue 2 x 1TB | EVGA Supernova G2 850W | AOC 2560x1440 monitor | Win 10 Pro 64-bit

Share this post


Link to post
Share on other sites

Pause on task switch is not the solution.

Solving this error usually requires identifying a notifier that is taking focus.

A program is probably taking focus when it should not be.


Steve Waite: Engineer at codelegend.com

Share this post


Link to post
Share on other sites

Could be anti-virus software running a scan or checking for updates, could be any number of programs checking for updates, automatic backups, disc scans, and defragmenting or SSD optimizing can also cause pauses.  Personally, I turn off all automatic features in Windows and in any software I install.

Share this post


Link to post
Share on other sites
Posted (edited)
11 hours ago, SteveW said:

Pause on task switch is not the solution.

Solving this error usually requires identifying a notifier that is taking focus.

A program is probably taking focus when it should not be.

But if turning off "pause on task switch" has prevented the pauses, and clearly anything going on in the background isn't noticeably affecting sim performance any more, surely this is a solution? I agree that trying to find whatever was causing the pause is the best solution, but not the only one (as the OP has discovered).

Edited by vortex681

 i7-6700k | Asus Maximus VIII Hero | 16GB RAM | MSI GTX 1080 Gaming X Plus | Samsung Evo 500GB & 1TB | WD Blue 2 x 1TB | EVGA Supernova G2 850W | AOC 2560x1440 monitor | Win 10 Pro 64-bit

Share this post


Link to post
Share on other sites

Well, of course it isn't a solution in the slightest, it is a poor work around at best.

Focus is taken from the sim and returns when you activate the window or a control or key.

So any app taking focus by calling out intermittently will be negatively impacting the sim whatever anyone says.

 

 


Steve Waite: Engineer at codelegend.com

Share this post


Link to post
Share on other sites
Posted (edited)
21 hours ago, SteveW said:

Well, of course it isn't a solution in the slightest, it is a poor work around at best.

Focus is taken from the sim and returns when you activate the window or a control or key.

So any app taking focus by calling out intermittently will be negatively impacting the sim whatever anyone says.

Semantics. If changing the setting has stopped the pauses with no noticeable effect on the sim, then it's a solution. It's much more than a "poor work around" - it's simple, effective and the problem is no longer apparent on the OP's system. I'm sure that plenty of people who have systems performing well would get pauses if they enabled "pause on task switch". Like many others, I turned it off on my system because I don't want to be interrupted by background tasks.

We could argue all day about what, if anything, should be running whilst running the sim but it's all a compromise. If you have background apps which you consider important to leave running and you can mitigate their effects on your primary focus (the sim, in this case), then it would be foolish not to do it. I would agree with you if the background task was still noticeably affecting the sim but if it isn't, job done!

Edited by vortex681

 i7-6700k | Asus Maximus VIII Hero | 16GB RAM | MSI GTX 1080 Gaming X Plus | Samsung Evo 500GB & 1TB | WD Blue 2 x 1TB | EVGA Supernova G2 850W | AOC 2560x1440 monitor | Win 10 Pro 64-bit

Share this post


Link to post
Share on other sites

If you say so.


Steve Waite: Engineer at codelegend.com

Share this post


Link to post
Share on other sites

That's so funny, "Semantics?"

In general, common sense sense dictates, if your is different, then why is that?

If I got that PC I would take it back to the shop I got it from because it aint working the same as my mate's PC. :blink:

 


Steve Waite: Engineer at codelegend.com

Share this post


Link to post
Share on other sites
Posted (edited)

And then of course, there's how it is all supposed to work.

Games and FSX and P3D and Windows are made especially so that we don't have focus taken when we are busy, and don't want that.

Sometimes a program of some kind checks out for updates or some tooltray app checks a resource, and they have an error whereby they take focus by accident.

I'm going by your description of the problem, which may be incomplete.

Your semantics suggest you could fix it by deleting P3D or turning off the PC as well. The same semantics, but too extreme, rather than different.

Anyway, that's the best I can do here.

Edited by SteveW

Steve Waite: Engineer at codelegend.com

Share this post


Link to post
Share on other sites
Posted (edited)

There is one other thing, since it is semantics that are being considered before the correct operation of the system.

In General Settings, we see the option to Pause on Task Switch. If we want to be notified by a popup from another program, but we do not want to stop the plane flying. Let's say, when it's dinner time for example.

We make sure Pause on Task Switch is checked and the simulation carries on when we get the message "Dinner's Ready!"

If we want the simulation to stop when dinner is ready, we uncheck Pause on Task Switch. So we come back from dinner and the sim has not crashed into a mountain.

If we are using Pause on Task Switch to fix a problem with a program calling out when we do not want it, we have lost the proper use of the setting, it is occupied by our fault.

 

Edited by SteveW

Steve Waite: Engineer at codelegend.com

Share this post


Link to post
Share on other sites
Posted (edited)

I'm not arguing all day. i'm simply spelling out facts.

I have provided a proper explanation regarding the use of that setting that shows it fixes nothing.

To say it is a fix is incorrect, I would go with "OP is happy with work-around" but it is not OK to say fixed.

 

We see "problem fixed" when it is not.

Such as "I deleted the addon airport ABCD and the CTD stopped, so it is fixed"!

It might not be fixed. It could be the system is mangled and the extra complex ABCD airport can't run on the system.

So  ABCD get's a bad name. I could go on. But "fixed" must be used carefully.

Edited by SteveW

Steve Waite: Engineer at codelegend.com

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...