Jump to content

ah2511

P3Dv5.1 and VR

Recommended Posts

47 minutes ago, YoYo said:

Someone test 5.1 HF1 in VR maybe?

Something new here?

flying now, first impressions v good, no pixellation of skylines yet, no strange 'auras' around trees, very smooth and nice skies. i'll keep testing in different locations and seasons etc.

auto exposure works in vr now

Edited by peteregan3
  • Like 2

Share this post


Link to post

Sounds good! TY!


Webmaster of yoyosims.pl.
Yoyosimsbanner.gif
Win 10 64, i9 9900k, RTX 3090 24Gb, RAM32Gb, SSD M.2 NVMe, Predator XB271HU res.2560x1440 27'' G-sync, Sound Blaster Z + 5.1, TiR5 [MSFS, P3Dv5, DCS, RoF, Condor, IL-2 CoD/BoX] VR fly only: HP Reverb v2

Share this post


Link to post
On 11/19/2020 at 6:20 PM, peteregan3 said:

hi

apart from the Robinson i ONLY use 3rd party aircraft so i don't think it's that.

maybe you need to have a look at your settings, here's what i've found applies to MY system using VR:

Autogen draw distance is the biggest framerate hit - set it to LOW.

Turn OFF dynamic reflections - they aren't needed with PBR models.

Higher pixel densities affect latency when looking at panels.

Tailor your settings to your aircraft - If flying a complex jetliner turn autogen buildings off and trees to low etc.

if you have a decent graphics card you can set opaque shadow texture size to  4096, vc texture size to 4096, high res textures to ON, and use TEXTURE_SIZE_EXP=9 in your config and the sim looks lovely.

here's the display settings i use for High Performance Aircraft.

Display

Image and Texture Quality

FXAA:  
Off
AA:  
4xSSAA
Texture Filtering:  
Anisotropic 16x
Texture Resolution:  
Ultra (4096x4096)
Dynamic Texture Streaming:  
Off

Full Screen Settings

Black-out Desktop:  
[1]
Auto-fill Main View:  
[1]

Frame Rate Controls

VSync:  
Off
Triple Buffering:  
Off
Target frame rate:  
42

View and Panel Settings

Variable Refresh Rate:  
Off
Wide-view Aspect Ratio:  
[0]
Mipmap VC Panels:  
On
2-D panel transparency (%):  
0


 

World

Terrain

Level of detail radius:  
High
Tessellation Factor:  
Ultra
Mesh resolution:  
19 m
Texture resolution:  
7 cm
Use high-resolution terrain textures  
Off

Scenery Objects

Scenery complexity:  
Normal
Autogen and scenery draw distance:  
Low
Autogen vegetation density:  
Sparse
Autogen building density:  
None
Dynamic 3D Autogen Vegetation:  
Off

Water and Bathymetry

Water Detail:  
Low
Enable Bathymetry:  
Off

Reflections

Clouds:  
Off
Terrain:  
Off
User Vehicle:  
On
Vegetation:  
Off
SimObjects:  
Off
Buildings:  
Off

Special Effects

Special effects detail:  
Low
Special effects distance:  
Low

Weather

Cloud draw distance:  
80 miles / 128 km
Cloud coverage density:  
Maximum
Volumetric Fog  
On
Turbulence and thermal effects  
On
Windshield Effects  
On
Thermal visualization:  
None
Rate at which weather changes over time:  
No changes
Enhanced Atmospherics (Beta)  
On
Cloud Resolution  
Low
Godrays  
On


 

Lighting

Lighting

HDR lighting  
On
Auto Exposure:  
Off
Brightness:  
0,85
Bloom:  
0,00
Saturation:  
0,65

Lighting

Dynamic Reflections:  
Off
Dynamic Lighting:  
On
Aircraft landing lights illuminating ground:  
On
Lens flare:  
On

Shadows

Shadow Quality:  
Medium
Shadow Draw Distance:  
High

Object Shadows

Internal Vehicle Cast:  
On
Internal Vehicle Receive:  
On
External Vehicle Cast:  
On
External Vehicle Receive:  
On
SimObjects Cast:  
Off
SimObjects Receive:  
On
Vegetation Cast:  
Off
Vegetation Receive:  
On
Buildings Cast:  
Off
Buildings Receive:  
On
Particles:  
Off
Cloud Shadow Cast:  
Off
Terrain Shadow Cast:  
Off
NoShadow Flagged Content:  
Off

 

Thanks, will try these tonight when I install new HF.

I tested v5.1 last night again, and VR experience in far worse than in v4, it's unflyable even with default aircrafts with EA on. EA is the only reason I would use v5, but with it fps is around 50-60 (truesky clouds on high), and in VR fps is 50% worse logically, so around 25 usually, a stutter fest. I'm using single pass method in the options, and also tried SteamVR vs Oculus, no difference. Using moderate settings for autogen, both trees and buildings are on normal (sliders on the middle), autogen visilibity low. I really don't want to fly without autogen as I'm using FTX Global, and also I don't wanna use EA clouds on Low, as visual immersion is the key with VR, can't really see the point of flying around white blurry puffs. 🙂
 In XP11 I can achieve 40fps constantly, and with simple script, fps is locked to 40 with forced ASW, it's super smooth.

Edited by Pe11e

Advertising links removed.  Cannot advertise in signature.

Share this post


Link to post

WindowsMixedReality VR Single pass mode

I see within VR Singlepass all the dynamic lights are rendered wrong. It is like they are rendered in one eye (I mean it is left) completely (as it should) and in the other eye as follow, depending on the angle/distance from the lights:

  • No dyn light visible in one eye (thought it is the right eye)
  • Dyn Light partially rendered (like they become "cut off" to the right sight of the lights

This is visible at Dyn lights from airports (Like EDDF, LEPA, etc.) and on Addon AI planes like those from OCI AIGAIM I am using. Especially the Logo lights are very good visible and wrong rendered.

This is visible at all FPS ranges, also above 200FPS (Test FALE Airport with DynLights but less demanding on GPU).

I tested all possible SteamVr Modes with no influence on this (Legacy Reprojection mode on/off, Motion Smoothing Enabled, Disabled, Forced on, different SS settings with ranges between 75% - 200%)

Thanks for any feedback.

System specs

Prepar3D_v5_Academic_5.1.12.26829

Edition Windows 10 Home
Version 20H2
Installed on 20201023
OS Build 19042.630
Windows Feature Experience Pack 120.2212.31.0

Latest Nvidia Drivers

i9 10900K @ 5.2 Ghz | HT OFF | 1.32V
Mainboard ASUS ROG Maximus XII Formula Z490
32 GB RAM 3600 Mhz Corsair Vengeance | 4x8GB
RTX 3090 24GB
32" Samsung UHD Monitor using 4k
Custom Water Cooling | 2x 360MM | 1x 240MM Radiator
HP Reverb v2 VR HMD | Steam VR

Main Addons

ASP3D | BETA
FSRGW
ChasePlane | Via ORBX
FSReborn Prof.
GSX 2
FSUIPC6
AIGAIM | Latest Version
SODE | Latest Version
MultiCrewExperience | Latest Version
Aerosoft Airbus A330 | Latest Version
Aerosoft Airbus A320/321 | Latest Version
PMDG 747/748 | Latest Version
QW787 | Latest Version
FSLABS A320X | Latest Version
FSLABS A321X | Latest Version
Navigraph Charts
ORBX Base
ORBX LC
ORBX TE NL
ORBX TE NCA
ORBX Regions
ORBX HD Buildings
ORBX HD Trees V1 & V2
REALTURB | All Continents
+200 Addon Aiports | via .xml method added

 

Share this post


Link to post
10 hours ago, Pe11e said:

Thanks, will try these tonight when I install new HF.

I tested v5.1 last night again, and VR experience in far worse than in v4, it's unflyable even with default aircrafts with EA on. EA is the only reason I would use v5, but with it fps is around 50-60 (truesky clouds on high), and in VR fps is 50% worse logically, so around 25 usually, a stutter fest. I'm using single pass method in the options, and also tried SteamVR vs Oculus, no difference. Using moderate settings for autogen, both trees and buildings are on normal (sliders on the middle), autogen visilibity low. I really don't want to fly without autogen as I'm using FTX Global, and also I don't wanna use EA clouds on Low, as visual immersion is the key with VR, can't really see the point of flying around white blurry puffs. 🙂
 In XP11 I can achieve 40fps constantly, and with simple script, fps is locked to 40 with forced ASW, it's super smooth.

hi 

do you get good framerates with EA off?

oculus debug tool has options for showing performance information in your headset while you fly, might be worth testing various sim settings whilst watching how they affect your vr performance.

for scenery, if you tick the box 'use high resolution terrain textures' stick to these rules (posted by a LM dev a while ago)

For default 256:
HIGH_RESOLUTION_TERRAIN_TEXTURES=0
TEXTURE_SIZE_EXP=8 (or not set)

For 512:
HIGH_RESOLUTION_TERRAIN_TEXTURES=1
TEXTURE_SIZE_EXP=9 (or not set)

For 1024:
HIGH_RESOLUTION_TERRAIN_TEXTURES=1
TEXTURE_SIZE_EXP=10

Please do not use these setting combinations as they may cause problems:

HIGH_RESOLUTION_TERRAIN_TEXTURES=0
TEXTURE_SIZE_EXP=9

HIGH_RESOLUTION_TERRAIN_TEXTURES=0
TEXTURE_SIZE_EXP=10

HIGH_RESOLUTION_TERRAIN_TEXTURES=1
TEXTURE_SIZE_EXP=8

 

also, it's a long shot but in your simulator SOUND menu check that the devices are not just left as 'default primary device', assign to the specific sound devices you are using. 

this makes a difference on my system.

all the best, pete.

 

Edited by peteregan3

Share this post


Link to post
11 minutes ago, peteregan3 said:

hi 

do you get good framerates with EA off?

oculus debug tool has options for showing performance information in your headset while you fly, might be worth testing various sim settings whilst watching how they affect your vr performance.

also, it's a long shot but in your simulator SOUND menu check that the devices are not just left as 'default primary device', assign to the specific sound devices you are using. 

this makes a difference on my system.

all the best, pete.

 

Yes, With EA on I have now near the same FPS like without but..,. Personally I prefer to turn it off for VR flying.


Webmaster of yoyosims.pl.
Yoyosimsbanner.gif
Win 10 64, i9 9900k, RTX 3090 24Gb, RAM32Gb, SSD M.2 NVMe, Predator XB271HU res.2560x1440 27'' G-sync, Sound Blaster Z + 5.1, TiR5 [MSFS, P3Dv5, DCS, RoF, Condor, IL-2 CoD/BoX] VR fly only: HP Reverb v2

Share this post


Link to post
3 minutes ago, YoYo said:

Yes, With EA on I have now near the same FPS like without but..,. Personally I prefer to turn it off for VR flying.

same here, no FPS hit. i love the look of the clouds in standard weather (but not the spinning!) but EA gives a certain 'feel' which i like also, really works well with  pbr textures. i find auto exposure too harsh for the daytime but amazing at night with EA.

Share this post


Link to post
3 hours ago, mpo910 said:

WindowsMixedReality VR Single pass mode

I see within VR Singlepass all the dynamic lights are rendered wrong. It is like they are rendered in one eye (I mean it is left) completely (as it should) and in the other eye as follow, depending on the angle/distance from the lights...

 

Its a single pass "feature" not for solving according me. You will see all lights in stereo mode when the picture is randered for two screens, not like in single pass for one only (and double virtually for both after this).


Webmaster of yoyosims.pl.
Yoyosimsbanner.gif
Win 10 64, i9 9900k, RTX 3090 24Gb, RAM32Gb, SSD M.2 NVMe, Predator XB271HU res.2560x1440 27'' G-sync, Sound Blaster Z + 5.1, TiR5 [MSFS, P3Dv5, DCS, RoF, Condor, IL-2 CoD/BoX] VR fly only: HP Reverb v2

Share this post


Link to post
11 hours ago, peteregan3 said:

hi 

do you get good framerates with EA off?

oculus debug tool has options for showing performance information in your headset while you fly, might be worth testing various sim settings whilst watching how they affect your vr performance.

for scenery, if you tick the box 'use high resolution terrain textures' stick to these rules (posted by a LM dev a while ago)

For default 256:
HIGH_RESOLUTION_TERRAIN_TEXTURES=0
TEXTURE_SIZE_EXP=8 (or not set)

For 512:
HIGH_RESOLUTION_TERRAIN_TEXTURES=1
TEXTURE_SIZE_EXP=9 (or not set)

For 1024:
HIGH_RESOLUTION_TERRAIN_TEXTURES=1
TEXTURE_SIZE_EXP=10

Please do not use these setting combinations as they may cause problems:

HIGH_RESOLUTION_TERRAIN_TEXTURES=0
TEXTURE_SIZE_EXP=9

HIGH_RESOLUTION_TERRAIN_TEXTURES=0
TEXTURE_SIZE_EXP=10

HIGH_RESOLUTION_TERRAIN_TEXTURES=1
TEXTURE_SIZE_EXP=8

 

also, it's a long shot but in your simulator SOUND menu check that the devices are not just left as 'default primary device', assign to the specific sound devices you are using. 

this makes a difference on my system.

all the best, pete.

 

Hi,

I will try changing sound devices in the options, will select Rift S instead of default. Who knows, P3D is a strange beast.
Last night I did another test, and I was stunned how bad fps was, 15 to 25 with default Cub, medium settings for scenery, EA on, single pass. More stuff I change, fps is getting worse. When I turn EA off, fps was fine, but visuals simply are not acceptable for me. I will test also cfg tweaks, but as I don't have so much time lately since I have more work to do regarding soundpacks, I'm kinda losing my patience with P3D in VR. So I will either use v4 or stay with XP11 for my private simming needs. 


Advertising links removed.  Cannot advertise in signature.

Share this post


Link to post
On 11/12/2020 at 9:20 PM, mpo910 said:

OK understand.

Try also:

When in VR, Start P3D. VR ON, set your HMD on. Take your HP Reverb controller. Press Thumbstick". IN VR you see a menu. Go to graphics and  with the 4 options:

SteamVR per app setting

Motion Vector

Auto

Disabled

 Press thumbstick and watch the results. You have to turn the menu off by pressing the thumbstick to see the best performance. 

I tried this Today. The fact, I didnt know this option in WMR (personally I dont use controller) - but it's not helping for MR on 3090 and ultra water. I tried all options with MR in SteamVR and WMR directly. This ultra water settings is a problem.

Edited by YoYo
  • Like 1

Webmaster of yoyosims.pl.
Yoyosimsbanner.gif
Win 10 64, i9 9900k, RTX 3090 24Gb, RAM32Gb, SSD M.2 NVMe, Predator XB271HU res.2560x1440 27'' G-sync, Sound Blaster Z + 5.1, TiR5 [MSFS, P3Dv5, DCS, RoF, Condor, IL-2 CoD/BoX] VR fly only: HP Reverb v2

Share this post


Link to post

Btw. someone has it (Envshade) https://secure.simmarket.com/toga-projects-envshade-p3d.phtml and use for VR flying with P3Dv5.1?

Id like to know how the water looks with this in VR (but high or less water settings in P3D). Default water (with REX Texture direct even) looks very poor in VR, it has very strange 3D effect and plane on the water looks like in the "air". Ultra water is ok but its unplayble for me (big problem with Motion reprojection, FPS are jumping a lot). 

I used PTA for P3Dv4.5 but now owner of PTA completely left this market so no any update for P3Dv5.

Maybe water from Envshade and his shaders looks better than default?

 

Edited by YoYo

Webmaster of yoyosims.pl.
Yoyosimsbanner.gif
Win 10 64, i9 9900k, RTX 3090 24Gb, RAM32Gb, SSD M.2 NVMe, Predator XB271HU res.2560x1440 27'' G-sync, Sound Blaster Z + 5.1, TiR5 [MSFS, P3Dv5, DCS, RoF, Condor, IL-2 CoD/BoX] VR fly only: HP Reverb v2

Share this post


Link to post
4 hours ago, YoYo said:

Btw. someone has it (Envshade) https://secure.simmarket.com/toga-projects-envshade-p3d.phtml and use for VR flying with P3Dv5.1?

Id like to know how the water looks with this in VR (but high or less water settings in P3D). Default water (with REX Texture direct even) looks very poor in VR, it has very strange 3D effect and plane on the water looks like in the "air". Ultra water is ok but its unplayble for me (big problem with Motion reprojection, FPS are jumping a lot). 

I used PTA for P3Dv4.5 but now owner of PTA completely left this market so no any update for P3Dv5.

Maybe water from Envshade and his shaders looks better than default?

 

i used envshade with no problems prior to 5.1, but now with EA i  just get a white cloudscape: no panels, no plane, nothing, as though you are looking into fog with no way out!

had to reinstall the P3D client to fix it, tried it twice but now uninstalled it as unuseable for me.

one other person reported the same problem on their forum but i havn't looked into it further.

 

EDIT apparently there's a fix  https://www.togaprojects.com/forum/envshade/single-pass-vr

Edited by peteregan3
  • Like 1

Share this post


Link to post
On 11/21/2020 at 5:45 PM, mpo910 said:

WindowsMixedReality VR Single pass mode

I see within VR Singlepass all the dynamic lights are rendered wrong. It is like they are rendered in one eye (I mean it is left) completely (as it should) and in the other eye as follow, depending on the angle/distance from the lights:

  • No dyn light visible in one eye (thought it is the right eye)
  • Dyn Light partially rendered (like they become "cut off" to the right sight of the lights

This is visible at Dyn lights from airports (Like EDDF, LEPA, etc.) and on Addon AI planes like those from OCI AIGAIM I am using. Especially the Logo lights are very good visible and wrong rendered.

This is visible at all FPS ranges, also above 200FPS (Test FALE Airport with DynLights but less demanding on GPU).

I tested all possible SteamVr Modes with no influence on this (Legacy Reprojection mode on/off, Motion Smoothing Enabled, Disabled, Forced on, different SS settings with ranges between 75% - 200%)

Thanks for any feedback.

System specs

Prepar3D_v5_Academic_5.1.12.26829

Edition Windows 10 Home
Version 20H2
Installed on 20201023
OS Build 19042.630
Windows Feature Experience Pack 120.2212.31.0

Latest Nvidia Drivers

i9 10900K @ 5.2 Ghz | HT OFF | 1.32V
Mainboard ASUS ROG Maximus XII Formula Z490
32 GB RAM 3600 Mhz Corsair Vengeance | 4x8GB
RTX 3090 24GB
32" Samsung UHD Monitor using 4k
Custom Water Cooling | 2x 360MM | 1x 240MM Radiator
HP Reverb v2 VR HMD | Steam VR

Main Addons

ASP3D | BETA
FSRGW
ChasePlane | Via ORBX
FSReborn Prof.
GSX 2
FSUIPC6
AIGAIM | Latest Version
SODE | Latest Version
MultiCrewExperience | Latest Version
Aerosoft Airbus A330 | Latest Version
Aerosoft Airbus A320/321 | Latest Version
PMDG 747/748 | Latest Version
QW787 | Latest Version
FSLABS A320X | Latest Version
FSLABS A321X | Latest Version
Navigraph Charts
ORBX Base
ORBX LC
ORBX TE NL
ORBX TE NCA
ORBX Regions
ORBX HD Buildings
ORBX HD Trees V1 & V2
REALTURB | All Continents
+200 Addon Aiports | via .xml method added

 

I have the same problem. Do you know if LM is aware?

Share this post


Link to post
2 hours ago, ah2511 said:

I have the same problem. Do you know if LM is aware?

I at least posted this on their LM Support Forum. You should reply there that you have the same issue as well. Here is the link and it would be great if you post your issue also. Because the more are posting, the more attention we get.

Thanks a lot.

Marcus

https://www.prepar3d.com/forum/viewtopic.php?f=6312&t=140461

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    34%
    $8,560.00 of $25,000.00 Donate Now
×
×
  • Create New...