Sign in to follow this  
skully

FSX - Is Autogen Holding Me Back?

Recommended Posts

Hey all, thought I would post this before heading off to work.My comments concern Autogen within FSX. First, lemme start off with my system. I have a/an...AMD Athlon 64 FX60 (939)Asus A8N32 SLI Deluxe3GB Corsair XMS (400mhz)XFX Nvidia 8800GTX 768mbOnboard AudioNow, I know that the performance I'm getting would be better if I had a AM2 based CPU, but for a 939, this is as fast as it gets.For graphics, I have everything all the way to the right. Even water is maxed out. On a side note, this doesn't look very realistic, but thats another post for another time.I have ground vehicles, boats, and ferries disabled. Commercial, GA, and Airport Ground Traffic are kept to a minimum. Autogen is completely turned off. My screen resolution is set to 3840x1024x32, I'm using a Matrox Triple Head.FPS are locked at 24. I've read a few times that the human eye can't distinguish anything above that.Autogen seems to be the thorn in the paw, so to speak. Even when set to sparse, it seems to drag down performance. I've tried reducing the size of the textures, not only for Autogen, but also for runways and taxiways. I've also tried the tweaks found here:http://www.fox-fam.com/wordpress/?page_id=41When autogen is completely disabled, flying is smooth and frames stay at 24. When enabled, they fluxuate between 24 and 7.Am I going to have to wait to upgrade to a more powerful processor? Or have any posters here managed to get FSX to run with more Autogen present? Its not a total deal breaker. I'm still using FS9. I just think there are some aspects in FSX that make me want to stick with it. The clouds, the crispness of the stock airport grounds, etc.What say you readers of Avsim?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I agree about the water-for me it only looks realistic with sliders to the right when flying over the ocean-for rivers and lakes I leave it just one notch to the right and for me this looks more realistic .As for autogen-yes I find it to be the biggest performance drain.We will have to see what Aces comes up with in their patch.http://mywebpages.comcast.net/geofa/pages/rxp-pilot.jpg

Share this post


Link to post
Share on other sites

Autogen settings in FSX display 1000% higher numbers of polygons than the same setting in FS2004.We wanted forests and dense cities - and Microsoft gave them to us.You might try one of the tweaks in the FSX.cfg file to being the autogen down closer to FS2004 levels.Actually my biggest complaint about autogen is not the performance hit, but the impact of all those trees on flying approaches.The way autogen and the airport polygons work often results in 70-100 foot high trees right at the airport fenceline.This isn't such a big deal for major airports with 1000-2000 foot clear zones past the runway ends.But for small 3,000 and 4,000 foot strips with only a couple hundred feet clearance - it forces landings to be dives for the runway and a sharp pullup.

Share this post


Link to post
Share on other sites

Flakchak wroteQuoteNow, I know that the performance I'm getting would be better if I had a AM2 based CPU, but for a 939, this is as fast as it gets.UnQuoteFlakchak, the AMD Athlon 64 dual core 939 socket processors and the AMD Athlon 64 dual core 940 AM2 socket processors are pretty much the same, and whilst the 940 AM2 comes with DDR2 memory this is a dubious "advantage" since AMD Athlon 64 processors especially benefit from low latency RAM sticks and DDR2 has higher latency than DDR. In fact an equivalent AMD Athon 64 processor may actually be slower in a 940 AM2 motherboard than in a 939 board. Best and Warm RegardsAdrian Wainer

Share this post


Link to post
Share on other sites

>Hey all, thought I would post this before heading off to>work.>>My comments concern Autogen within FSX. First, lemme start>off with my system. I have a/an...>>AMD Athlon 64 FX60 (939)>Asus A8N32 SLI Deluxe>3GB Corsair XMS (400mhz)>XFX Nvidia 8800GTX 768mb>Onboard Audio>>Now, I know that the performance I'm getting would be better>if I had a AM2 based CPU, but for a 939, this is as fast as it>gets.>>For graphics, I have everything all the way to the right. >Even water is maxed out. On a side note, this doesn't look>very realistic, but thats another post for another time.>>I have ground vehicles, boats, and ferries disabled. >Commercial, GA, and Airport Ground Traffic are kept to a>minimum. Autogen is completely turned off. My screen>resolution is set to 3840x1024x32, I'm using a Matrox Triple>Head.>>FPS are locked at 24. I've read a few times that the human>eye can't distinguish anything above that.>>Autogen seems to be the thorn in the paw, so to speak. Even>when set to sparse, it seems to drag down performance. I've>tried reducing the size of the textures, not only for Autogen,>but also for runways and taxiways. I've also tried the tweaks>found here:>>http://www.fox-fam.com/wordpress/?page_id=41>>When autogen is completely disabled, flying is smooth and>frames stay at 24. When enabled, they fluxuate between 24 and>7.>>Am I going to have to wait to upgrade to a more powerful>processor? Or have any posters here managed to get FSX to run>with more Autogen present? Its not a total deal breaker. I'm>still using FS9. I just think there are some aspects in FSX>that make me want to stick with it. The clouds, the crispness>of the stock airport grounds, etc.>>What say you readers of Avsim?>There are a number of tweaks that could help you, check Ryan's sticky post in the PMDG Forum. The 3 main ones, that will help you are.1. Rename the extension (Don't delete) the default.xml file in the autogen folder.2. Decrease the number of cells for autogen trees and buildings to 800. in the fsx.cfg file. The fields are TERRAIN_MAX_AUTOGEN_TREES_PER_CELLTERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL3 Increase the Texture_Bandwidth_Mult for your system between 220-250.There are others that will help in Ryan's post!

Share this post


Link to post
Share on other sites

>I agree about the water-for me it only looks realistic with>sliders to the right when flying over the ocean-for rivers and>lakes I leave it just one notch to the right and for me this>looks more realistic .>Seems more than not, I just like leaving the water OFF.Yesterday's real weather, KSLC/KPVUFSX- Water & autogen off:http://forums.avsim.net/user_files/167625.jpgFS9 - Water & autogen on:http://forums.avsim.net/user_files/167626.jpg

Share this post


Link to post
Share on other sites

Geofa and LAdamson,I'm glad I'm not the only one who doesn't like the water. I was tooling around KCHS, and was flying up and down the Cooper and Ashley. The water, both the ocean and river, just looked wrong. It was more suited to the clear Caribbean Island water then the murkey brakish river water.tf51d,Thanks for those tweaks. I had the tweaks in my *.CFG file, but the numbers were much higher. I'll also move the *.XML file to a backup folder.Hope some of those work. I took a small hop from KROC to KELM and it was nice approaching the airport through the valley. It would be even nicer if there were some trees thrown into the mix.===I'm really starting to like flying with the virtual cockpit only. Since setting up the Matrox Triple Head and my 3 Samsung 940BXs. I'm thinking about getting really creative and setting up 3 more on my right, and possibly 2 more on my left. My money could be better spent... but I just don't know the value of a dollar, hehe.

Share this post


Link to post
Share on other sites

You can do better with your FX60.I would consider using Matt Fox's autogendescriptions.spb file.It gave my 939 platform a 20% boost to frame rates without any noticeable loss of visual quality.Also tweak your memory latency as this gave me 8% boost to frames.The only advantage of AM2 over 939 is the memory, but that is, as was said, a pretty nominal difference in terms of real-world performance. AM2 will also run faster cpu's. That would be another advantage if you were to move beyond the FX60.You should be getting better frame rates than that with your FX60. My slightly slower system locks at 24 with Dense autogen, and in most locations gets between 18-24 fps.RhettAMD 3700+ (@2310 mhz), eVGA 7800GT 256 (Guru3D 93.71), ASUS A8N-E, PC Power 510 SLI, 2 GB Corsair XMS 2.5-3-3-8 (1T), WD 250 gig 7200 rpm SATA2, CoolerMaster Praetorian case

Share this post


Link to post
Share on other sites

>You can do better with your FX60.>>I would consider using Matt Fox's autogendescriptions.spb>file.>It gave my 939 platform a 20% boost to frame rates without any>noticeable loss of visual quality.>>Also tweak your memory latency as this gave me 8% boost to>frames.>>The only advantage of AM2 over 939 is the memory, but that is,>as was said, a pretty nominal difference in terms of>real-world performance. AM2 will also run faster cpu's. That>would be another advantage if you were to move beyond the>FX60.>>You should be getting better frame rates than that with your>FX60. My slightly slower system locks at 24 with Dense>autogen, and in most locations gets between 18-24 fps.>>Rhett>>AMD 3700+ (@2310 mhz), eVGA 7800GT 256 (Guru3D 93.71), ASUS>A8N-E, PC Power 510 SLI, 2 GB Corsair XMS 2.5-3-3-8 (1T), WD>250 gig 7200 rpm SATA2, CoolerMaster Praetorian caseRhett,Sounds good. I was missing those tweaks. I'm going to have to wade through my bios settings and see what I can come up with. I'm not overclocking, but I'll dabble with that as well.

Share this post


Link to post
Share on other sites

Once you try out the additional tweeks (default.xml rename had the most dramatic impact on my frames), consider bumping a few of your sliders down a bit. Nudging the level of detail radius or terrain sliders to the left a bit will give more processor power to autogen. Autogen is by far the most processor intensive aspect of FSX.-Paul

Share this post


Link to post
Share on other sites

>>You can do better with your FX60.>>>>I would consider using Matt Fox's autogendescriptions.spb>>file.>>It gave my 939 platform a 20% boost to frame rates without>any>>noticeable loss of visual quality.>>>>Also tweak your memory latency as this gave me 8% boost to>>frames.>>>>The only advantage of AM2 over 939 is the memory, but that>is,>>as was said, a pretty nominal difference in terms of>>real-world performance. AM2 will also run faster cpu's. >That>>would be another advantage if you were to move beyond the>>FX60.>>>>You should be getting better frame rates than that with your>>FX60. My slightly slower system locks at 24 with Dense>>autogen, and in most locations gets between 18-24 fps.>>>>Rhett>>>>AMD 3700+ (@2310 mhz), eVGA 7800GT 256 (Guru3D 93.71), ASUS>>A8N-E, PC Power 510 SLI, 2 GB Corsair XMS 2.5-3-3-8 (1T), WD>>250 gig 7200 rpm SATA2, CoolerMaster Praetorian case>>Rhett,>>Sounds good. I was missing those tweaks. I'm going to have>to wade through my bios settings and see what I can come up>with. I'm not overclocking, but I'll dabble with that as>well.>If your not familiar with adjusting the memory latency, don't try it. You can really lock up your system but good, if you do it wrong!! Your system wo'nt even let you get into the bios. This will force you to reset the bios in Hardware, usually by setting a jumper. This will put you back to factory defaults, and you'll still have to make the adjustments to match your original settings!

Share this post


Link to post
Share on other sites

Ok, got home from work and fired up the puter.Moved the default.xml file in the autogen folder to a "backup" subdir.Downloaded Matt Fox's AutogenDescriptions.spb file and sent the old one to the "backup" subdir.Decrease the number of cells for autogen trees and buildings to 800 and 700 in the fsx.cfg file. TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=800TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=700These had been set way way higher. This is a good base setting for my system, and I may try and work in higher numbers while trying to maintain performance.Increased the Texture_Bandwidth_Mult to 250. This had been set to 400.I moved my water effects back down, just because I didn't like the look of the high end stuf. I took it down to 2 steps above off.Level of Detail Radius: LargeMesh Complexity: 100Mesh Resolution: 10mTexture Resolution: 1mScenery Complexity: Extremely DenseAutogen: All the way to the right (Extremely Dense)Cloud Draw Distance: 70nmDetailed CloudsCloud Coverage Density: MaximumAirline Traffic Density: 25%GA Traffic Density: 15%Airport Vehicle Density: First SettingRoad Vehicles, Ships, Liesure Boats: all 10%Frames are steady at 24. They actually go anywhere from 24.1 to 22.I took off from KROC, flew north over the city and back around. Did a touch and go from KROC and then followed the highway and backroads back to Batavia (KGVQ). Landed and Taxied.At first I was wondering where all the autogen was. There were really no autogen buildings. Only trees, and they were only in parks. Then when I headed south, the trees were everywhere, and it looked very nice.It should also be noted. I reduced the texture sizes on different aspects to 50% and 25%. I am also using FSGenesis North American Terrain Mesh for FSX, as well as the FSGenesis FSX Landclass BETA.One last question: Is there any way to reduce the size of the VASI lights at the airports? They are unbelievably large orbs, and it really bothers me.Thanks for everyone's help.

Share this post


Link to post
Share on other sites

>Moved the default.xml file in the autogen folder to a "backup">subdir.>Mesh Resolution: 10m>At first I was wondering where all the autogen was. There>were really no autogen buildings. Only trees, and they were>only in parks. Then when I headed south, the trees were>everywhere, and it looked very nice.I think deactivating the default.xml completely removes a lot of autogen, especially trees in urban areas (if I remember right). Try activating this file and see what your frames are.Also, I would set mesh resolution to only 38m as this is normally the highest resolution of the standard and most addon meshes (unless your FSGenesis mesh is at 12m or LOD12 resolution.When comparing frame rates you should also consider your huge viewport area (come on - most people are happy flying with a SINGLE monitor and frame rates above 15 LOL).Regards

Share this post


Link to post
Share on other sites

>I think deactivating the default.xml completely removes a lot>of autogen, especially trees in urban areas (if I remember>right). Try activating this file and see what your frames>are.I'll try that as well and report back.>Also, I would set mesh resolution to only 38m as this is>normally the highest resolution of the standard and most addon>meshes (unless your FSGenesis mesh is at 12m or LOD12>resolution.When I was using the stock scnerey, I had the mesh resolution set at 38m. Now that I have the FSGenesis Mesh, it needs to be set a 10m to take advangtage of it.>When comparing frame rates you should also consider your huge>viewport area (come on - most people are happy flying with a>SINGLE monitor and frame rates above 15 LOL).Very true... maybe if I disable the other two monitors my framerates will triple! :D

Share this post


Link to post
Share on other sites

>>When I was using the stock scnerey, I had the mesh resolution>set at 38m. Now that I have the FSGenesis Mesh, it needs to>be set a 10m to take advangtage of it.>Only if you have 10m mesh installed. Most FSGenesis mesh is 76m or 38m. If you don't have any 10m products then there is no point in setting your mesh slider at 10m.There was discussion some time back about how setting the mesh slider lower when you had no need to, was harmful to performance, but I have never tested this myself.RhettAMD 3700+ (@2310 mhz), eVGA 7800GT 256 (Guru3D 93.71), ASUS A8N-E, PC Power 510 SLI, 2 GB Corsair XMS 2.5-3-3-8 (1T), WD 250 gig 7200 rpm SATA2, CoolerMaster Praetorian case

Share this post


Link to post
Share on other sites

you can try RealSky 3 for FSX. It also shrinks the VASI and gives them a more "diffuse" aspect.

Share this post


Link to post
Share on other sites

>>>>When I was using the stock scnerey, I had the mesh>resolution>>set at 38m. Now that I have the FSGenesis Mesh, it needs to>>be set a 10m to take advangtage of it.>>>>Only if you have 10m mesh installed. Most FSGenesis mesh is>76m or 38m. If you don't have any 10m products then there is>no point in setting your mesh slider at 10m.>>There was discussion some time back about how setting the mesh>slider lower when you had no need to, was harmful to>performance, but I have never tested this myself.>>Rhett>>AMD 3700+ (@2310 mhz), eVGA 7800GT 256 (Guru3D 93.71), ASUS>A8N-E, PC Power 510 SLI, 2 GB Corsair XMS 2.5-3-3-8 (1T), WD>250 gig 7200 rpm SATA2, CoolerMaster Praetorian caseNot the new US FSX mesh, which is suppose to be 9.6m in the US.

Share this post


Link to post
Share on other sites

>>Not the new US FSX mesh, which is suppose to be 9.6m in the>US. Well I did say "most" :) I forgot how detailed the new mesh was. 9.6 for the whole USA is getting pretty detailed!RhettAMD 3700+ (@2310 mhz), eVGA 7800GT 256 (Guru3D 93.71), ASUS A8N-E, PC Power 510 SLI, 2 GB Corsair XMS 2.5-3-3-8 (1T), WD 250 gig 7200 rpm SATA2, CoolerMaster Praetorian case

Share this post


Link to post
Share on other sites

Seems like in previous versions, you could shrink the VASI with a few settings in your FS.CFG file. Am I way off here, or wasn't that the case?RhettAMD 3700+ (@2310 mhz), eVGA 7800GT 256 (Guru3D 93.71), ASUS A8N-E, PC Power 510 SLI, 2 GB Corsair XMS 2.5-3-3-8 (1T), WD 250 gig 7200 rpm SATA2, CoolerMaster Praetorian case

Share this post


Link to post
Share on other sites

I understand your dilema Joe.On my system I get ripping great frame rates and perfectly smooth operation from FSX with the autogen turned OFF. In fact with the autogen disabled FSX is the smoothest sim I've ever used.When I enable autogen FSX turns into a stuttering choppy mess and it runs about 7 to 9 fps average.This thread has enticed me to try some of the tweaks found at PMDG's excellent FSX FPS guide by Ryan Maziarz. Thanks for the links guys!http://ops.precisionmanuals.com/wiki/FSX_F...uide#CFG_tweaksI gained 7 to 8 fps by using these tweaks which may not sound like much but when your running at 7 fps and then have it go to 15 to 16 fps with autogen set at normal, that's a meaningful improvement effectively doubling my frame rates.The exact tweaks I used from Ryan's guide were,1. Fiber Frame Time Fraction2. Texture Bandwidth Mult3. Autogen Density4. AutogenDescriptions.spbThese have proven to be effective on my system. More tweaking and adjustments to do but so far so good.Cheers!Homebuilt:P4 Prescott 3.2 gigRadeon X800 Pro 256 mbASRock P4V88 mobo1 gig Corsair Pro Series RAM120 SATA HDAudigy 2 Sound19" CRT Monitor

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this