Archived

This topic is now archived and is closed to further replies.

McCrash

FSX and GTX295

Recommended Posts

Amazing how much trouble it is to get FSX to run. With my older system with a 4870 1GB card FSX runs great. This GTX295 runs my games great, but NOT FSX.In FSX I get spikes that come and go. I tried 5 freak'n driver releases and still have these spikes. I run the driver settings at the default level in novidia control panel.I tired turning of the Phyx setting too and even tried differenet settings in FSX. What gives?This is with FSX SP2.Any ideas would be appreciated. Just can't wait for the new ATI cards. :(

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Amazing how much trouble it is to get FSX to run. With my older system with a 4870 1GB card FSX runs great. This GTX295 runs my games great, but NOT FSX.In FSX I get spikes that come and go. I tried 5 freak'n driver releases and still have these spikes. I run the driver settings at the default level in novidia control panel.I tired turning of the Phyx setting too and even tried differenet settings in FSX. What gives?Any ideas would be appreciated. Just can't wait for the new ATI cards. :(
My rig had the same problem on GTX280. Try to underclock it, than try to underclock the RAM - in my case 1333MHz RAM at 1066MHz solved the issue

Share this post


Link to post
Share on other sites
Amazing how much trouble it is to get FSX to run. With my older system with a 4870 1GB card FSX runs great. This GTX295 runs my games great, but NOT FSX.In FSX I get spikes that come and go. I tried 5 freak'n driver releases and still have these spikes. I run the driver settings at the default level in novidia control panel.I tired turning of the Phyx setting too and even tried differenet settings in FSX. What gives?This is with FSX SP2.Any ideas would be appreciated. Just can't wait for the new ATI cards. :(
Do you have buffer pools enabled in your fsx.cfg? I had major issues with spikes, and as soon as I got rid of the buffer pools, they went away.Bill

Share this post


Link to post
Share on other sites

No I am not using BufferPools. I am not using InfinityMask either. I even let FSX rebuild the fsx.cfg file when trying different releases. I should mention that I am using FSX SP2.Memory speed, interesting. I will have to do some experimentation.

Share this post


Link to post
Share on other sites

I put my 4970 1GB card back in and FSX run just fine. I guess I will have to RMA the card back and see what they say. However I do think the problem is the driver code. Oh well!

Share this post


Link to post
Share on other sites
Disable SLI in the NV control panel and your frame rate spikes will disappear.
I had tried that and still had spikes. So I RMA'd the card so they could check it out.

Share this post


Link to post
Share on other sites

I have GTX 280 and it works great. Desable anti alising and download and use NHANCER for you graphic settings. It will work !

Share this post


Link to post
Share on other sites

I get spikes and flashes in FSX with a 280 card. I've tried to solve it with and without the buffer pool setting and the infinity mask setting. Neither setting made any difference. I use nHancer and it makes no difference, still getting spikes and flashes. I've looked in the Nvidia control panel, there's no setting for SLI. The only time spike and flashes are less of an issue is when I turn down the in-game graphics settings to pre-i7 graphic levels.i7 940Vista 64gtx 280

Share this post


Link to post
Share on other sites
I get spikes and flashes in FSX with a 280 card. I've tried to solve it with and without the buffer pool setting and the infinity mask setting. Neither setting made any difference. I use nHancer and it makes no difference, still getting spikes and flashes. I've looked in the Nvidia control panel, there's no setting for SLI. The only time spike and flashes are less of an issue is when I turn down the in-game graphics settings to pre-i7 graphic levels.i7 940Vista 64gtx 280
What do you mean by 'I turn down the in-game graphics settings to pre-i7 graphic levels'?

Share this post


Link to post
Share on other sites
What do you mean by 'I turn down the in-game graphics settings to pre-i7 graphic levels'?
I lower the autogen level, mesh and texture resolution back to a level as used on my previous computer, at which point I experience far less spiking and artifacting. One thing I have noticed. At the start of a flight session, if I go chase view and rotate around the aircraft about 20 times or so then the artifacting and spiking basically goes away. That's about the best I can describe it.i7 940gtx 280 1gbasus motherboardvista 64

Share this post


Link to post
Share on other sites
I lower the autogen level, mesh and texture resolution back to a level as used on my previous computer, at which point I experience far less spiking and artifacting. One thing I have noticed. At the start of a flight session, if I go chase view and rotate around the aircraft about 20 times or so then the artifacting and spiking basically goes away. That's about the best I can describe it.i7 940gtx 280 1gbasus motherboardvista 64
The problem happens when I go to chase view and rotate. And the more I do it the worse it gets. Anyway card went back to get checked. Seems like the drivers (novidia and ati) are both getting worse.Unified = way to much code.Oh well.

Share this post


Link to post
Share on other sites

Seems like a bad deal alright, considering money spent. It's very strange that I can negate the problem after 20 seconds or so of rotating, but it never should be like that in the first place. I lack the knowledge to ascertain the actual reason; there are so many variables at play. There is definately lot's of flickering at the start of every flight. Whatever textures are surrounding the plane are being drawn in random spikes and flashes. Post the results if you are getting a card replacement.

Share this post


Link to post
Share on other sites
Amazing how much trouble it is to get FSX to run. With my older system with a 4870 1GB card FSX runs great. This GTX295 runs my games great, but NOT FSX.In FSX I get spikes that come and go. I tried 5 freak'n driver releases and still have these spikes. I run the driver settings at the default level in novidia control panel.I tired turning of the Phyx setting too and even tried differenet settings in FSX. What gives?This is with FSX SP2.Any ideas would be appreciated. Just can't wait for the new ATI cards. :(
User Bufferpools. If your Vcard has 1GB, you can use a bufferpool value between 10 000 000 and 100 000 000[bufferPools]PoolSize=10000000

Share this post


Link to post
Share on other sites

Not sure but if this card has 2gig on board, it very well may be an issue if you are running a 32 bit OS. How much on board memory do you have?The spiking, I am not sure about. If you are using XP, it might be worth investigating the /3GB and userva=xxxx switch's used in the boot.ini.If you are already aware of this and the problems that can occur,and understand what these switch's do, then disregard this reply.RegardsBob G

Share this post


Link to post
Share on other sites
Amazing how much trouble it is to get FSX to run. With my older system with a 4870 1GB card FSX runs great. This GTX295 runs my games great, but NOT FSX.In FSX I get spikes that come and go. I tried 5 freak'n driver releases and still have these spikes. I run the driver settings at the default level in novidia control panel.I tired turning of the Phyx setting too and even tried differenet settings in FSX. What gives?This is with FSX SP2.Any ideas would be appreciated. Just can't wait for the new ATI cards. :(
Hi McCrash, Go to the main FSX forum and look for my recent post on a New FSX Optimizer. It will cure "spikes" and "surges" (depending on your definition), probably most effectively in machines which have enough GPU headroom to make them prone to this issue. Give it a try. Between it and using the correct Bufferpools setting, FSX is now fully optimized and maximally smooth. These two moves, plus 64bit OS, were the final touches for me--many are having good luck so far with this utility--I know it has totally improved my installation, and I don't have Vista optimized hardly at all.Noel

Share this post


Link to post
Share on other sites

EVGA sent me a new 295. I will be installing it in a day or two. We shall see if there is an improvement.Their RMA process was fairly easy and the turn around was excellent.

Share this post


Link to post
Share on other sites

Hi thereI have just updated my PC is to the following configuration >Operating System: Windows Vista (64 bit)CPU: Intel Core i7 CPU 965 @ 3.20GHzMemory (RAM): 12.0 GBGraphics Card: Nvidia GeForce GTX 295 (x2, I have two of them - running latest drivers, from the official website, version 182.08)DirectX Version: 10FSX: SP2All is not okay. When flying my PMDG MD11 the system crashes, telling me I am out of memory when I have plenty left! This is the error message I get (see below)Problem signature: Problem Event Name: APPCRASH Application Name: fsx.exe Application Version: 10.0.61355.0 Application Timestamp: 4643ee0a Fault Module Name: PMDG_MD11.DLL Fault Module Version: 10.0.61355.58 Fault Module Timestamp: 49669c84 Exception Code: c0000005 Exception Offset: 001175d1 OS Version: 6.0.6001.2.1.0.768.3 Locale ID: 2057Additional information about the problem: LCID: 2057At the time I was flying with only one card active (in non SLI mode)If I run in SLI mode (which I'm getting means I am using both cards!?) the system crashes before I can get off the ground!Anyone have any idea's into what's going on? Does FSX have a limit of memory it will use, even if I have more!??ThanksKimberly RJ

Share this post


Link to post
Share on other sites

Kimberly:you need to disable SLI to get the most out of FSX. It simply doesn't support Alternate Frame Rendering.

Share this post


Link to post
Share on other sites
Kimberly:you need to disable SLI to get the most out of FSX. It simply doesn't support Alternate Frame Rendering.
In testing it makes no difference into if SLI mode is engaged or not - the system still crashes!

Share this post


Link to post
Share on other sites
In testing it makes no difference into if SLI mode is engaged or not - the system still crashes!
Kimberly,I was browsing through this thread and I have not really been involved, but I have a question for you. Have you tested your memory? Either running OCCT or Prime95 or best of all Memtest? It may be a shot in the dark, but it is possible that memory is faulty on one of your banks. You could also try to remove enough that would leave say 4 gig. You could then test each 4 gig. Just a thought.Bob G

Share this post


Link to post
Share on other sites

Im being told its because FSX is going over 2GB which is causing it to crash...PMDG Support said I can programe FSX to use more then 2GB memory but they did not explain clearly how this could be done, only copying in this linkhttp://msdn.microsoft.com/en-us/library/aa906211.aspxWhich I can make head or tail of.So, as FSX is limited to 2GB and Im going over it, surely increasing its 'limit' to 3GB or 4GB would solve that issue?I have however tested the RAM etc, all running normally.I dont have any spike issues and none of the other issues certain 295 users are having, just crashing when the FSX goes over 2GBKimberly.

Share this post


Link to post
Share on other sites
I dont have any spike issues and none of the other issues certain 295 users are having, just crashing when the FSX goes over 2GBKimberly.
So why don't you adapt your 32bit OS to use 3GB of address space for FSX? Remember, nothing to do with memory.In your boot.ini, put /3GB /userva=2760 in the line where other "/" settings are, that is what others recommend.I say, go with 64bit OS.Good luck!

Share this post


Link to post
Share on other sites
User Bufferpools. If your Vcard has 1GB, you can use a bufferpool value between 10 000 000 and 100 000 000[bufferPools]PoolSize=10000000
Bad idea. To much memory reserved for storing textures can make the sim run slower, or give problems no matter who much VRAM your card has. Best thing to do is to leave it at the default and delete the bufferpool setting from the cfg. Trust me, I used to think bufferpools was the best setting and that all people that left it at the default would have the worst texture loading speed but I was so wrong. Recently after reinstalling FSX, brand spankin knew with the only tweaks to it being airspeed, and heading showing up on aircraft labels, the time to display the views (exp. "Virtual Cockpit Zoom 0.60..."), and the affinitymask tweak, I have FSX running at the best it ever has, no bufferpools no nothing. The textures load faster than ever and its smoother than ever as well. Nothing beats clean FSX with no or little tweaks.Everyone read this. It works, and it works very well, clearing many out of memory errors, and causing less graphical glitches, while giving no performance hit. Worst thing that can happen is you uninstalling it if you don't like it.http://forums1.avsim.net/index.php?showtop...amp;hl=cleanmem

Share this post


Link to post
Share on other sites
EVGA sent me a new 295. I will be installing it in a day or two. We shall see if there is an improvement.Their RMA process was fairly easy and the turn around was excellent.
To update ... the second card was 10 times worse ... sent that puppy back too ... now I have a third one on the floor ... but I had send my motherboard back to Asus to have it checked ... have no idea when I will get it back.

Share this post


Link to post
Share on other sites