Jump to content

Archived

This topic is now archived and is closed to further replies.

Squishy

FSX crashes when viewing options in-game

Recommended Posts

Hi all.I've recently gone to FSX after years of FS9.It works OK now, however FSX crashes when scrolling through the rightclick menu (views, etc).The error message says : uiautomationcore.dll.When i don't use the menu, it does not crash.It's very inconvenient though because i need to use the menu for addons etc.. Now i'm running Windows 7 RC and 181.72 nvidia drivers.. so i know its not a fully stable OS (every other game runs 100% perfect though)Anyone else got this error? can't seem to find much info about it.Thanks,Walter

Share this post


Link to post
Share on other sites

I just had the problem again, but this time i the error was different (still happened when i in the right-click menu, though..as always)

This was the error:Problem signature:  Problem Event Name:	BEX  Application Name:	fsx.exe  Application Version:	10.0.61472.0  Application Timestamp:	475e17d3  Fault Module Name:	unknown  Fault Module Version:	0.0.0.0  Fault Module Timestamp:	00000000  Exception Offset:	00000000  Exception Code:	c0000005  Exception Data:	00000008  OS Version:	6.1.7077.2.0.0.256.1  Locale ID:	1033Additional information about the problem:  LCID:	1033

Share this post


Link to post
Share on other sites

Hi,I am getting CTD as well when using the right click menu. I am using the release candidate x64 7100 on an i7 ex58 Gigabyte MB with ECS 9800 GTX+ 1GB and a matrox triplehead2go with 3x 1280x1024 monitors. I have tried reducing all the sliders to the left, latest driver etc but it still does it. In all other respects it seems to be working much better than XP64.

Share this post


Link to post
Share on other sites

More...I have tried reducing every setting in the Nvidia control panel globally to either off or disabled... still does it.Tried reducing screen size to 1024 and everything off...still does it.Tried compatibility mode down to XP SP2 still does it.Very reproducible bug...Choose Trike, Friday Harbour any time. Once you are underway right click a few times without selecting anything then run the mouse up and down the menu it will take less than 30sec to crash.

Share this post


Link to post
Share on other sites
More...I have tried reducing every setting in the Nvidia control panel globally to either off or disabled... still does it.Tried reducing screen size to 1024 and everything off...still does it.Tried compatibility mode down to XP SP2 still does it.Very reproducible bug...Choose Trike, Friday Harbour any time. Once you are underway right click a few times without selecting anything then run the mouse up and down the menu it will take less than 30sec to crash.
Try disabling Intel enhanced speedstep in your BIOS in case it's enabled and see if it helps.Also, What FSX SP are you ? try SP2 if not already installed

Share this post


Link to post
Share on other sites
Try disabling Intel enhanced speedstep in your BIOS in case it's enabled and see if it helps.Also, What FSX SP are you ? try SP2 if not already installed
Hi,Thanks for the suggestion. I will try that right now and let you know. I am running FSX deluxe with acc.

Share this post


Link to post
Share on other sites

Well I am getting ready to pull the plug on windows 7. I have tried the following:Completely removing all add ons and FSX then reinstalling FSX without any add on or change ... still does it.Tried disabling one by one in the bios: Hyperthread, EIST, C1E ... still getting the fatal error and restart when in the right click menu.Tried removing the nvidia 185.85 driver and letting WIN7 install its own ... still does it.Tried running FSX in compatibility mode XPSP3 ... still does it.Tried only one monitor at 1024x768 ... still does it.Tried turning off or disabling every 3D feature globally in the nvidia panel ... still does it.So where to from here ... probably back to XP64 which has been very stable.If anyone can suggest something else I will try it before using the HD for something else ... X - Plane ;)

Share this post


Link to post
Share on other sites
Try disabling DEP.Guide.
Thanks I'll give it whirl and let you know. It is pretty frustrating though as FSX *seems* to run smoother on WIN 7.

Share this post


Link to post
Share on other sites

Well, two hours later and a fresh install on a new disk. No overclock, disabled DEP and UAC, no antivirus, no nvidia driver, and logged in as admin. Fresh install of FSX ... guest what ... still does it when viewing AI from the right click menu. If I cycle through the AI with the A key no problems. Willing try anything at this stage.

Share this post


Link to post
Share on other sites

Well I used GlovePie to program the F2 and F3 keys as macros to cycle through all AI planes ... i.e. they were acting as key presses and it was fine. This is at least a work around for me. I use GlovePie to control all the instrument switches with three USB keyboards already, so a few more keys is not an issue.Key.LeftAlt + V + M + Right = Key1.F2Down + Down + Down + Down + Down + Right + Down + Enter = Key1.F3Not very elegant I know but it didn't seem to like putting it all on one key?So it is something quite specific to using the mouse to right click.

Share this post


Link to post
Share on other sites

I spoke too soon ... any use of the menu will crash FSX given enough time :(. So I suppose that eliminates looking for something in the mouse/USB software? If I set the number of AI planes really low (i.e. the number of selectable items in the menu) it will take longer to crash. Does that suggest a stack overflow maybe? Using exactly the same hardware setup but on a different HD XP64 has been very stable and does not suffer any of the menu problems :(

Share this post


Link to post
Share on other sites

I have re-installed FSX again but this time only with SP1 and SP2 .. still crashes. Tried an earlier video driver 182.08 ... nope still does it. The only solution it seems is to NOT USE THE MENU WITH THE MOUSE :(

Share this post


Link to post
Share on other sites
Guest abulaafia

I have the same software, same drivers and the same problem :(DEP is not the issue. Seems to be a bug in the dll. Very annoying, it runs so much better on Win7 Problem replicated on another PC with a different graphics card, so its not hardware related.

Share this post


Link to post
Share on other sites
Guest abulaafia
This might help: (on Win7)Mouse Properties | Pointers | Scheme (None)
nice idea, but no. tried that.

Share this post


Link to post
Share on other sites
Guest MaxH

Same stuff here. Made a VATSIM flight tonight and didn't hit any menu items through the trip but as soon as I landed I tried opening a menu and FSX crashed. Sure is annoying as otherwise FSX has been much better on Windows 7 for me.

Share this post


Link to post
Share on other sites
Guest abulaafia

Good to get another report in. Sign up at MS Technet (http://social.technet.microsoft.com/Forums/en/w7itproappcompat/thread/fb1808ff-92f0-478b-9826-f2ed6fbeae97?prof=required) or 7forums (http://www.sevenforums.com/), so they get more feedbackIt is annoying, isn't it. I can fly without problems, as long as I don't touch the menus. Incidentially, I find that after opening the sim and starting a new flight, it always crashes on the 18-20th menu access. Never before. :) It seems suspiciously like some stack overflow, but I haven't a clue where. And you are right, the improvement over Vista is simply amazing. I landed at KJFK yesterday with full AI and fluent 40 fps, absolutely amazing. Check the core loads during flight ... so much better load distribution and thread management than Vista ever had. I don't see any texture loading during flight, no popping, no stuttering. Just hope we figure out the uiautomationcore.dll issue soon :)

Share this post


Link to post
Share on other sites

Hi,Well I finally gave up on Win 7 and reluctantly went back to XP64. Before I went, though, I tried using a PS2 mouse but sadly it didn't fix the CTD. So the same software and hardware works perfectly on XP64 but not on Win 7. Even if you don't touch the menu, and you want to use a serious sim like the PMDG MD-11 (which uses a lot of clicks on the VC) on Win 7 and you are one of the unlucky ones affected by this bug then you are screwed. :(

Share this post


Link to post
Share on other sites

Hi,any news on this issue? I have the same problem. It is a pitty, Windows 7 and FSX match perfectly expect the problem with uiautomationcore.dll. What can I do, to report this bug directly to the microsoft staff?RegardsStefan

Share this post


Link to post
Share on other sites
Guest piotr0r

Hi everyone,I think I have a solution for this. I had the same kind of problem when trying to launch Neverwinter Nights 2 on windows 7, which had a serious DLL issue preventing the game from even starting. So instead of letting NWN2 relying of the built-in Windows 7 version of this particular DLL, I just dropped its Windows Vista counterpart in the same folder as the executable, and it worked perfectly.This is what gave me the idea to try the same solution with FSX after I understood that the problem originated from FS X not coping very well with Win7. I dropped a Windows Vista version of UIAutomationCore.dll in the same folder as FS X, and I couldn't crash the sim by clicking the menus like mad, no matter how hard I tried. Then I removed it, and crashed the sim in a fatal error after 20 mouse clicks on the menus. I put the Vista-version DLL back, and no more crashes.I've made a flight test between TNCM and TFFF with the Hornet that comes bundled in FS Acceleration Pack, and it still didn't crash - once again, no matter how hard I try.So if you can get your hands on a vista-version of UIAutomationCore.dll, just drop it in your FSX folder, run a cmd.exe as an administrator and while in your FSX folder, run a regsvr32 UIAutomationCore.dll command to register the dll just to be sure, and test.It has worked for me so far. If it crashes again, I'll let you know, but I do hope I've found a quick-and-dirty-but-functional fix to this. I'll be glad to provide my configuration & system info if that helps, but I think this is what we need to eradicate those @#&! fatal errors.I wish you luck!Pierre J.

Share this post


Link to post
Share on other sites

Thank you for your suggestion, Pierre. I've copied a vista-UIAutomationCore.dll in the FSX-Folder, ran regsvr32 UIAutomationCore.dll with success, but FSX still crashes after using the menu bar :-(ProblemsignaturProblemereignisame: APPCRASHAnwendungsname: fsx.exeAnwendungsversion: 10.0.61472.0Anwendungszeitstempel: 475e17d3Fehlermodulname: uiautomationcore.dllFehlermodulversion: 7.0.0.0Fehlermodulzeitstempel: 49eea6d9Ausnahmecode: c0000005Ausnahmeoffset: 0000ec58Betriebsystemversion: 6.1.7100.2.0.0.256.1Gebietsschema-ID: 1031RegardsStefan

Share this post


Link to post
Share on other sites
Guest piotr0r

Bummer. I've posted the same reply on the technet boards, and this fix didn't work for someone running the build 7201 as well. This person pointed out that I did not install my FS X in the default folder, but in a c:\fsx folder instead. I don't know if this changes anything (I'm not a programmer), but I can assure you that my FS X running in Windows Seven IS using the Vista DLL :uiautomationcore.pngSo Stefan, I don't know why your FS X is refusing to use the Vista DLL you provided, but if you can somehow find a way to do it, I'm pretty sure it will do the trick. Unfortunately, apart from installing in a c:\fsx folder ... I have no clue.For information's sake : system info: Intel Core i7 920 (overclocked to 3,54 GHz, rock stable, never ever crashes), 6 GB DDR3 1600 RAM, Gigabyte GA-EX58-UD5 motherboard with HT enabled but with energy saving features off, nvidia geforce 260+ graphics card with 186.16 Windows 7 drivers, Windows 7 build 7137, FS X + Acceleration Pack and REX installed, nHancer tweaks, runs super smooth, Preview Direct X 10 mode is ENABLED (water shaders are w00t). DEP is disabled, UAC is on, FS X running as administrator, default folder ownership.My FS X version is the 10.0.61637.0 English language , and my uiautomationcore.dll is version 6.0.6001.1800 English language as well.This is all the more frustrating that I've played the sim a few hours today, and flew across the pacific ocean ... and no more crashes, I swear.Edit: I'll point out that since the default folder located in program files requires special permissions and programs running as administator, I would not be surprised that this hack doesn't work precisely because of this. Installing in a c:\fsx no longer requires special privileges.I installed it there just to conveniently edit my .CFG files without having to run the notepad as administrator when creating my liveries for my airplanes.

Share this post


Link to post
Share on other sites

×
×
  • Create New...