Jump to content

Archived

This topic is now archived and is closed to further replies.

Hirgab

Panning around in cockpit

Recommended Posts

Hello!Why is it I can't pan around in my virtual cockpit?I look straight ahead, when I click on my middle mouse button and move my mouse, it does not pan around for some reason, I'm just fixed straight ahead. Any ideas? Thank you!

Share this post


Link to post
Share on other sites
Hello!Why is it I can't pan around in my virtual cockpit?I look straight ahead, when I click on my middle mouse button and move my mouse, it does not pan around for some reason, I'm just fixed straight ahead. Any ideas? Thank you!
Do you use a Joystick with a "hat switch" ??If so, you should be able to pan in VC using the hat switch. I have never attempted to use a mouse for panning.

Share this post


Link to post
Share on other sites
Hello!Why is it I can't pan around in my virtual cockpit?I look straight ahead, when I click on my middle mouse button and move my mouse, it does not pan around for some reason, I'm just fixed straight ahead. Any ideas? Thank you!
Have you actually turned on Mouse Look? Hold the space bar to engage or lock it on/off with SHIFT+O. It doesn't pan with the mouse by default.Loyd

Share this post


Link to post
Share on other sites
Have you actually turned on Mouse Look? Hold the space bar to engage or lock it on/off with SHIFT+O. It doesn't pan with the mouse by default.Loyd
Spot on, Loyd.That is actually described is some detail in the FSX Learning Center (which is within FSX itself) - I had just never tried it myself.There is a wealth of information there that many simmers never seem to explore.

Share this post


Link to post
Share on other sites

I hold down space bar/left click &hold & move mouse everyway, to getpanning in VC. Very smooth!Peter Sydney AustraliaFSX PIC 737 Windows 7 64bit MegasceneryVFR Britain 4Core i7 GTX 470

Share this post


Link to post
Share on other sites

Thanks all. I was able to get my mouse to pan around, but I'm also having issues with my hatswitch on my joystick. When I try to pan around, it squiggles, as if trying to resist the pan, and then eventually gives way and pans but then it squiggles a bit. I'm using Ezdok camera. Any ideas?it also works very nicely in slew mode, but not so much in the normal mode.

Share this post


Link to post
Share on other sites
Thanks all. I was able to get my mouse to pan around, but I'm also having issues with my hatswitch on my joystick. When I try to pan around, it squiggles, as if trying to resist the pan, and then eventually gives way and pans but then it squiggles a bit. I'm using Ezdok camera. Any ideas?it also works very nicely in slew mode, but not so much in the normal mode.
i'm thinging EZDOK is your problem, something to do with the setup most likely. i dont have it but given what it is supposed to do I would be looking in that direction.

Share this post


Link to post
Share on other sites

I think you're right. FSX and ezdok are conflicting, but I still haven't figured out why. It's driving me nuts!

Share this post


Link to post
Share on other sites

A big wet kiss to anyone who can figure this out. ;) Still having problems and it's driving me nuts.

Share this post


Link to post
Share on other sites

With EZDOK on some planes, especially non-default, you have to go into window mode, press alt, then addons, then EZdok, thenShow Studio; activate all the little squares, close and go back et Voilà ! you can now pan using your hat switch..if you do not want ezdok features then, click alt,then addons, then EZdok,then click Global Disable.If it works, i do not want the kiss thanks ! LOLAlain from Montreal

Share this post


Link to post
Share on other sites
A big wet kiss to anyone who can figure this out. ;) Still having problems and it's driving me nuts.
Don't want the kiss :) , but have you got the hat switch disabled in the FSX settings menu (where the joystick axes and buttons are listed, as well as the keyborad asignments)? You might try this, easy enough to restore if you need to.Thanks, Bruce.

Share this post


Link to post
Share on other sites

If u still have the problem with the controller vibrating go to control panel then type game in the top right search bar and click USB game controllers, then select the one you use for fsx and clic k properties and go to the tab on the far right and lower the rumble to the left for less rumble

Share this post


Link to post
Share on other sites

If u still have the problem with the controller vibrating go to control panel then type game in the top right search bar and click USB game controllers, then select the one you use for fsx and clic k properties and go to the tab on the far right and lower the rumble to the left for less rumble

 

I am sure he has fixed it after three years :-)

Share this post


Link to post
Share on other sites

×
×
  • Create New...