Jump to content

Archived

This topic is now archived and is closed to further replies.

mosteen

AS2012 Simconnect issue (client / server setup)

Recommended Posts

Well, I am back in the Simconnect quagmire...

 

I have a server/client setup with SB4 on my laptop, FSX running on the server, all good. Before installing AS2012 I did all the tests and I have permissions and shares all set up and working, did the AI-planes test, made a txt-file in all the folders and so on. Static IP's on both server and client.

 

When starting AS2012 on the client as described I get the following messages:

 

1. "Simconnect Client SP2 not found. You must have FSX SP1 or SP2 SimConnect Client installed in order to use FSX mode with AS2012"

 

2. "A valid Simconnect managed version was not found to be correctly installed. It is recommended to uninstall and reinstall the latest FSX SP update so this can be repaired. [sHORTENED].

 

I am at my wits end.

 

What is happening? I have a Simconnect connection running and working, and the dialog seems to think that I have FSX on the client PC, wich I of course dont.

 

I am also reading something about different Simconnect versions?

 

Anyone to the rescue?

 

Thanks

Morten

Share this post


Link to post
Share on other sites

Hi Morten,

 

The Simconnect client version (in side by side) for SP2 or SP1 is not being located by AS2012 client for some reason. The easiest fix for this involves installing the simconnect.msi file which is included in the FSX SDK (you can install this from your CD, if you don't have it installed already). Note that the SDK should be updated to SP2, which requires update to SP1/SP1A first (if you are not using Acceleration). If using Acceleration, it is already updated to SP2.

 

Does this help? If you continue having trouble please open a ticket at support.hifitechinc.com with your log export and details and we can troubleshoot this with you.

Share this post


Link to post
Share on other sites

Thanks Damian,

 

Ok, I have Accel, should I install the Accel SDK from the Accel DVD on my server (FSX)?

 

I installed SP1A from fsinsider earlier and did not think more about this when my SB4 as client worked after that stunt:)

 

I have 3 versions of the dll in my winsxs folder on the server, 60905, 61242 and 61259.

 

On my client PC I have only the 60905 in the winsxs so I guess that is the problem.

 

How do I proceed?

 

Thanks,

Morten

Share this post


Link to post
Share on other sites

Solved ;) I made a doo-doo... Apparently I had used an old msi that came with SB4. Moved the newest msi to my client, ran it and I am back in the saddle :) :) Sorry to bother you with this supersilly mistake.

 

So now I am off to dl' SP2 ;)

Share this post


Link to post
Share on other sites

If I had any hair eft, SImconnect issues would turn it gray. I have YET to see a product that uses Simconnect not have some issue. Glad you got it sorted!

 

Vic

Share this post


Link to post
Share on other sites

Yup, but now I finally I have EFB, SB4 and the WX engine running on my client. And a WX with true winds aloft ;) I spent 5 hours on this mess today, still I am a happy camper, this hobby is strange ;)

Share this post


Link to post
Share on other sites

Hi Morten,

 

" . . . Moved the newest msi to my client, ran it and I am back in the saddle :)"

 

What is it that you moved to and ran on your client? And how do I identify 'the newest'?

 

Needless to say, I'm in serious need of handholding!

 

 

Thanks, JJ

Share this post


Link to post
Share on other sites

Do a search for simconnect.dll on your server, the listing reveil their version number. If you have three files you probably have what it takes ;) If not you have to install some SDK SPs. I have Accel so apparently I did not need to upgrade the SDK.

 

Then, search for simconnect.msi on your server, take the newest one and run it on your client and simconnect should work.

Share this post


Link to post
Share on other sites

Many thanks Morten. Finally got it sorted out. I had been experiencing simconnect issues for the past week not knowing why the connection ceased working after several years. I still don't know but the important thing is that it now works and hope it continues to work. Simconnect is a strange beast!

 

JJ

Share this post


Link to post
Share on other sites

Hello all,

I am having a simconnect issue as well; however, it has to do with REX Essentials. I have looked at the REX support forums but to no avail. So, I thought I try here since I'm sure its a simconnect issue. So here is the problem details:

I have followed the instruction on REX forums to the letter to get a network set-up going for REX E+OD but it wont recognize simconnect on my client PC. The error is gives is as follows:

************* Exception Text **************

System.IO.FileLoadException: Could not load file or assembly 'Microsoft.FlightSimulator.SimConnect, Version=10.0.61242.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The referenced assembly is not installed on your system.

The reason I know its a simconnect issue is because it has to do with version of simconnect. I am running FSX acceleration on the server and had REX 2.0+OD running on the client with simconnect v61259 a few days ago and it worked perfectly. However, REX(E) needs version 61242 which i installed on the client but that is not working with fsx PC, since I cannot get the sample AI program to work properly.

So, a recap: REX 2.0+OD works fine from the client and is using simconnect v61259. But REX(E) is not working as it fails to find simconnect v61242 from the client but it is installed in the Client PC.

Any suggestion? And I've already looked at REX forums so please dont refer me there, I want to know what you all think.

Thanks a lot

Share this post


Link to post
Share on other sites

WOW, so I just bought AS2012, and so your saying I can run this from a networked PC using this simconnect thingy, to lighten the load on my main FSX rig?

Is there any sort of guide of instructions kicking about so I could do the same thing?

 

Does AS2012 have quite an impact on your main FSX rig then?

 

Sorry if those are silly questions guys, am just finding my feet with FSX and now looking to expand a little into taking some of the load off my main rig where possible.

What else can this simconnect do or what else could be put onto another PC to take the weight off the FSX rig? UTX?

I Saw that FSCommander 9.2 can use WideFS, which I have bought. Could I use WideFS instead of Simconnect?

Share this post


Link to post
Share on other sites

You may want to ask REX folks. Things are a little different than ASE.

 

Hey Rendi,

I tried their forums but it wasn't helpful. However, i did mange to get everything sorted. As I had suspected, it was a simconnect issue with different versions. It turns out that the msi didnt install the version 61242 dll in the winsxs folder. So, I copied that folder from the server to the client pc under safe-mode and everything just clicked! Its beautiful!

Share this post


Link to post
Share on other sites

WOW, so I just bought AS2012, and so your saying I can run this from a networked PC using this simconnect thingy, to lighten the load on my main FSX rig?

Is there any sort of guide of instructions kicking about so I could do the same thing?

 

Does AS2012 have quite an impact on your main FSX rig then?

 

Sorry if those are silly questions guys, am just finding my feet with FSX and now looking to expand a little into taking some of the load off my main rig where possible.

What else can this simconnect do or what else could be put onto another PC to take the weight off the FSX rig? UTX?

I Saw that FSCommander 9.2 can use WideFS, which I have bought. Could I use WideFS instead of Simconnect?

 

 

The AS2012 User Guide has a pretty good section on setting up a networked AS2012.

 

Personally, I have little performance hit with AS2012 on my FSX or P3d system directly. A lot depends on the number of add-ons that are using up CPU cycles as to whether or not you might need it.

 

Usually flight planners can easily be offloaded but it really depends. I do not believe that AS2012 can be configured for WIDEFS - think it's just SimConnect. IIRC, WIDEFS uses FSUIPC and AS2012 uses SimConnect.

 

Vic

Share this post


Link to post
Share on other sites

Hi i'm having the same issue.

 

i have one simconnect.msi which I used but AS2012 is still giving the same error. i have 3 versions of simconnect.dll, the latest being in C:\Windows\winsxs\x86_microsoft.flightsimulator.simconnect_67c7c14424d61b5b_10.0.61259.0_none_55f5ecdc14f60568.

 

Do i copy that over to the client?

 

i have been advised to install SP1 and SP2 from http://www.fsdeveloper.com/wiki/index.php?title=SDK_Installation_%28FSX%29. But as i already have FSX Gold yjay will ruin my Acceleration install.

Share this post


Link to post
Share on other sites

Now you've dug up a post from last year. Now I think that makes 4 threads in which you are posting about the same stuff.

 

No you cannot copy over any simconnect files. You must use the simconnect.msi files to install simconnect on the client computer.

Share this post


Link to post
Share on other sites

Goto your Control Panel\ programs and features. Look and see what you have there, if any of Microsoft Flight Simulator Simconnect Client vxxx?

 

Who knows where your at now! This is by far the easiest part. Setting up the network and sharing folders gets even more complicated.

Share this post


Link to post
Share on other sites

Goto your Control Panel\ programs and features. Look and see what you have there, if any of Microsoft Flight Simulator Simconnect Client vxxx?

 

Who knows where your at now! This is by far the easiest part. Setting up the network and sharing folders gets even more complicated.

 

yes I have Microsoft Flight Simulator Simconnect Client v10.0.60905.0 installed on the client PC. however AS2012 is still giving the same error as the OP.

Share this post


Link to post
Share on other sites

×
×
  • Create New...