Sign in to follow this  
ebksb123

FS-Recorder REPLAY - Controls not moving

Recommended Posts

All the previous PMDG planes had no problems with it, but if I replay a landing with the 777 using FS-Recorder, controls on the wings are not moving (both flaperon & aileron). To be more precisely, the flaperon changes position related to the flap's position and e.g. moves up when reverse thrust is activated on the ground, but the inputs done by the yoke are not shown. Is there a trick to make them move normally? Maybe the fly-by-wire system prevents the moves. At least the Autopilot was off, so it must be something different.

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Bumping this, as I have exactly the same question?

I like to watch replays of my landings, especially those in severe x-wind & turbulence ^_^. Not seeing any control inputs on the wing while replaying with FSrecorder, the wing is "dead" which makes it quite dull.....

Is there a solution for this?

Share this post


Link to post
Share on other sites

Noticed also that the fs built in replays have some problems with several  items  not working. Guess I 'll have to use

FRAPS

Ron

Share this post


Link to post
Share on other sites

If i recall, there was a solution to this as the NGX had the exact same problem. It was all to do with loading a certain panel state that FSRecorder creates when making a recording.

Then again, it maybe an entirely new problem because with it being a new plane. Haven't had a chance to use FSRecorder yet on the T7. Not sure how active the development is on the program, seeing as the last release is over a year old. I plan on firing up the sim today, if i get a chance I'll have a look!

Share this post


Link to post
Share on other sites

Any solution to this problem?  It is still  unanswered.  Why can't we see reverse thruster and spoiler animations on PMDG aircrafts during replay?

Share this post


Link to post
Share on other sites

The last post clearly states: "Note that this workaround may not help with non-working gear, ailerons, reversers, etc."

 

So that's not the solution for the problem... Look at all the pmdg777 videos on youtube, especially the wing views. The plane starts rolling to a 30° turn and NOTHING on the wing moves. That looks really stupid. There has to be a solution for that :O

Share this post


Link to post
Share on other sites

All the previous PMDG planes had no problems with it, but if I replay a landing with the 777 using FS-Recorder, controls on the wings are not moving (both flaperon & aileron). To be more precisely, the flaperon changes position related to the flap's position and e.g. moves up when reverse thrust is activated on the ground, but the inputs done by the yoke are not shown. Is there a trick to make them move normally? Maybe the fly-by-wire system prevents the moves. At least the Autopilot was off, so it must be something different.

 

Same here, it's working fine with the NGX, but not with the 777.  Perhaps they had to use different custom animations that FS-Recorder doesn't support. 

 

John

Share this post


Link to post
Share on other sites

Same here, it's working fine with the NGX, but not with the 777.  Perhaps they had to use different custom animations that FS-Recorder doesn't support. 

 

John

 

I have already contacted PMDG because of this and they told me something like that. Sounds logical, but I thought that over the next few weeks/months after release one of the many smart guys of our FS community would crack this problem, as always :D. Sadly that's not the case...

Share this post


Link to post
Share on other sites

 

 


All the previous PMDG planes had no problems with it, but if I replay a landing with the 777 using FS-Recorder, controls on the wings are not moving (both flaperon & aileron). To be more precisely, the flaperon changes position related to the flap's position and e.g. moves up when reverse thrust is activated on the ground, but the inputs done by the yoke are not shown. Is there a trick to make them move normally? Maybe the fly-by-wire system prevents the moves. At least the Autopilot was off, so it must be something different.

 

Hi, Anton and everyone,

 

I've done a little more experimenting.  To get most of the externally visible functions to work, the key appears to be to have the correct panel state loaded.  If the panel state is set up properly, the following functions seem to work for approaches and landings:  flap deployment, reversers, spoiler deployment on touchdown (but I suggest arming it during the replay just to be on the safe side).  The gear starts to come down, but very jerkily.  It works smoothly once "G" is pressed.  The ailerons/flaperons do NOT work.  The rudder appears to work, not sure how accurately though.   

 

The panel state should be the one saved at the beginning of the recording (FS-Recorder should be set to save the flight -- this will also save the 777 panel state).  The panel state will have the same name as the recording (and the flight saved by FS-Recorder).  The flight should be reloaded by FS-Recorder - it should be set to do so.  However "load user aircraft" should not be checked, as that seems to reload the aircraft twice, causing weird problems.  FS-Recorder's reload of the flight will load the correct aircraft anyway.  Once the flight is loaded by FS-Recorder, it will be necessary to manually reload the panel state (again with the same name as the recording). 

 

FS-Recorder does save the panel state when it saves the flight, but it seems it doesn't name the files correctly.  There is a workaround: go into Flight Simulator X\PMDG\PMDG 777X\PanelState.  This is where FS and FS-Recorder save the panel state. Find the three files with the same name as the saved recording.  They end in .frc.0.rte, .frc.sav and frc.fmc (occasionally the rte file has a 1, 2, 3 or 4 instead of 0).  Rename them as follows:  .frc.FLT.0.rte,  .frc.FLT.sav and frc.FLT.fmc.  The panel state should then be loaded automatically when FS-Recorder reloads the flight corresponding to the beginning of the recording. 
 

However I've found the results still to be somewhat unpredictable.  Just replayed a landing at TNCM (w. renamed panelstate files) and the aircraft came up with all panel displays blank, but pop-up displays working, CDU display of flight plan working, and the aircraft operated correctly from external view, as described earlier.

 

For takeoffs, it's best to start your recording right before takeoff.  Or save a flight just before takeoff and load that instead of one saved by FS-Recorder.  If you start the recording and save the flight at the gate w/ engines off, many things will not work correctly.

 

FS-Recorder Alpha Version 2.18 has the possibility to add variables, so perhaps when the 777 SDK comes out someone will figure out how to get the ailerons/flaperons to work correctly by adding the correct variables. 

 

Finally, remember that if you want to restart a playback after it has ended you should load a default Cessna in between to avoid reloading the 777 on top of itself.

 

Mike

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this