Sign in to follow this  
cvearl

DX10 Fixer - ATI/AMD AA and Vsync Guide

Recommended Posts

For ATI/AMD customers using Steve Parsons' new DX10 Fixer, here is how to apply maximum AA/AF settings and force vSync.

 

First, you need RadeonPro - http://www.radeonpro.info/

 

Enabling FXAA using RadeonPro - while in game with RadeonPro, you can hit CTRL-O to open RadeonPro's OSD and then use CTRL+F to turn FXAA on and off. FXAA (Fast Approximate Anti-Aliasing) can (for free) provide a slight "additional" smoothing to edges as it will combine with SSAA.

 

http://youtu.be/rj8-PpmJ6pI

 

#1. Install you DX10 fixer. Switch to DX10 using Steve's tool. Enable the effects if you have not already during the install.

#2. Select 8xAA in DX10 Fixer's dialogue box.

#3. You will need to configure RadeonPro with an FSX Profile so you can set the stuff for FSX in RadeonPro (screenshots).

 

IMPORTANT:  Once you are in FSX and have it set to DX10, you must have AA and Ansio enabled in FSX Graphics settings as well as setting fps to unlimited in the game. You will be locking fps through RadeonPro.

 

NOTE: You can set 4xAA in the DX10 Controller instead of 8xAA for those cloudy days to maintain that magic 30 fps as 8xSSAA and heavy clouds might cause stutters.

 

yh7d.jpg
Qd620.jpg
GmRrq.jpg
X0DS.jpg
kcuhJ.jpg
 


PR7J.jpg
eniS0.jpg
nOKkW.jpg
ejwV5.jpg
Hf9X.jpg
HBms.jpg
TfcB.jpg
 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

apology, but not is how you can get that since I'm with the randeon pro with all the controls to maximum and all selected filters and not get even half, my card is ATI 6990 double nucleus and 4 gb of memory, even though I don't have the fixative still am trying to your regulations achieve at least something that is visibly pleasing, but it can not. The question is your what you did once you have installed the post or your already saw FSX so

disculpa, pero no se como puedes lograr eso ya que estoy con el randeon pro con todos los controles a maximo y todos los filtros seleccionados y no logro ni la mitad, mi tarjeta es ATI 6990 doble nucleo y 4gb de memoria, si bien no tengo el fijador aun estoy intentando mediante tus regulaciones lograr al menos algo que sea visiblemente agradable, pero no lo logro. La pregunta es tu lo lograste una ves que instalaste el fijador o tu ya veías el FSX asi

pu4u.jpg

This image is of this same team, but in DX9

 

 

2idr.jpg

m2pa.jpg

Share this post


Link to post
Share on other sites

apology, but not is how you can get that since I'm with the randeon pro with all the controls to maximum and all selected filters and not get even half, my card is ATI 6990 double nucleus and 4 gb of memory, even though I don't have the fixative still am trying to your regulations achieve at least something that is visibly pleasing, but it can not. The question is your what you did once you have installed the post or your already saw FSX so

disculpa, pero no se como puedes lograr eso ya que estoy con el randeon pro con todos los controles a maximo y todos los filtros seleccionados y no logro ni la mitad, mi tarjeta es ATI 6990 doble nucleo y 4gb de memoria, si bien no tengo el fijador aun estoy intentando mediante tus regulaciones lograr al menos algo que sea visiblemente agradable, pero no lo logro. La pregunta es tu lo lograste una ves que instalaste el fijador o tu ya veías el FSX asi

pu4u.jpg

This image is of this same team, but in DX9

 

 

2idr.jpg

m2pa.jpg

 

Without the DX10 Fixer... You have to put the lines in the FSX.CFG manually.

 

under [GRAPHICS] add MultiSamplesPerPixel=8 or 4.

 

But that is only needed if you do NOT have the DX10 FIXER. You want that fixer if you are going to fly DX10.

 

Charles.

Share this post


Link to post
Share on other sites

I have put these lines since I was reading almost all the messages on this post I leave my FSX.cfg

 

[bufferPools]

RejectThreshold=131072
Poolsize=0
 
[VirtualCopilot]
VirtualCopilotActive=1
 
[sOUND]
AmbientUI=1
AmbientUIMusicVolume=-6.000000
PrimaryDevice={00000000-0000-0000-0000-000000000000}
SOUND=1
SOUND_LOD=1
SOUND_QUALITY=2
UISound=1
VoiceDevice={00000000-0000-0000-0000-000000000000}
 
[slewTextInfo.1]
AirSpeed=1,5
Altitude=1,3
Heading=1,4
Latitude=1,1
Longitude=1,2
 
[DISPLAY.Device.AMD Radeon HD 6900 Series.0]
Anisotropic=1
Mode=1920x1080x32
 
[AContain]
LabelColor=FFFF0000
LabelDelay=1000
ShowLabelAirline=0
ShowLabelAirlineAndFlightNumber=0
ShowLabelAirspeed=0
ShowLabelAltitude=1
ShowLabelContainerId=0
ShowLabelDistance=1
ShowLabelFlightPlan=0
ShowLabelHeading=0
ShowLabelManufacturer=1
ShowLabelModel=1
ShowLabelTailNumber=0
ShowLabels=1
ShowUserLabel=0
 
[ATC]
AutoOpenAirTrafficWindow=1
COMM_MSG_AI_ATC_COLOR=FFFF7840
COMM_MSG_ATC_AI_COLOR=FF00FF00
COMM_MSG_ATC_USER_COLOR=FFB6FFB6
COMM_MSG_NONE_COLOR=FFFFFFFF
COMM_MSG_USER_ATC_COLOR=FFFFD21B
PilotVoice=0
ShowATCText=1
UsePilotVoice=1
 
[TextInfo.1]
AirSpeed=1,5
Altitude=1,3
Heading=1,4
Latitude=1,1
Longitude=1,2
WindDirectionAndSpeed=1,6
 
[AccelerationPack]
ControlsFirstRun=0
HomePageFirstRun=0
[iNTERNATIONAL]
ASLAT=2
ASLON=1
MEASURE=0
 
[CONTROLS]
Controls_Current=Standard
Controls_Default=Standard
KBDAIL=64
KBDELEV=64
KBDRUD=64
 
[FACILITIES]
CITY=
COUNTRY=
GTL_BUTTON=1405
STATE=
 
[TextInfo.3]
AirSpeed=1,5
Altitude=1,3
FrameRate=2,1
FuelPercentage=2,4
GForce=2,3
Heading=1,4
Latitude=1,1
LockedFrameRate=2,2
Longitude=1,2
WindDirectionAndSpeed=1,6
[PointOfInterestSystem]
CycleSetting=0
 
[GRAPHICS]
AC_SELF_SHADOW=1
AIRCRAFT_REFLECTIONS=1
AIRCRAFT_SHADOWS=0
ALLOW_SHADER_30=1
COCKPIT_HIGH_LOD=1
D3D10=1
EFFECTS_QUALITY=2
ForceFullScreenVSync=1
ForceWindowedVSync=1
GROUND_SHADOWS=0
HIGHMEMFIX=1
IMAGE_QUALITY=0
LANDING_LIGHTS=1
NUM_LIGHTS=8
See_Self=1
TEXTURE_MAX_LOAD=4096
TEXTURE_QUALITY=3
Text_Scroll=1
SHADER_CACHE_PRIMED_10=1693500672
MultiSamplesPerPixel=8 
MultiSampleQuality=32
 
 
 
[TrafficManager]
AIRPORT_SCENERY_DENSITY=3
AirlineDensity=20
FreewayDensity=20
GADensity=20
IFROnly=0
LeisureBoatsDensity=40
ShipsAndFerriesDensity=40
 
[DynamicHeadMovement]
HeadMoveTimeConstant=1.000000
LonAccelOnHeadLon=-0.020000
LonAccelOnHeadPitch=-0.010000
MaxHeadAngle=5.000000
MaxHeadOffset=0.300000
RollAccelOnHeadLat=0.010000
RollAccelOnHeadRoll=0.100000
YawAccelOnHeadLat=-0.100000
 
[REALISM]
AllowEngineDamage=False
AutoCoord=False
AutoTrim=False
CrashDetection=False
CrashTolerance=0.000000
CrashWithDyn=False
GEffect=False
General=0.000000
GyroDrift=False
GyroEffect=0.000000
ManualLights=False
PFactor=0.000000
RealMixture=False
StressDamage=False
Torque=0.000000
TrueAirspeed=False
UnlimitedFuel=True
 
[Weather]
AdjustForMagVarInDialog=1
CLOUD_COVERAGE_DENSITY=8
CLOUD_DRAW_DISTANCE=4
DETAILED_CLOUDS=1
DisableTurbulence=0
DownloadWindsAloft=0
DynamicWeather=0
MaxGustRampSpeed=200
MaxGustTime=500
MaxVarRampSpeed=75
MaxVarTime=50
MinGustRampSpeed=1
MinGustTime=10
MinVarRampSpeed=10
MinVarTime=5
THERMAL_VISUALS=1
TurbulenceScale=1.000000
WeatherGraphDataInDialog=0
WeatherServerAddress=fs2k.zone.com
WeatherServerPort=80
WindshieldPrecipitationEffects=1
 
[Misc]
Com_Rate=7
 
[Main]
HideMenuFullscreen=1
HideMenuNormal=0
Location=440,151,1480,929,\\.\DISPLAY1
Maximized=1
SimObjectPaths.0=SimObjects\Airplanes
SimObjectPaths.1=SimObjects\Rotorcraft
SimObjectPaths.2=SimObjects\GroundVehicles
SimObjectPaths.3=SimObjects\Boats
SimObjectPaths.4=SimObjects\Animals
SimObjectPaths.5=SimObjects\Misc
User Objects=Airplane, Helicopter
ProcSpeed=10122
PerfBucket=7
disablepreload=1
 
[Trusted]
 
 
[TextInfo.2]
FrameRate=1,1
FuelPercentage=1,4
GForce=1,3
LockedFrameRate=1,2
 
[uSERINTERFACE]
Map_Orientation=2
OpenATCOnCreate=0
PAUSE_ON_LOST_FOCUS=1
PROMPT_ON_EXIT=1
PageID=1
SHOW_MISSION_CAPTIONS=1
SITUATION=FLIGHTS\OTHER\FLTSIM
SelectAircraftManufacturer=Todos
SelectAircraftPublisher=Todos
SelectAircraftType=Todos
ShowAllACPaintSchemes=1
 
[sIM]
SYSCLOCK=1
 
[Display]
ActiveWindowTitleBackGroundColor=0,28,140,64
ActiveWindowTitleTextColor=255,255,255
BLOOM_EFFECTS=0
ChangeTime=4.000000
InfoBrakesEnable=True
InfoLowerLeftBackGroundColor=255,0,0,128
InfoLowerLeftTextColor=255,255,255
InfoLowerRightBackGroundColor=255,0,0,128
InfoLowerRightTextColor=255,255,255
InfoOverspeedEnable=True
InfoParkingBrakesEnable=True
InfoPauseEnable=True
InfoSlewEnable=True
InfoStallEnable=True
InfoUpperRightBackGroundColor=0,0,0,0
InfoUpperRightTextColor=255,0,0
NonActiveWindowTitleBackGroundColor=24,33,87,64
NonActiveWindowTitleTextColor=255,255,255
SKINNED_ANIMATIONS=1
TEXTURE_BANDWIDTH_MULT=17
MAX_TEXTURE_DATA=711
TextureMaxLoad=12
TransitionTime=4.000000
UPPER_FRAMERATE_LIMIT=27
WideViewAspect=True
 
[JOBSCHEDULER]
AffinityMask=1344
 
 
[slewTextInfo.3]
AirSpeed=1,5
Altitude=1,3
FrameRate=2,1
Heading=1,4
Latitude=1,1
LockedFrameRate=2,2
Longitude=1,2
 
[PANELS]
DEFAULT_VIEW=0
IMAGE_QUALITY=1
PANEL_MASKING=1
PANEL_OPACITY=100
PANEL_STRETCHING=1
QUICKTIPS=0
UNITS_OF_MEASURE=0
 
[sTARTUP]
DEMO=0
LoadWindow=1
SHOW_OPENING_SCREEN=1
STARTUP_DEMO=0
 
[slewTextInfo.2]
FrameRate=1,1
LockedFrameRate=1,2
 
[TERRAIN]
AUTOGEN_DENSITY=4
DETAIL_TEXTURE=1
LOD_RADIUS=8.500000
MESH_COMPLEXITY=99
MESH_RESOLUTION=25
SWAP_WAIT_TIMEOUT=2
TEXTURE_RESOLUTION=25
WATER_EFFECTS=6
 
[sCENERY]
DAWN_DUSK_SMOOTHING=1
IMAGE_COMPLEXITY=4
LENSFLARE=1
MAX_ASYNC_BATCHING_JOBS=3
SmallPartRejectRadius=4.0
 
[DISPLAY.Device.AMD Radeon HD 6900 Series.0.0]
Mode=1920x1080x32
Anisotropic=1
[MULTIPLAYER]
condAccoutPassword=0

Share this post


Link to post
Share on other sites

Why is it always that i get COUATL.EXE expected an error in the engine everytime i try install RadeonPro? It also says its not up to date but it is. I cannot continue because the popupkeeps coming every second when loading the aircraft :-) so i have to unstall RadeonPro and every thing is fine again

 

Michael Moe

Share this post


Link to post
Share on other sites

Michael,

 

go to the settings in RadeonPro, Advanced tab and mark 'Disable API monitoring for programs not listed in my profiles list'. That solves the Couatl issue.

 

Cheers

  • Upvote 2

Share this post


Link to post
Share on other sites

Michael,

 

go to the settings in RadeonPro, Advanced tab and mark 'Disable API monitoring for programs not listed in my profiles list'. That solves the Couatl issue.

 

Cheers

 

 

 

Tweak tweak , thanks :-)

 

Michael Moe

Share this post


Link to post
Share on other sites

Michael,

 

go to the settings in RadeonPro, Advanced tab and mark 'Disable API monitoring for programs not listed in my profiles list'. That solves the Couatl issue.

 

Cheers

 

Awesome advise. Thanks for stepping in. :)

 

Charles.

Share this post


Link to post
Share on other sites

I am sorry to report that the performance on my PC is much worse following the guide and using RadeonPro rather than have unlimited FPS or the internal fps limiter set a 30.

 

I have stutter and pauses with Radeonpro so for me its back to a much smoother experience but theres not 2 PC a like i guess.

 

Michael Moe

I7-4770K 4,7

HD7970 3GB Ghz Edition

Raptor FSX drive

SSD128GB W7-64

Share this post


Link to post
Share on other sites

 

 


Awesome advice. Thanks for stepping in. :)

Charles.

 

And your walkthrough was/is 'awesome' too. After several abortive attempts I have at last got some sense out of DX10!

I have a couple of issues left. One is a slight 'twinkling/shimmering of the instruments especially the GPS (C172R)

and sparkly white dots on airports. I don't know if you can see from this screenie but it's more pronounced in game:

glitters.jpg

 

Anyway, thanks for pointing me in the right direction. We ATIers must stick together!  :biggrin:

Share this post


Link to post
Share on other sites

I have seen those sparkly white dots in some of the payware ORBX airports. I have been busy but at some point want to fly up to one and see what object we are dealing with. Like a light pole or something that has missing textures. I dont know.

 

If I find out what it is I will submit it to Steve.

 

What airport?

 

Charles.

Share this post


Link to post
Share on other sites

I have seen those sparkly white dots in some of the payware ORBX airports. I have been busy but at some point want to fly up to one and see what object we are dealing with. Like a light pole or something that has missing textures. I dont know.

 

If I find out what it is I will submit it to Steve.

 

What airport?

 

Charles.

Charles, you might want to look at orbx Queenstown. I noticed sparkles up some of the light poles on the road just behind the airport at dusk (looking at the bay).

 

Cheers

 

Tony

Share this post


Link to post
Share on other sites

Charles, you might want to look at orbx Queenstown. I noticed sparkles up some of the light poles on the road just behind the airport at dusk (looking at the bay).

 

Cheers

 

Tony

 

What model video card you have?

 

Charles.

Share this post


Link to post
Share on other sites

I've just noticed now that I've logged more flying time, that after 3 to 4 minutes horrendous artefacts are appearing. I didn't notice this last night when I first installed. As I said above my card is an ATI 7850HD 2GB and I've been using the BP = 0 tweak.

 

Do you have any suggestions on BP or a suitable reject threshold?

 

Tony

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this