Sign in to follow this  
Richard Sennett

Rain shader grayed out

Recommended Posts

Help AVSIM continue to serve you!
Please donate today!

Because you didn't un-install the old Patch 3.2.2, Rich, before installing the Fixer. No problem, but it's best to do that first, as it avoids this issue cropping up. Just delete the ShadersHLSL folder completely, and put the original back in. If you need a new ShadersHLSL - here 'tis!

 

ATB!

 

pj

Share this post


Link to post
Share on other sites

Your the best Paul do I need to just do this or do I need to reinstall - thanks for the quick help Buddy

Share this post


Link to post
Share on other sites

My General Shader and Rain Shader are un-checkable. 

 

I was previously running the old 3.2.2 fixes. I've made innumerable changes to FSX over the years so I may have changed a texture file or something somewhere somehow. :)

 

I attempted to fix by uninstalling DX10 Controller, replacing the stock shader, and reinstalling to no avail. 

 

Not sure what to try next. Any help is appreciated.

Share this post


Link to post
Share on other sites

Hey Bread! Delete your existing ShadersHLSL folder completely. Download this stock folder, and put it into the root folder of FSX - where fsx.exe lives and unzip it. You now have a completely new ShadersHLSL folder.

 

Then  - Uninstall the libraries from within the Controller, and then uninstall the DX10 Scenery Fixer using the Windows Control Panel. This will get you back to a baseline.

 

Then - re-install the Fixer, as a fresh installation, checking all the buttons except the "8-Bit Texture Fix" in the "General Options.

 

You should then be ready to fly! :wink:

 

All the Best

 

pj

Share this post


Link to post
Share on other sites

Can you tell me the exact sizes of the two shaders? i.e General10.fsx and the rain shader. The only check it makes is on the size of those files.

 

Hi Paul!

Share this post


Link to post
Share on other sites

Hi Paul

I had also Rain shader grayed, and after following your instructions to Bread and after twice installing, now I have General,water,rain and cloud shaders grayed; only my legacy is checked.

In FSX Shaders HLSL folder is inside Stock_ShadersHLSL folder...if that is important.

What do I do wrong?.

Any help will be appreciated.

Share this post


Link to post
Share on other sites

Hi Amadeo: There is only one ShadersHLSL folder, and it should be sitting in the FSX root folder, just like "SimObjects", "Modules", Scenery" "Rewards", and all the other "stock" folders. You must delete the original ShadersHLSL folder because it has been changed by the earlier freeware patches.

 

Once you have deleted it, then can copy this one into the FSX folder, so that it looks like this,.

Next - simply unzip the zipfile. It will automatically put the new ShadersHLSL folder in the correct place - OK!

Share this post


Link to post
Share on other sites

Hello Paul,

 

I have installed dx10 and runs well except rain fix.

during raining I see the rain stops hafway my screen.

if I untab the rainfix it is the same so my conclusion is it doesnot do anything.

do you have an idea what it could be?

I have a clean install so there are no former folders

Share this post


Link to post
Share on other sites

General Comment.

I purchased the DX10 fixer last night and had the greyed out general and rain shaders. No need to reply how to fix - I got that. I''l make the repairs tonight. I've been using DX10 for about a year now after a new build. All I can say is that I don't now why everyone isn't onboard. After a few tweaks I had it running as smooth as silk. I'm not sure how to post a video, but I will one day soon. Anyway, what led to my purchase of the fixer lastnight was the installation of WOAI packages and some white planes. The fixer fixed the issue. Thanks for all of your hard work Steve. I appreciate it. Dx10 is the only way to go. I still don't have progressive taxi??

 

Bill.

Share this post


Link to post
Share on other sites

Thanks bill, you won't get progressive taxi until the general shader is not greyed out

Share this post


Link to post
Share on other sites

Hey Bread! Delete your existing ShadersHLSL folder completely. Download this stock folder, and put it into the root folder of FSX - where fsx.exe lives and unzip it. You now have a completely new ShadersHLSL folder.

 

Then  - Uninstall the libraries from within the Controller, and then uninstall the DX10 Scenery Fixer using the Windows Control Panel. This will get you back to a baseline.

 

Then - re-install the Fixer, as a fresh installation, checking all the buttons except the "8-Bit Texture Fix" in the "General Options.

 

You should then be ready to fly! :wink:

 

All the Best

 

pj

Paul,

I have seen the link for the original fsx shaders is no longer working. Would you be so kind to send me a working link ? I have just started using Steve's fixer but I am having the "greyed" out water button.

Thanks

 

Regards

Share this post


Link to post
Share on other sites

Hi Ezio: Check this link here. Adamski_NZ now has the Guide, and you'll find all of the new links inside - ok!

 

All the Best,

 

pj

Share this post


Link to post
Share on other sites

Thanks Paul.....

I have been using this tool for just a week now but I love it...

 

Regards

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this