Sign in to follow this  
Followers 0
Brian Riggs

AA workaround for NVidia cards

44 posts in this topic

Decided to test a few inspector settings out tonight and found that if I use AA_MODE_METHOD settings in the NI AA setting drop down menu the jagged lines around the runways and other shimmering objects are reduced considerably. 

 

FPS will vary if using addon airports/planes and heavy weather, no issues otherwise using FTXG and stock P3D airports/planes.  Example, with Flightbeam KPHX and IRIS F-22, frames ran between 25-30 fps, Carenado A36 28-30 fps.  Locked at 30 fps using start-up scenario (F-22/Virginia/light wx).

 

Here's a screenshot of my NI settings.

 

 

post-169914-0-92522800-1386989052.gif

post-169914-0-92522800-1386989052.gif

1

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

 

 


Here's a screenshot of my NI settings.

 

Tried it, with FXAA off, and seems to be a definite improvement.

 

What are your in-game settings?

 

Thanks,

gb.

0

Share this post


Link to post
Share on other sites

Ive tried every setting you could imagine. Even installed a 780 ti. Microstutters. jitters. eyeball wobble. Hard on the eyeballs after a few brews. :)

0

Share this post


Link to post
Share on other sites

What's the story on the fix/support from Nvidia?  I'm an Nvidia user, and this is one of several factors postponing my transition.

0

Share this post


Link to post
Share on other sites

Here's my modest settings, I've tried to keep it basically the same look as my DX10 FSX installation.

 

 

 

post-169914-0-71896600-1386995085.gif

post-169914-0-00363400-1386995092.gif

post-169914-0-52962500-1386995102.gif

post-169914-0-77749100-1386995107.gif

0

Share this post


Link to post
Share on other sites

What's the story on the fix/support from Nvidia?  I'm an Nvidia user, and this is one of several factors postponing my transition.

 

It may not be that Nvidia aren't supporting it..  A lot of DX1x games simply don't respond to brute force AA methods like they did in DX9 games.. This is mostly because of the advanced shading methods most DX1x games use. It's a trade off for real time lighting and shadows.. This even goes back to some DX9 games. GTA 4 to this day still doesn't respond to brute force AA methods via NI because it uses deferred shading.  

0

Share this post


Link to post
Share on other sites

Amazing, it works ! The runway jaggies are gone ! I could even reduce ingame MSAA to 4 samples and lower transparency supersampling to 2xSGSS in NI and still get acceptable graphics. (even if  4xSGSS does look better  :wink: )

 

Great find !

0

Share this post


Link to post
Share on other sites

Bump. Everyone really needs to try this.  It works beautifully!  No more flashing runways! 

0

Share this post


Link to post
Share on other sites

It appears I have the same NI version but under Antialiasing - Setting, you have an option that I do not see in the drop-down list.  "AA_MODE_METHOD_SUPERSAMPLE_4X_BIAS"

 

I don't know if it will work, yet, but I was able to manually type that in. 

0

Share this post


Link to post
Share on other sites

I just sat and went through a buffet of various settings... In my opinion.. Any perceived difference other than just setting 2X-4X-8X SGSSAA are placebo..  I even downsampled 2560x1440 and still saw runway jaggies.. You'd probably have to downsample 8k to make a dent in them.

 

My settings...

 

8raU4Jz.jpg

0

Share this post


Link to post
Share on other sites

thanks Bill. i wasn't going to say anything. If it fixes their mind, so be it. :) Antialiasing-Setting is an override and that aint gona happen

0

Share this post


Link to post
Share on other sites

thanks Bill. i wasn't going to say anything. If it fixes their mind, so be it. :) Antialiasing-Setting is an override and that aint gona happen

 

:) No fault of anyone really. I thought the same too when I first got v2 also..  I flipped some stuff and it looked better.. I never actually sat down to see if the stuff I flipped was actually the cause of it looking better.  :lol:  Turns out.. It was only one of those things.  I love this sort of stuff though..  I'm such a nerd.  :Nerd:

0

Share this post


Link to post
Share on other sites

Placebo eh ? Then zoom in

 

comparison.jpg

 

In case you want to see the lossless BMP, it's here

 

 

 

 If it fixes their mind, so be it. :)

 

And that was a lousy remark

2

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0