Archived

This topic is now archived and is closed to further replies.

doublebubble

ASN still stutters with tweaks added.

Recommended Posts

If someone could advise me of something else to try that would be great as having ASN installed and being a long time user of ASE with no stutters I get constant stutters with ASN, ASN turned off no stutters so I'm starting to get a little dissapointed when reading how other simmers are having a great expirience, I have done all the tweaks advised ( ASN update, the antivirus thing tried different cloud distance's but no go. I'm using DX10 fixer with Rex textures, FTXG.

 

Cheers Rod.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Try setting the affinity of ASN to CPU3.  After starting ASN, ctrl+alt+del to the task manager.  On to the processes tab, right click on the ASN process and set affinity to CPU3.  May solve your problem.

 

Other things you can check :

 

1. Exclude ASN & FSX directory from your anti virus

2. In case you are using REX or AS2012 textures, reduce the textures to 1024 and / or DXT5

 

Ted

Share this post


Link to post
Share on other sites

Had same issue my fix was to do task manager and find exe file called an_sound.exe or something like that kill it and frame rate and stutter went away. Try see

 

 

 

Thx. Andrei.

Share this post


Link to post
Share on other sites

Hi Andrei,

 

you mean as_audio.exe? This is needed for ASN to be able to play ATIS/briefing etc messages on the fsx machine (and on the dedicated sound device you select). If you kill this process, this will fail. Weird though, as this is just a process sleeping all the time waiting for messages from ASN main application, so that it can start playing the messages. What was the CPU utilization from this process prior to killing it? Did you have 122.0 (or 122.02 or 122.05) tuned? I'd like to investigate this a little bit more (if others are affected, if it's a sound device conflict of some kind etc).

 

Thanks,

 

Kostas Terzides

ASN developer

Share this post


Link to post
Share on other sites

I ran into something similar today. Networked ASN running on a client. Started to get stuttering 30 min into flight at cruise alt. Turned off ASN and restated and resolved the stutters? Simconnect? Time of stutters:

 

9:55:15 AM:0548-Loading previously loaded weather...
9:55:15 AM:0950-Error parsing zulu time 232450Z 12/23/2013 3:36:57 PM
9:55:15 AM:0951-Error parsing zulu time 232450Z 12/23/2013 3:36:57 PM
9:55:17 AM:0445-Weather read complete
9:55:21 AM:0846-Building the theme...
9:55:24 AM:0274-Copying theme file and loading to the sim...
9:55:25 AM:0611-FSX connection not established! ( I manualy disconnected)

 

Believe Ill ask Damian and crew.

Share this post


Link to post
Share on other sites

Hi Andrei,

 

you mean as_audio.exe? This is needed for ASN to be able to play ATIS/briefing etc messages on the fsx machine (and on the dedicated sound device you select). If you kill this process, this will fail. Weird though, as this is just a process sleeping all the time waiting for messages from ASN main application, so that it can start playing the messages. What was the CPU utilization from this process prior to killing it? Did you have 122.0 (or 122.02 or 122.05) tuned? I'd like to investigate this a little bit more (if others are affected, if it's a sound device conflict of some kind etc).

 

Thanks,

 

Kostas Terzides

ASN developer

 

Kostas,

 

yes thats the exe that causes my stutters, not sure how to explain but whenever it runs i have the micro-stutters going heavy, we are talking jumping from 28fps to 19 and so on, drove me crazy initially thought it was something wrong with my machine, but whenever i ran the as2012 no stutters, so started messing around and turns out this file caused it, i know u lose in cockpit ability to listen to weather and stuff but when i terminated this task system runs smooth again.  the CPU load belive it or not with this running is 0, which is even more odd, if i tune it then it will spike to about 5-9% load and drop, so definatly app is not loading my cpu or anything but when its running my fsx stutters, its not running my fsx 30fps all heavy settings with pmdg running.  very odd in deed and not sure how to explain it but could be just me.

 

thanks 

 

 

andrei.

Share this post


Link to post
Share on other sites

Interesting, what if you don't tune to 122.00 do the stutters appear then? I will try this and above suggestions went I get home so you don't  have to kill the app as I can still listen to weather atis via RC4 atc which I've performed many times this way out of habit but the stutters are still there doing it this way as well, stutters on the fly as well turn ASN off stutters gone. To me it seems like a weather injection stutter, as it is rythmic happening in about five minute intervals for a few seconds, all ASN settings are at default weather injection 15min's, I will keep investigating and see what becomes of it

 

Cheers Rod.

Share this post


Link to post
Share on other sites

Rod,

doesnt matter if it was tuned or not. in matter of fact if it was not tuned and just at whatever it was set initialy or default fsx freq, it stuttered heavy, if i tuned it in and listen to info it was visible as well.  So really didnt matter,

 

but i am curious if ur setup does it same after killing that task via task manager.

 

 

thx.

 

 

Andrei

Share this post


Link to post
Share on other sites

To me it seems like a weather injection stutter, as it is rythmic happening in about five minute intervals for a few seconds, all ASN settings are at default weather injection 15min's, I will keep investigating and see what becomes of it

 

After having a good time with ASN initially, on one flight exactly the same happened here:

I blamed it on heavy weather first. I flew FR 5203 on last saturday from LIME to EDFH departing 2013-12-21 0715Z. Significant clouds and rain continuing northbound along the route.

I knew that sometimes there could be slight stutters on my machine on heavy weather using AS2012, but this time it was more like a stroboscope effect with more than 50% freezed time... I noticed that the first two CPU processors for FSX were running 100% while "stroboscoping" appeared. (I have a 4 Core using HT, so FSX is running on CPU 2/3+4/5+6/7 via jobscheduler's affinity mask 84 inside fsx.cfg. So CPUs 0/1 are free for other processes. Up to 100% CPU stress was partially on CPU 2/3 and 4/5, while CPU 6/7 was relatively relaxed...)

So I uninstalled ASN, "refreshed" AS2012 installation and re-flew the mission. The result: only slight stutters, like in the past.

I now have reinstalled ASN, and tried this:

 

Try setting the affinity of ASN to CPU3. After starting ASN, ctrl+alt+del to the task manager. On to the processes tab, right click on the ASN process and set affinity to CPU3. May solve your problem.

 

I set ASN (in my case) to CPU 6/7 and at least running ground preperations for again exactly this flight was quite promising. (I did this test in windowed mode side by side with the performance manager window). I will fly the complete flight again (for the third time) right now to see what happens in full screen mode (nvidia 3D vision2).

 

BTW: just a guess, but probably a combination of ASN's new theme related wx generation (long term frequency) with a couple of other add ons like PMDG NGX/T7, UT2, RCv4, GSX, UTX/GEX etc. is causing more traffic jams on FSX's ascending CPUs due to a lack of internal task spreading (organization/scheduling)?

 

Greetings,

Claus

Share this post


Link to post
Share on other sites

Hi,

 

Please also don't forget to try lowering AA settings. During a smooth cloud redraw, effectively fsx needs to draw double the amount of clouds (both the previous and new clouds slowly altering their alpha value/transparency). This is directly affected by settings like e.g. SGSS (in Nvidia Inspector).

 

Of course, this is not the only reason for freezes. FSInn multicore optimization or aggressive antivirus scanning of radar files produced by ASN are some other reasons we've isolated during these first days after release. For more information, please follow the info we're posting on HiFi forums (and this will be updated as more conflicts/issues are identified)

 

As for the as_audio.exe issue, this must be related somehow to audio device drivers or something. As I said I'd like to investigate why this happens. Andrei, could you open up a support ticket so that we can gather more info?

 

Thanks (and Merry Christmas to all),

 

Kostas Terzides,

ASN developer

Share this post


Link to post
Share on other sites

 

 


I have a 4 Core using HT, so FSX is running on CPU 2/3+4/5+6/7 via jobscheduler's affinity mask 84 inside fsx.cfg.

 

Claus, perhaps I'm misunderstanding what you're saying here, but if you're running with HT enabled, an affinity mask of 84 would enable cores 2, 4, and 6, masking off 0, 1, 5 and 7.  Basically the same as running a mask of 14 with HT turned off as far as FSX is concerned.

 

Scott

Share this post


Link to post
Share on other sites

Claus, perhaps I'm misunderstanding what you're saying here, but if you're running with HT enabled, an affinity mask of 84 would enable cores 2, 4, and 6, masking off 0, 1, 5 and 7. Basically the same as running a mask of 14 with HT turned off as far as FSX is concerned.

You are right in that concern. 84 actually means 2+4+6 for physical cores. But leaving the adjacent hyper cores "off" is reported to deliver better performance than having them all forced "on".

Sorry for that "more than inaccuracy", but I meant core 2,3,4 reserved for FSX....

And related again to the thread: cores 2 and 3 are "exhausted" in that approx. 5 minute frequency...

Greetings,

Claus

Share this post


Link to post
Share on other sites

 

 


Sorry for that "more than inaccuracy", but I meant core 2,3,4 reserved for FSX....

 

No worries, just wanted to be sure you were getting what you thought you were getting!

 

Scott

Share this post


Link to post
Share on other sites

Hello everybody!

 

I hope you all had a nice christmas so far.

I actually got a nice christmas present from this thread as testing around with CPU cores and affinities brought a huge performance improvement in general, not only concerning ASN usage.

And here is the result of flying FR 5203 from LIME to EDFH (see posts above) three more times (it was like "Groundhog Day", but was worth it!):

 

-"every-core" affinity masks like 255 or 254 etc. on 4 cores+HT produce micro stutters, affinity mask 84 (cores 2,4,6) instead runs smooth.

-setting  processor affinity (via task manager>processes tab) for ASN to an "FSX-free" CPU works great! I (using 4 cores+HT) set ASN CPU affinity to CPU 0+1 with FSX runing on CPU 2,4,6. On 4 cores w/o HT this would mean ASN on CPU 0 and FSX on CPU 1,2,3.

-even other apps like RCv4 seem to profit by removing ASN from FSX CPUs.

 

So for the time being I let the apps started by FSX internally (all add ons, dll.xml, exe.xml) run "untouched" and FSX itself is limited by the affinity mask entry inside the fsx.cfg.

"External and manual launchers" like ASN, AS2012 or RCv4 I use after manually setting processor affinity to CPU 0/1 (with HT) or CPU 0 (w/o HT).

 

This easy change not only made the stroboscopic (ASN-) freezes (totally!) disappear, it also gave me the opportunity to add one cloud layer in the ASN settings without noticing a perfomance hit.

 

I hope you get similar positive effects from this change.

 

Greetings,

Claus

 

BTW: I can not confirm any problems with audio drivers or performance issues using 122.000, 122.025 or 122.050. Everything is running smooth here...

 

 

 

 

Share this post


Link to post
Share on other sites

Although this post is in reference to FSXAssist / ASN but we at SkyPilot Software found that ASN works very well with the configuration described

 

That doesnt explain my ASN running on a networked computer and having nothing to do with the FSX dedicated computers X86 program folder.Exhibiting the stutter issue...One thing thast does make sense is the sound btstrp.

Share this post


Link to post
Share on other sites

Just as a FYI as this has nothing to do with ASN - at work I use an expensive remote timeclock software. Had to upgrade my system and after the upgrade the software took almost 45 seconds to execute a command that prior took 2 seconds. Ultimately I tracked it down to some CD burning software that came preinstalled on my new system. Disabled it and timeclock worked perfectly.

 

Point is - check everything - not just flight related software. There was absolutely NO connection between the timeclock software and the cd burning software except that they didn't like each other.

 

Eliminate the obvious but check everything - slowly, step by step - it's the only way.

 

Merry Christmas!

 

 

Vic

Share this post


Link to post
Share on other sites

My computer has nothing and I mean nothing but FSX running on it. 14 processes and 13 of them are MS services and most of them are network related. Also as_audio.exe running. I would almost believe it was something else if I didnt disable ASN on the client machine a quit injecting weather into FSX and the stutters/frame killers go away.

Share this post


Link to post
Share on other sites

ASN performance has nothing to do with OS Priorites or Affinity Masks.  It runs very well with the default settings.  When running ASN with FSXAssist  using RealTime FSX OS priority and an Affinity mask of 1 for Addon Applications ASN performs very well.  Our recommendation is to load ASN as an Addon Application in FSXAssist and set the Addon Application priority to to NORMAL.

 

Regards

Jim Allen

SkyPilot Software

Share this post


Link to post
Share on other sites

Hey there!

 

Been following this thread for a while now since i have exactly the same stuttering issue.

 

Can somebody please explain to me how to change ASNs affinity permanently?

It seems that i have to change it manually everytime ASN is started.

Is there a way to save the affinity setting?

 

Best regards,

Tom

Share this post


Link to post
Share on other sites

Can somebody please explain to me how to change ASNs affinity permanently?

 

Good question. But unfortunately I don't know the answer.

Should be possible via win "exe.-properties" or by a dos "run with options cmd", of which I don't have a real idea....

BTW: setting ASN's processor affinity away from FSX's activities really seems to make sense.

 

Perhaps anybody else?

 

Greetings,

Claus

Share this post


Link to post
Share on other sites

I came across this in another Forum.

Unfortunately it's in German but i'll try to give you the information needed:

 

To set ASN affinity permanently right click on the ASN Shortcut.

Open the properties and change the "Target" line to C:\Windows\System32\cmd.exe /C START "ASN" /affinity 1 "Whatever your ASN folder is"

This worked on my PC.

 

BUT after three flights it seems that it doesnt prevent FSX/ASN from microstuttering.

Still, after some 30-45 minutes into the flight FSX starts to drop Frames.

 

Hopefully this is going to be fixed sometime! :)

 

Best regards,

Tom

Share this post


Link to post
Share on other sites

Installing Steve's DX10 fixer and enabling "Cloud Cull" has increased performance in clouds 10 fold. Even in thick dense cloud, no stutters whatsoever.

Share this post


Link to post
Share on other sites

Usually i'm running FSX at 60 FPS locked with no exceptions. Even in the heaviest weather.

But after changing from FS Global Real Weather to ASN, FSX starts to stutter. But only in some situations

some time into the flight. Restarting ASN then resolves the problem for a few minutes.

 

Tom

Share this post


Link to post
Share on other sites

HIFI has just released an ASN patch update some hours ago. I made a short trip from EDHI to EKBI already with it and I made no changes on any affinity settings. Worked fine so far...

Greetings,

Claus.

Share this post


Link to post
Share on other sites