Sign in to follow this  
max_schuster

Display graphical problem

Recommended Posts

Hey,

 

I have the problem, that when I zoom out in the virtual cockpit I get points and stripes on the displays (see the attached photo). If I zoom in everything is perfect. 

 

But when i set COCKPIT_HIGH_LOD=0 I don't have this problem in any case, but then the resolution of the displays is low and the plane doesn't look that amazing.

 

My graphic card is the NVIDIA GTX 760 and I use Windows 8 - 64bit. I installed the newest drivers and patches, but that doesn't help.

 

 

Thanks for your help!

 

FSX_PMDG737NGX_Graphic_Problem.PNG

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

 

 


I have the problem, that when I zoom out in the virtual cockpit I get points and stripes on the displays (see the attached photo). If I zoom in everything is perfect. 

 

Solution?  It's going to sound stupid, but...

 

Don't use weird zoom levels (0.3 is weird, honestly).

 

 

 

It's simply an artifact of rendering.  When you render things not at their native resolution (zoom level 1.0), things get compromised.  What you're seeing is simply a result of the graphics being compromised by being rendered at increasingly non-native resolution.  Next time you're watching TV, look for people with striped shirts.  You'll see a similar graphic anomaly there, too.

 

Like this:

 

Basically, the lines of pixels (physically) are not equal to the lines on the shirt (as displayed via those pixels).  Zoom in and out will change the severity of this, just like it does in the sim.

Share this post


Link to post
Share on other sites

Thanks for your answer. Then I have a very dumb question. Whats the proper way for zooming out and in. I always hit space and then zoom with the mouse wheel.

Share this post


Link to post
Share on other sites

 

 


Whats the proper way for zooming out and in. I always hit space and then zoom with the mouse wheel.

 

There's no real "proper" way.  What you're doing works, but the plus and minus keys (to the left of the backspace key) work just as well.  Using shift with either plus or minus gives you a little more precision (much like space + mousewheel).

 

I tend to be a little dynamic with my zooming.  I rarely go below 0.7 or 0.8 (and if I do, it's usually in the Majestic Dash, so I can use the tiller but still see out the window).  Remember that, despite the overwhelming simism that you need to see everything all at once, you really don't.  A zoom level of 0.7-1.0 should be sufficient for just about everything, with occasional dips below 0.7, and zooms up to about 1.5.  That's just my own version of a guideline, though.  It's all personal preference, though I'd still caution against anything below 0.5.  The fisheye effect that it gives can distort the graphics, and there's little operational advantage gained from it.

Share this post


Link to post
Share on other sites

That's the same way I zoom most of the time as well and I'm not experiencing that artifact. What is the 'native' resolution of your display? And do you have flight sim set to the same resolution? If not, that's what I would try next. Find out the native resolution of your display and set flight sim to run at that resolution when in full screen mode. If you don't run flight sim in full screen mode then make sure your desktop resolution is set to the same resolution as the native for the display.

 

The artifact that Kyle is describing will only happen with a fine pattern in the image. I doubt that the flat displays in the PMDG panel have a pattern in the background but I could be wrong.

 

The native resolution of my 30" display is 2560x1600 and I usually run FSX at that resolution. But even when running it at 1920x1200 on the same display I have no artifact like that.

 

Dave

Share this post


Link to post
Share on other sites

 

 


The artifact that Kyle is describing will only happen with a fine pattern in the image. I doubt that the flat displays in the PMDG panel have a pattern in the background but I could be wrong.

 

They do have a pattern of some sort, otherwise this artifact would not be appearing. It's made more noticeable if you have terrain turned on.

Share this post


Link to post
Share on other sites

I tend to be a little dynamic with my zooming. I rarely go below 0.7 or 0.8 (and if I do, it's usually in the Majestic Dash, so I can use the tiller but still see out the window). Remember that, despite the overwhelming simism that you need to see everything all at once, you really don't. A zoom level of 0.7-1.0 should be sufficient for just about everything, with occasional dips below 0.7, and zooms up to about 1.5. That's just my own version of a guideline, though.

 

If you haven't seen them, you may be interested in a couple of videos I came across:

 

http://www.youtube.com/watch?v=qjbCFNSofpk 

http://www.youtube.com/watch?v=ikwToOzX_UA.

 

These videos address the question: Given your particular simulation setup  (screen size, etc), what zoom setting will give you the most realistic view outside the window of the cockpit? While admittedly not a particularly important consideration at 30,000 ft, it does suggest what might be a good zoom setting to use on approach, etc. The bottom line the author of the videos comes up with is: 

 

Z=34/[2 atan(h/2d)]   = 17/[atan(h/2d)]  

 

where Z is the zoom setting for the most realistic outside view, h the height of your video screen, d the distance from your eyes to the screen, and atan the inverse tangent.  For my setup, d=32” and h=13.5” so I get Z= 1.43.

 

Just interesting, I thought.

Al

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this