Sign in to follow this  
arnobg

Help from 4770k/4790k users with Nvidia Inspector

Recommended Posts

I've been trying to tweak my new 4790k GTX770 system for what seems forever now and I'm about ready to just give up it's so frustrating. I've followed Nick's guide's as well as many other posts and still am not getting sufficient results as far as graphics quality that I'm looking for. I can't complain about the overall performance but I am not seeing graphics I am happy with. I've spent what seems like hundreds of hours researching and tweaking and  haven't even barely gotten to enjoy the simulator itself because of it.

 

I just don't understand why I am still not getting clean edges on aircraft and why I am getting the dreaded black spikes when panning in spot view. I copied Nick's guide on advanced Invidia Inspector settings and made appropriate changes in the FSX.cfg and I honestly can't tell a single difference besides it taking longer for the scenery bar to load when I start a flight.

 

Any suggestions? Here's my settings that have been changed in my .cfg:

 

[bUFFERPOOLS]
UsePools=1
Poolsize=8388608
RejectThreshold=126976
 
[Display]
ActiveWindowTitleBackGroundColor=0,28,140,64
ActiveWindowTitleTextColor=255,255,255
BLOOM_EFFECTS=0
ChangeTime=4.000000
InfoBrakesEnable=True
InfoLowerLeftBackGroundColor=255,0,0,128
InfoLowerLeftTextColor=255,255,255
InfoLowerRightBackGroundColor=255,0,0,128
InfoLowerRightTextColor=255,255,255
InfoOverspeedEnable=True
InfoParkingBrakesEnable=True
InfoPauseEnable=True
InfoSlewEnable=True
InfoStallEnable=True
InfoUpperRightBackGroundColor=0,0,0,0
InfoUpperRightTextColor=255,0,0
NonActiveWindowTitleBackGroundColor=24,33,87,64
NonActiveWindowTitleTextColor=255,255,255
SKINNED_ANIMATIONS=1
TEXTURE_BANDWIDTH_MULT=120
TransitionTime=4.000000
UPPER_FRAMERATE_LIMIT=30
WideViewAspect=True
 
[GRAPHICS]
AC_SELF_SHADOW=0
AIRCRAFT_REFLECTIONS=1
AIRCRAFT_SHADOWS=1
COCKPIT_HIGH_LOD=1
D3D10=0
EFFECTS_QUALITY=2
GROUND_SHADOWS=0
HIGHMEMFIX=1
IMAGE_QUALITY=0
LANDING_LIGHTS=1
NUM_LIGHTS=8
See_Self=1
SHADER_CACHE_PRIMED=1693500672
SHADER_CACHE_PRIMED_10=1693500672
TEXTURE_MAX_LOAD=4096
TEXTURE_QUALITY=3
Text_Scroll=1
 
[Main]
DisablePreload=1
HideMenuFullscreen=1
HideMenuNormal=0
Location=0,0,1920,1080,\\.\DISPLAY1
Maximized=1
PerfBucket=7
ProcSpeed=10112
SimObjectPaths.0=SimObjects\Airplanes
SimObjectPaths.1=SimObjects\Rotorcraft
SimObjectPaths.2=SimObjects\GroundVehicles
SimObjectPaths.3=SimObjects\Boats
SimObjectPaths.4=SimObjects\Animals
SimObjectPaths.5=SimObjects\Misc
SimObjectPaths.6=SimObjects\IVAO_MTL
User Objects=Airplane, Helicopter

 

[TERRAIN]
AUTOGEN_DENSITY=4
DETAIL_TEXTURE=1
LOD_RADIUS=6.500000
MESH_COMPLEXITY=100
MESH_RESOLUTION=23
TEXTURE_RESOLUTION=29
WATER_EFFECTS=4
 
nvidia1_zpscadc082e.png

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

On my 770, I have dropped all Bufferpools lines, lod at 5.5, and in NI, added 2xSGSS

Share this post


Link to post
Share on other sites

On my 770, I have dropped all Bufferpools lines, lod at 5.5, and in NI, added 2xSGSS

 

I dropped the bufferpool and it definitely cleared some of the black spiking issues so I am happy with that.

 

Are you running this line?

 

[MAIN]

 

FIBER_FRAME_TIME_FRACTION=0.15

 

Would the 2xSGSS help with cleaning up edge lines and such? that is currently my biggest complaint. FPS I am pretty happy with and it seems smooth even with cloud draw on 110mi and during heavy weather sessions with Active Sky Next drawing up to 10 cloud layers.

Share this post


Link to post
Share on other sites

How Ironic.. I too have an i7 4770k with the Nvidia 770 and have been frustrated about achieveing a decent graphical representation.  (even lodging a fault direct to the manufacturer).

Have you tried the very latest 344.11 drivers from Nvidia?

I have 8xQS with 4 x GSS  but have turned off 4 x Grid Super sampling as I was taking too big a hit on performance

 

You could posisbly try out 2x GSS if you find a similar hit with 4xGSS

 From what I can see also, you could try dropping your

TEXTURE_BANDWIDTH_MULT=120 down to 90 or less as a test, and also Increasing

FIBER_FRAME_TIME_FRACTION=0.15 back to the default 0.33 to see if that helps give you more adjustment room

Share this post


Link to post
Share on other sites

My system is pretty much identical to yours and I use exactly 2 performance tweaks:

TEXTURE_BANDWIDTH_MULT=120

HIGHMEMFIX=1

 

As Bert Suggested, you absolutely need to set Antialiasing - Transparency Supersampling to 2x Sparse Grid Supersampling (4x if you can handle the performance hit) in Nvidia Inspector.

You may also want to set NVIDIA Predefined FXAA Usage to Disallowed.

 

In Nvidia Inspector, I also set Anisotropic filtering mode to Application-Controlled.  Anisotropic filter setting to OFF (Linear).  Then select Anisotropic filtering within FSX.

Setting your texture filter in NI is known to cause performance drops around water.

 

I run LOD_RADIUS at 5.5 and TEXTURE_MAX_LOAD at 2048... but that's mainly to avoid OOM issues.  Other than that, all your settings are identical to mine... and I get very good antialiasing.

 

Hope this helps,

M.D.

Share this post


Link to post
Share on other sites

Thanks for the pointers I wil give the settings a try. I am not OC at all just stock 4790k.

 

Right now As you can see above I am not running the fiber frame time reaction I will try that.

 

Are you guys using AFFINITYMASK=14?

 

With the Anisotropic set to application controlled and then selecting it in FSX, what difference does that make from Nick's recommended Trilinear, that's what I am currently using. Is the 8xS anti aliasing correct with this?

 

I have switched to 2x SGSS and havent noticed a hit. I will experiment with 4x.

Share this post


Link to post
Share on other sites

So I updated the Nvidia drivers, put all my settings back in, made some .cfg changes. Performance still seems very good no stutters but I am experiencing some blurry ground textures and textures not looking good further than 3 miles with ORBX. Also no sharp edge lines except at some angles. It's also like my water is not as sharp and detailed as it used to be, but maybe I am imagining that part. This is what I'm getting, should I be happy with this, or am I being way too demanding?

 

.cfg settings:

 

TEXTURE_BANDWIDTH_MULT=120

 

WideViewAspect=True

 

TEXTURE_MAX_LOAD=4096

 

AffinityMask=14

 

FIBER_FRAME_TIME_FRACTION=0.15

 

LOD_RADIUS=5.500000

 

 

 

NOTE: the clean lines in the dawn picture, the terrible lines in the last picture. Also the blurry textures on the ground in the downtown Seattle picture.

 

 

nvidia2_zpsec743e73.png

 

2014-9-21_10-9-49-467_zps0e682fa9.png

 

2014-9-21_10-13-38-124_zpsbd590141.png

 

2014-9-21_10-11-50-175_zps36900a75.png

Share this post


Link to post
Share on other sites

I'd get rid of the FIBER_FRAME_TIME_FRACTION tweak.  If you want sharper textures further out, set LOD_RADIUS to 6.5, but be aware that it might cause out of memory errors with complex aircraft.  Of all the computers I've ever used with MSFS, I've never had to set an affinity mask, compare with and without it and see if it's necessary.  When you get adventurous, try an overclock. My 4790k goes to 4.6 easily (with an after-market cooler).

Share this post


Link to post
Share on other sites

I'd get rid of the FIBER_FRAME_TIME_FRACTION tweak.  If you want sharper textures further out, set LOD_RADIUS to 6.5, but be aware that it might cause out of memory errors with complex aircraft.  Of all the computers I've ever used with MSFS, I've never had to set an affinity mask, compare with and without it and see if it's necessary.  When you get adventurous, try an overclock. My 4790k goes to 4.6 easily (with an after-market cooler).

 

I've been trying to research into overclocking but have never done it. I'd like to learn. I have an aftermarket cooler master EVO already on it. 

Share this post


Link to post
Share on other sites

Can anyone confirm that my anti-aliasing settings should be what is posted in the screenshot "8xS" if I am using 2x SGSS?

 

Still not happy with the settings.

 

Should I be using FXAA on or off? 

Share this post


Link to post
Share on other sites

 

 


Can anyone confirm that my anti-aliasing settings should be what is posted in the screenshot "8xS" if I am using 2x SGSS?

 

It's all setup correctly, yep

 

 


Still not happy with the settings.

 

What exactly? You mean this?

 

 

 


Also no sharp edge lines except at some angles. It's also like my water is not as sharp and detailed as it used to be

 

Keep in mind that adding SGSS helps with shimmering by smoothing edges and the entire view in general. You can't have both antialiased & sharp edges unless you up pixel density somehow

 

 


Should I be using FXAA on or off? 

 

Try it. It blurs everything a lot and doesn't help with shimmering all that much. Personally I don't like it

Share this post


Link to post
Share on other sites

You need to change 8xS to 8xSQ and turn off all FXAA settings.

If you have Hyper Threading on in your bios, then affinity mask should be set to 84 instead of 14.

 

You use:

 

[bUFFERPOOLS]
UsePools=1
Poolsize=8388608
RejectThreshold=126976
 
Get rid off UsePools, Poolsize. Yes, they could increase FPS, but you'll likely see a lot more texture flashes. RejectThreshold doesn't seem to have that problem as long as you use the proper value.

Share this post


Link to post
Share on other sites

This is an automatic message.

 

This topic has been moved from "MS FSX Forum" to "Monitors, Video Cards and Drivers". This move has been done for a number of possible reasons.

  • The most likely reason is that the post was off topic.
  • The topic could also have contained images or a video that were not appropriate to the original forum it was posted in.
  • The images might not have been "illustrative" or "explanatory" in nature.
  • The topic could have been moved because we deemed it to be more appropriately placed elsewhere.
Please ensure that your posts are "on topic" and contain illustrative images or videos as appropriate. Do not post videos or images just for entertainment purposes anywhere but in the screen shot or video forums. See our image posting rules here.

 

Members who continue to post off topic posts can be denied entry to specific forums in order to reduce and remove the practice. Your cooperation is appreciated.

Share this post


Link to post
Share on other sites

Can anyone confirm that my anti-aliasing settings should be what is posted in the screenshot "8xS" if I am using 2x SGSS?

 

Still not happy with the settings.

 

Should I be using FXAA on or off?

You should read the link I posted above as it answers all your questions on AA and Filtering.

Share this post


Link to post
Share on other sites

You should read the link I posted above as it answers all your questions on AA and Filtering.

 

I read it. Did I get it right? You are claiming SGSS does nothing in DX9? 

Share this post


Link to post
Share on other sites

try it!

 

I have in the past, and it does work. I can't try it now cause I switched to AMD.

Hope you know SGSS is not really a transparency AA mode. It was supposed to, but a bugged driver applied it to the full scene, not only transparent textures. When NVidia fixed it in the next driver release people complained and they reverted it back to full scene.

 

http://naturalviolence.webs.com/sgssaa.htm

Share this post


Link to post
Share on other sites

...DX9 is fundamentally different to DX10/DX11 by the way it handles the backgrounds of subimages. SGSSAA is a transparency mode setting of DX10 and DX11.

Share this post


Link to post
Share on other sites

...DX9 is fundamentally different to DX10/DX11 by the way it handles the backgrounds of subimages. SGSSAA is a transparency mode setting of DX10 and DX11.

 

I'm not sure I follow, but I know you know your stuff.

That being said, SGSS is not a transparency mode for all I know (see my post above) so I don't think it matters if DX9, DX10 or DX11

 

There's one thing I know for sure, SGSS works in DX9 overriding the app settings in Inspector and the effect is too obvious to dismiss

Share this post


Link to post
Share on other sites

There's one thing I know for sure, SGSS works in DX9 overriding the app settings in Inspector and the effect is too obvious to dismiss

I'm not seeing that. Post your setup if you can I'll go through it.

Share this post


Link to post
Share on other sites

I'm not seeing that. Post your setup if you can I'll go through it.

 

Sorry, I can't. I'm on a AMD HD7950 now so no Inspector for me, but I have the screenshot with the config I used

 

inspectorUltimate.png

 

That was with a GTX580, the last Nvidia card I owned after a 480 & 460. Obviously 4xSGSS brought it to it's knees

 

Something I never got to figure out is how could 8xSGSS work too with 8xS since that's only 4 multisamples

Share this post


Link to post
Share on other sites

...Nope cannot get DX9 AA to change with any of the Transparency settings and overrides or enhances.

 

...tried your settings exactly and changes to "Antialiasing - Transparency" make no difference. However, changing "Antialiasing - Setting" has a marked effect.

Share this post


Link to post
Share on other sites

...Nope cannot get DX9 AA to change with any of the Transparency settings and overrides or enhances.

 

...tried your settings exactly and changes to Antialiasing - Transparency make no difference. However, changing Antialiasing - Setting has a marked effect.

 

Do you have the AA box ticked in FSX? I know it's counterintuitive when overriding, but some need to have it checked for AA to work properly

Share this post


Link to post
Share on other sites

Well, I tried again with AA set off and on in the sim display settings, no AA changes at all with any transparency setting.

 

...well i'm going back to DX10 now. :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this