Sign in to follow this  
Bozdog

Shimmering Airports - Can anyone help ?

Recommended Posts

When looking at an airport from a distance, they often "Shimmer",  close in they are fine.  Good example  take off from heathrow in default Learjet,  spot view looking back to runway all looks fine,  get to about 4,000 feet slight shimmering and by 5,000 looks like a strobe light at a nightclub.

 

I understand it is likely to be "Antilalising" ?

 

Running on a gtx 680 in surround over 3 screens,  driver 344.48

 

In FSX  Filtering set to "Anisotropic"  Anti -aliasing is NOT TICKED

 

Nvidia Inpsector Settings

Antialiasing - Behavior Flags -  Treat override any application setting as application controlled

 

Antialiasing  Mode - Overide any application setting

Antialiasing  Setting - 8 x SQ (combined 2x2 SS + 2x MS)

Antialiasing Transparancy Multisampling - Disabled

Antialiasing  Transparency Supersampling 8 x Supersampling

Nvidia Predefined FXAA Usage - Disallowed

 

Anisoropic filtering Mode  User/defined/off

Anisoropic  filtering setting 16x

 

Any advise on what  i should change to greatly appreciated,  Just never been able to fix this

 

Cheers

 

Steve

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You have to tick AA in FSX.

 

Change AA Setting to 8xS (combined: 1x2SS + 4x MS)

 

Change AA SS to 4x Sparse Grid SS.

 

I have Texture filtering - Negative LOD bias set to Clamp (suppose to reduce shimmering) but I heard it does not work with the newer video cards.

 

Hope this helps.

 

Best regards,

Share this post


Link to post
Share on other sites

Thanks Firehawk44 , unfortunatly didnt solve.  Appeared to be not quite as bad but  made my text on the menu bar appears very blurry with those settings. If I return to my settings text is crystal clear.   Shimmers between 5000-6,000 feet  flying away from the airport any higher or lower isnt too bad at all.  Does shimmer when a airport is a long way off in the distance though.  After 2 years of tweaking  its just the final issue I have never been able to solve. 

Thanks for your suggestions anyway

 

Regards

Steve

Share this post


Link to post
Share on other sites

Thanks Firehawk44 , unfortunatly didnt solve.  Appeared to be not quite as bad but  made my text on the menu bar appears very blurry with those settings. If I return to my settings text is crystal clear.   Shimmers between 5000-6,000 feet  flying away from the airport any higher or lower isnt too bad at all.  Does shimmer when a airport is a long way off in the distance though.  After 2 years of tweaking  its just the final issue I have never been able to solve. 

Thanks for your suggestions anyway

 

Regards

Steve

Steve,

 

Make sure that the profile (Add application to current profile) is set to FSX. Then try these settings using DX 9:

 

2fITX.jpg

Share this post


Link to post
Share on other sites

Thanks Firehawk44 , unfortunatly didnt solve.  Appeared to be not quite as bad but  made my text on the menu bar appears very blurry with those settings. If I return to my settings text is crystal clear.   Shimmers between 5000-6,000 feet  flying away from the airport any higher or lower isnt too bad at all.  Does shimmer when a airport is a long way off in the distance though.  After 2 years of tweaking  its just the final issue I have never been able to solve. 

Thanks for your suggestions anyway

 

Regards

Steve

Everything is crystal clear for me with those settings. Why do they not work for you? Do you use tweaks in your fsx.cfg? Are your fsx settings set to the max? If you have high fsx settings you will see the blurries occasionally. That's normal with high settings no matter how great your computer system happens to be. FSX just cannot render fast enough in most cases. You have to let your system "breathe". What is truly amazing is that you think that shimmering and the stutters and the blurries will actually go away. You can certainly reduce them but they will not go away completely. Not with an old engine like FSX. I/we can give you suggestions on what resolves the shimmering for me/us but every system is different. You have your system configured one way with a lot of tweaks, another does not use tweaks or high settings and they have no problems. Almost every time I respond to a post like yours, I immediately get the negative, "it didn't work for me". Well, why? Now Jose has been brave enough to post almost exactly the same settings I posted as those settings work for a lot of people. Check out NickN's guides. They are about the same. What about the AVSIM FSX Configuration Guide here on AVSIM. The same. For you? No. They do not work.

 

We have tons of posts and topics here at AVSIM about shimmering airports and scenery objects. I suggest you do a search here in this forum using shimmering as your keyword. You'll get a ton of more suggestions on this topic.

 

Oh well, time to get off of the soap box and get ready for golf.

Share this post


Link to post
Share on other sites

Quite possibly a mipmap issue.  Try some alternative settings for MipBias in the fsx.cfg

Display device section (you have to add the line yourself)

 

MipBias=5 is fairly neutral but try some slightly lower settings too and see if that helps your shimmering.

 

IAN

Share this post


Link to post
Share on other sites

Hi Steve

 

I think your problem is this:

 

'Antialiasing - Behavior Flags -  Treat override any application setting as application controlled'

 

Change this setting to None and all should be well. One point to remember here is that every time I update my video drivers, this flag gets reset so I have to turn it off again after an update.

 

Hope this helps.

 

Cheers

Stu.

Share this post


Link to post
Share on other sites

 

Everything is crystal clear for me with those settings. Why do they not work for you? Do you use tweaks in your fsx.cfg? Are your fsx settings set to the max? If you have high fsx settings you will see the blurries occasionally. That's normal with high settings no matter how great your computer system happens to be. FSX just cannot render fast enough in most cases. You have to let your system "breathe". What is truly amazing is that you think that shimmering and the stutters and the blurries will actually go away. You can certainly reduce them but they will not go away completely. Not with an old engine like FSX. I/we can give you suggestions on what resolves the shimmering for me/us but every system is different. You have your system configured one way with a lot of tweaks, another does not use tweaks or high settings and they have no problems. Almost every time I respond to a post like yours, I immediately get the negative, "it didn't work for me". Well, why? Now Jose has been brave enough to post almost exactly the same settings I posted as those settings work for a lot of people. Check out NickN's guides. They are about the same. What about the AVSIM FSX Configuration Guide here on AVSIM. The same. For you? No. They do not work.

 

We have tons of posts and topics here at AVSIM about shimmering airports and scenery objects. I suggest you do a search here in this forum using shimmering as your keyword. You'll get a ton of more suggestions on this topic.

 

Oh well, time to get off of the soap box and get ready for golf.

 

Hi Firehawk, no my setting are not set to max, far from it, I have never said I expected them to go away just wondered if anyone had managed to solve this particular problem

 

I did do a search before hand but nothing came up that seemed to help in anyway, infact I found very few posts on the subject so will try some different keywords in the search facility.

 

I don’t really understand all these things like aniti alising this, antiscopic that trilinier, bilieniar quadlinier . 2 x xxx mutli gizmo flux capacitor sampling ;-)

 

I don’t know why they don’t work for me, and as you say maybe they never will.

 

I wasn’t being negative I was just stating a fact that they didn’t work for me, I thanked you for your suggestions and did appreciate you giving me advise.

 

Regards

Steve

 

Hi Steve

 

I think your problem is this:

 

'Antialiasing - Behavior Flags -  Treat override any application setting as application controlled'

 

Change this setting to None and all should be well. One point to remember here is that every time I update my video drivers, this flag gets reset so I have to turn it off again after an update.

 

Hope this helps.

 

Cheers

Stu.

Thanks Stu, will have a go tonight

 

Cheers

Share this post


Link to post
Share on other sites

I wasn’t being negative I was just stating a fact that they didn’t work for me, I thanked you for your suggestions and did appreciate you giving me advise.

I did not suggest you were being negative. You gave us a few of the settings you have set and say you are having shimmering. There's a lot more to it than just those settings although it is well known that 2x sparse grid supersampling will get rid of most shimmering and 4x's will get rid of it all at the cost of performance/fps (see page 10 of the AVSIM FSX Configuration Guide).

 

I agree with Stu above that turning off the behavior flag will definitely help. Sorry I missed that. AVSIM put out an AVSIM Configuration Guide to help people like you understand the settings and to set the settings that work for most. You can fiddle with those to your liking but they are very close to being perfect for most computer systems.

 

Best regards,

Share this post


Link to post
Share on other sites

Bozdog, is this happening to you at default airports or addon airports? The reason I ask is because some older add on airports, especially from Aerosoft, shimmer a lot because they didn't mip map their textures and just amount of AA won't help much. Although Aerosoft wasn't the only devs who used to sell airports with no mips, others did it as well, but most new addon airports these days usually include mip mapped textures.

 

If the shimmering is happening at default airports then your issue lays elsewhere in settings as default airports are mipped.

Share this post


Link to post
Share on other sites

Thanks Jim, I have the AVSIM guide its been my main reference item since I got back into FSX a couple of years back but having another look is helpful. 

 

Its almost the same as my settings I have just left 'Antialiasing - Behavior Flags -  Treat override any application setting as application controlled'

 

Reason for this is that I occasionally use FS Pasengers, and this setting effects the quality of the text on the custom guage, my vision is not the best in the world so this just helps me to read it easier.

 

Also I was trying to be consistent and using the same airport in all my testing, but tonight thought lets try another airport incase its the airport thats the issue,  so used ORBX Cardiff that came with Wales.  not a sign of the shimmering anywhere  So may well be just a problem with the odd airport.

 

I am not going to get obsessed with it (again)  I used to with FSP  but now have that turned off, what I can't see I can't worry about.

 

Thanks again for your input it is genuinely appreciated.

 

Regards

Steve


Ah yes,  it was Heathrow add on, tried my Cardiff add on (see previous post)  and all is fine.  I am a bit OCD in trying to get everything 100% right,  default also fine.

 

Aggh simple solutions are sometimes the simplest, I always think something is wrong with my set up , when sometimes it is just its  not me !"

 

Cheers


Sorry I can't seem to"quote post" on my home PC  but thanks jimburke and Jim Young

 

;-)

Share this post


Link to post
Share on other sites

Sorry I can't seem to"quote post" on my home PC

IE11 will not allow you to quote unless you hit the BBCode Mode button in the upper left corner of the post first. Not our fault. Strange it has not been fixed yet as IE11 has been out for some time. No problem with other browsers like FireFox.

 

Thanks for your comments and understanding.

 

Best regards,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this