Sign in to follow this  
Techno

FSX-SE and FS Recorder

Recommended Posts

I have spent hours now trying to get FS Recorder to install into FSX-SE but to no avail, I have managed to get the installer to put the insert into the XML.dll but on starting up FSX-SE I get a compatibility message which from what I have read is normal but, on accepting that message I immediately get another saying Simconect unable to initialise Fs Recorder module. Can anyone out there please provide step by step installation instructions to stop me going insane.

I  am currently trying ver3.1.3.1 of FS Recorder as advised in all the articles I have read.

 

Thanks in anticipation

 

Techno 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I have spent hours now trying to get FS Recorder to install into FSX-SE but to no avail, I have managed to get the installer to put the insert into the XML.dll but on starting up FSX-SE I get a compatibility message which from what I have read is normal but, on accepting that message I immediately get another saying Simconect unable to initialise Fs Recorder module. Can anyone out there please provide step by step installation instructions to stop me going insane.

I  am currently trying ver3.1.3.1 of FS Recorder as advised in all the articles I have read.

 

Thanks in anticipation

 

Techno 

From what I understand is it doesn't work and without an update won't work. This and few other compatibility issues keeps me from installing FSX-SE.

Share this post


Link to post
Share on other sites

Have you installed the SimConnect compatibility programs?

 

G:\Program Files (x86)\Steam\steamapps\common\FSX\SDK\Core Utilities Kit\SimConnect SDK\LegacyInterfaces

  • FSX-RTM
  • FSX-SP1
  • FSX-XPACK

Share this post


Link to post
Share on other sites

Yes, I  installed all simconnects  as advised on the Steam FSX-SE forum and this is as far as I could get, there is a guy on there who says he has got the program running but I just cannot work out how to contact him for the info on how he has managed to do it.

When I say I have installed the simconnects I have gone to their location in the SDK legacy files and clicked on the simconnect windows installers one at a time, I am assuming that is what you have to do  to install them, am I correct in  thinking that's it ?.

 I am a bit of a novice at this, well when I say novice I have been meddling with Flight simulation since ATP and FS98 but my computer skills are limited and like your comment regarding learning, I'm at that age where I forget more than I learn so I do need it written down.

I do not have my Steam Edition installed in the Program Files (86) folder on my C drive it is on a separate drive, my installation is D:\SteamLibrary\Steamapps\common ETC, could this be my problem?.

 

Thanks for the  prompt response

 

Techno 

Share this post


Link to post
Share on other sites

I do not have my Steam Edition installed in the Program Files (86) folder on my C drive it is on a separate drive, my installation is D:\SteamLibrary\Steamapps\common ETC, could this be my problem?.

No, because all of the SimConnect versions are stored in the C:\Windows\winsxs folder:

The version installed by FSX:SE is

x86_microsoft.flightsimulator.simconnect_1ed9da73c880e429_10.0.62613.0_none_6996383860d83d25

The versions installed should also be in there (side-by-side) which is what the ..\winsxs folder is for:

x86_microsoft.flightsimulator.simconnect_67c7c14424d61b5b_10.0.61259.0_none_55f5ecdc14f60568
x86_microsoft.flightsimulator.simconnect_67c7c14424d61b5b_10.0.61242.0_none_e079b46b85043c20
x86_microsoft.flightsimulator.simconnect_67c7c14424d61b5b_10.0.60905.0_none_dd92b94d8a196297

The numbers above in "light green" are the FSX version numbers.

Share this post


Link to post
Share on other sites

I have just checked and they are all there, one for FSX-SE as you state and three for FSX, does that therefore mean that they are all available to FSX-SE programs because from what I have so far been able to ascertain all three must be  installed for FSX-SE.

 

Techno

Share this post


Link to post
Share on other sites

Yes. Many of the add-on products for FSX have modules that rely on earlier versions of SimConnect, which is precisely why Dovetail Games included the installers for the "legacy SimConnect versions."

 

When configured correctly, gauges and modules will "auto-select" the correct version of SimConnect and load it.

Share this post


Link to post
Share on other sites

Thanks Bill for your help on this one, that at least it clears up the question regarding SimConnect installation, I can now rule that out as the problem and look elsewhere.

 

Cheers

 

Techno

Share this post


Link to post
Share on other sites

I was on the fsrecorder website last week and it says that FSX SE Will not work fsrecorder and they don't plan on updating it to work with FSX SE Anytime soon.

Share this post


Link to post
Share on other sites

I also have re reports to that effect but there are also individuals posting that they have managed to get Version 3131 working with limited functionality !.

Just wish those individuals would post detailed instructions on how they managed to achieve it.

 

Techno

Share this post


Link to post
Share on other sites
Every version of FSX (RTM, SP1, SP2, Acceleration) brings it's own version of SimConnect. FS Recorder 1.3x requires the SP1 version of SimConnect, which means, that you need to have FSX SP1 or higher installed! If this version of SimConnect is missing, FS Recorder will not be loaded by FSX.

 

There have been reports, that in some cases the SP1 version of SimConnect is not installed when installing FSX SP2 without installing SP1 before. Below you find a small utility, which shows the installed SimConnect versions, the required one is 10.0.61355.0.

 

 SimConnVersions.zip

Utility to display installed SimConnect versions

(28.07 KiB) Downloaded 1541 times

 

 

 

Visual C++ 2005 SP1 Runtime

 

If the Visual C++ 2005 SP1 Runtime is not installed on your system, FS Recorder might not load. It can be downloaded from the Microsoft website:

 

Microsoft Visual C++ 2005 SP1 Redistributable Package (x86)

 

 

dll.xml file

 

In FSX for every add-on module a launch entry in the file dll.xml is required. The entry for FS Recorder is added automatically by the Setup.msi installer.

 

In some cases the dll.xml file might be damaged by add-on installers. Also there have been reports, that in some cases the order of entries in the dll.xml file can play a role and cause some add-ons not to load correctly.

 

If you can't get FS Recorder working, and you have (or had) other FSX add-ons installed, try one of the following:

 

Download the free FSX DLL.XML Viewer and Repair Utility from the Flight1 website (read the included instructions!) and try to repair the dll.xml file or to change the order of the launch entries.

 

Or, to find out, if the problem is the dll.xml file:

Uninstall FS Recorder, find the dll.xml file on your system, rename it (e.g. to dll.xml.bak), then reinstall FS Recorder using the Setup.msi installer (it will create a new dll.xml file). If FS Recorder works then, it is clear, that the problem is in your original dll.xml file, and you have to repair it or to change the lauch order

 


step 1, Install all the simconnects that DTG doesnt automatically install for you

 

keep in mind these are simconnect.msi files...just double click to install

 

where my FSX:SE is installed into my E:\ drive

there are actually (4) simconnects in FSX:SE

 

E:\SteamLibrary\steamapps\common\FSX\SDK\Core Utilities Kit\SimConnect SDK\lib 

(install this one first)

 

E:\SteamLibrary\steamapps\common\FSX\SDK\Core Utilities Kit\SimConnect SDK\LegacyInterfaces\FSX-RTM

(install this one 2nd)

 

E:\SteamLibrary\steamapps\common\FSX\SDK\Core Utilities Kit\SimConnect SDK\LegacyInterfaces\FSX-SP1 

(install this one 3rd)

 

 

E:\SteamLibrary\steamapps\common\FSX\SDK\Core Utilities Kit\SimConnect SDK\LegacyInterfaces\FSX-XPACK (YOU SHOULD NOT NEED TO INSTALL THIS ONE)

DTG now includes the install for the xpack since the last update/patch

 

the 2nd thing to do is install the C++ redistributable

 

 

 

E:\SteamLibrary\steamapps\common\FSX\_CommonRedist\vcredist\2005

there are 2 files here

 

vcredist_x86.msi (to install for 32 bit)

vcredist_x64.msi (to install for 64 bit)

just double click on the pertinant one for your system,should be 64bit

 

just to make sure it is installed, the XML parser should also be installed, it should have been loaded already by fsx

 

E:\SteamLibrary\steamapps\common\FSX\Installers

msxml.msi

double click this file to install

 

 

then go to your flight menu and test fs-recorder once it is loaded

 

Share this post


Link to post
Share on other sites

There have been reports, that in some cases the SP1 version of SimConnect is not installed when installing FSX SP2 without installing SP1 before. Below you find a small utility, which shows the installed SimConnect versions, the required one is 10.0.61355.0.

Hi, mikeytwc,

 

I have read your post carefully and uninstalled and reinstalled all simconnects in the order you gave. I also reinstalled the FSX-XPACK version since I had uninstalled all simconnects showing in Uninstall programs.

 

Now, in uninstall programs, the following versions are showing:

62615

61259

61242

60905

 

I also searched "simconnect.dll" in winsxs and found the same four versions and no others. (They were still there after the uninstall and are still there now).

 

However I am unable to install the version you say is necessary for FS-Recorder 1-3-3-1 to work, 10.0.61355.0. And FS-Recorder still gives a simconnect failure message when I try to run it.

 

In FSX Steam SDK...Legacy Interfaces/FSX-SP1, the file Microsoft.FlightSimulator.SimConnect.dll exists. Using properties/details, it is the right version of simconnect, ..61355. But when I run the simconnect.msi in the same folder, it installs version ...61242. This version shows when I hover the cursor over the simconnect.msi file.

 

I found the same situation in the FSX Box SDK -- I still have FSX Box installed.

 

I also found another version of simconnect, ...61637,in FSX STEAM SDK ... Legacy Interfaces/FSX-XPACK, but the simconnect.msi installer installs 61259.

 

Please let me know how to install the correct simconnect version.

 

Thanks,

Mike

Share this post


Link to post
Share on other sites

No, because all of the SimConnect versions are stored in the C:\Windows\winsxs folder:

The version installed by FSX:SE is

x86_microsoft.flightsimulator.simconnect_1ed9da73c880e429_10.0.62613.0_none_6996383860d83d25

The versions installed should also be in there (side-by-side) which is what the ..\winsxs folder is for:

x86_microsoft.flightsimulator.simconnect_67c7c14424d61b5b_10.0.61259.0_none_55f5ecdc14f60568
x86_microsoft.flightsimulator.simconnect_67c7c14424d61b5b_10.0.61242.0_none_e079b46b85043c20
x86_microsoft.flightsimulator.simconnect_67c7c14424d61b5b_10.0.60905.0_none_dd92b94d8a196297

The numbers above in "light green" are the FSX version numbers.

 

Bump.....Thank God, a solution for Steam & FS Recorder.

 

FS Recorder was found on starting FSX, asked if I trusted it, but not loaded in to the Add On menu in a free flight.

 

My Steam FSX misconnect version is 15 not 13, : - i.e. x86_microsoft.flightsimulator.simconnect_1ed9da73c880e429_10.0.62615.0_none_6996383860d83d25

 

15 was installed by Steam along with 59: - x86_microsoft.flightsimulator.simconnect_67c7c14424d61b5b_10.0.61259.0_none_55f5ecdc14f60568

 

42 and 05 were both missing from the ..\winsxs folder.

 

x86_microsoft.flightsimulator.simconnect_67c7c14424d61b5b_10.0.61242.0_none_e079b46b85043c20

x86_microsoft.flightsimulator.simconnect_67c7c14424d61b5b_10.0.60905.0_none_dd92b94d8a196297

 

Installed them as above and FS Recorder is working a treat in my FSX Steam edition, I recorded and quick zip through the Mach Loop and then played it back as AI traffic.

 

WOW.. Thanks for the Solution that I've been looking for, for weeks, almost given up.

 

Tally HO.

Rog.

Share this post


Link to post
Share on other sites

Hello,

Can FSrecorder version 2.1 work with FSX:SE or we still have to use version 1? I tried to install 2.1 but it does not work.
Thanks.
Hoang Le

Share this post


Link to post
Share on other sites

I am planning to experiment with it, but I suspect it may need some of the FSX Deluxe / Acceleration components which might be ok if one has the DVD's.

 

Ill be back with news later. 

Share this post


Link to post
Share on other sites

I found FSRecorder 1.331 will not work with a side by side installation, no matter what I did it would not load in FSXSE. I have since converted to a standard install and now it works fine.

Share this post


Link to post
Share on other sites

I followed the first few posts on 

 

C:\Program Files (x86)\Steam\steamapps\common\FSX\SDK\Core Utilities Kit\SimConnect SDK\LegacyInterfaces

 

FSX-RTM FSX-SP1 FSX-XPACK

 

Now it works, WINDOWS 10, STEAM EDITION.

 

However i have only tried this on FS Recorder 1.331 (12.01.2009) version, I will be trying this for a while and see how i get along with it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this