Sign in to follow this  
dr6583

NGX won't initialize, displays dark, buttons don't work

Recommended Posts

Hello,

 

Everything was running fine until yesterday.  Now the NGX loads up with a cold and dark display that I cannot manipulate at all.  No buttons move.  No green initialization in progress countdown.  Reinstalled both FSX and NGX.  Manually installed the 4 Simconnects. The NGX doesn't ask for a license key either.

 

This is FSX:SE on Windows 10.  I have been running this configuration for some time now with no problems.  I cannot identify anything in my system that has changed since it last ran successfully.

 

Thanks,

Darrell Ryan

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

It shouldn't ask for license key unless you manually deactivated it. Reinstalling software creates more problems than it solves. Just sayin'

 

You cannot identify anything that you added/deleted/changed to your computer yesterday? That sure is frustrating, isn't it. I recommend you submit a trouble ticket to PMDG Product Support and let them help you with this one. They have some tools that may be useful in this situation. Report back in the forum once it is squared away and running again, help the next guy with this problem.

Share this post


Link to post
Share on other sites

Have you pressed the Q key to mute FSX on your previous flight? If FSX starts with the sound off, the NGX won't initialize.

Share this post


Link to post
Share on other sites

Have you pressed the Q key to mute FSX on your previous flight? If FSX starts with the sound off, the NGX won't initialize.

 

Personal experience, or something someone told you? I've never heard of this before...

 

If there's no sound card detected, there will be issues, but that's a different problem.

Share this post


Link to post
Share on other sites

 Hi,  something similar happened to me with PMDG 747. If you cannot uninstall it properly before you re-install I think the plane is gone. Could not get 747 re-installed. Gone with the wind...even if I got it re-installed, when you press any buttons/knobs on the cabin, everything just dies. Battery switch also does not work. Hope you have better luck than me.

 

john goncalves

Share this post


Link to post
Share on other sites

I have something similar happen to me but only with certain liveries. They worked before, now they don't initialize. I've tried everything except uninstall. Sorry, I wish I could help :(

Share this post


Link to post
Share on other sites

Personal experience, or something someone told you? I've never heard of this before...

 

If there's no sound card detected, there will be issues, but that's a different problem.

 

Happened to me before Kyle. I can't remember if I read the solution for that problem on Avsim or not (or a PMDG representative for that matter), but it did happen to me when I first got the NGX. The guy who told me also had the same issue.

Share this post


Link to post
Share on other sites

Problem resolved and the fix was simple. I had the NGX set to load by default which is known to cause these problems. I guess I should have read the manual more carefully. Here is PMDG's full response:

 

"There is a known issue within FSX that actually can cause the type of CTD issues you describe when loading an Add on complex aircraft as the default flight in FSX. It was an issue that we attempted to address with the ACES team at Microsoft before the release of the SP2 update for FSX but we were unsuccessful in getting the fix implemented prior to its release. The only known work around is to always load FSX with a default aircraft in a default airport (MS ultralight at Friday Harbor for example) and then select your add on aircraft from the select an aircraft screen. We make this specific recommendation in the introductory section of the manual that came with the product to help users avoid the type of behavior you are seeing. Please make sure you leave your default flight set to a Default aircraft and the issue should be corrected.

 

See here for more information (applies both the J41 and NGX):

http://support.precisionmanuals.com/KB/a90/j41-default-flight-related-issues.aspx"

 

Thanks,

Darrell Ryan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this