Sign in to follow this  
racklefratz

Enabling Prepar3d v3 Frame Rate Counter

Recommended Posts

I'm unable to do it.  Shift+Z, once or repeatedly, has no effect. 

 

Someone here mentioned something about the "standard.xml file".  I looked in it and found the following entry

 

<Entry><Key>SHIFT+Z</Key><Down>READOUTS_SLEW</Down></Entry>

 

which references Shift+Z, but the rest is greek to me.

 

I'm out of altitude and airspeed on this one.  Anyone have a suggestion of how I can get it working?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

in the settings (i think its display settings), do you have the text boxes enabled? You need the check box next to "top right text" or something to that effect (which is a bit ironic being that the fps counter is on the left). If you turn off all text boxes, Shift-z won't work.

Edited by n4gix
Corrected the Shift-Z command.

Share this post


Link to post

Hello,  i'm having the same problem.  I have ticked all the boxes but still no FPS counter.  I'm ticking the correct boxes yes ??

 

 

22015543706_89075de4a2_o.png

Share this post


Link to post

in the settings (i think its display settings), do you have the text boxes enabled? You need the check box next to "top right text" or something to that effect (which is a bit ironic being that the fps counter is on the left). If you turn off all text boxes, ctl-z won't work.

 

Of course even if you tick the text boxes, ctrl-z still won't work to display your frame rate...on the other hand, SHIFT-Z just might.  :wink:

 

Regards

Share this post


Link to post

Of course even if you tick the text boxes, ctrl-z still won't work to display your frame rate...on the other hand, SHIFT-Z just might.  :wink:

 

Regards

I just bang on the keyboard until I get what I want

Share this post


Link to post

While we're on the subject  - legacy tip

 

Open Prepar3d.cfg and change 

 

[TextInfo.2]
FrameRate=1,1
LockedFrameRate=1,2
GForce=1,3
FuelPercentage=1,4
 
to 
 
[TextInfo.2]
AverageFrameRate=1,1
LockedFrameRate=1,2
GForce=1,3
FuelPercentage=1,4

 

Now you get the max/min/average frame rate and most importantly percentage variation. The spot frame rate is almost useless for measurement of tweaks, changes and UI alterations.

 

It's the variation you want to eliminate or reduce to a minimal level.

Share this post


Link to post

Or: replace ALL THREE [TextInfo.#] entries with only this one:

 

[TextInfo.1]
AverageFrameRate=1,1
FrameRate=1,2
LockedFrameRate=1,3
 

Who needs GForce, Fuelpercentage and coordinates anyway!!! (Well, I don't... :wink:) Advantage of doing this is that you can toggle the counter with Shift-Z and you don't have to press it twice to get to the counter and twice again to get rid of it. Of course, if you really want those coordinates etc. you can combine it with the entries above and delete .2 and .3: again, you get a toggle which is far more convenient. For those who only need coordinates and no counter: remove the default .2 and .3 entries.

 

Either way and no matter what you do it is always easier to have only ONE Textinfo in your cfg! Saves a lot of useless key pressing.

Share this post


Link to post

Ok, got it now,  great thank you

Share this post


Link to post

Mine are displayed quite blurry and small. Can this be changed/fixed?

Share this post


Link to post

Mine are displayed quite blurry and small. Can this be changed/fixed?

 

Usually by modifying AA settings takes care of the blurries.

Share this post


Link to post

Mine are displayed quite blurry and small. Can this be changed/fixed?

 

LM have put a drop shadow in V3 under the info text for frame rate, wind, etc. Not a bright move really. Obviously done to make things look more slick, but readability is now very poor, especially if you are using higher than standard res on your monitor. I wonder if anyone knows where the fonts are kept and whether the drop shadow can be removed?

Share this post


Link to post

Exactly Robert, referring to the info text. Silly shadows. How to modify? Hmn...

Share this post


Link to post

You could disable clear type in the Windows display settings. Affects everything though.

 

 

Vic

Share this post


Link to post

Indeed but the fonts are obviously "calling" a drop shadow where there was no call before, so there must be a way of getting rid of them without affecting the windows clear type setting. But where?

Share this post


Link to post

Usually this is an attribute set in the code. Other than disabling clear type, there is no other way unless LM has put a hidden switch parameter somewhere.

 

 

 

Vic

Share this post


Link to post

Shift Z works fine for me. I haven't changed any settings from the default settings after installing P3Dv3, though.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this