Sign in to follow this  
alexcolka

The Alabeo C404 Titan for X-Plane

Recommended Posts

Is that plane like a fly on the wall? Nobody comment about that plane yet, is it good? Very tempted.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

It does look nice indeed.  I wasn't aware it had been released, to be honest.

 

Not sure if it's in the budget for me though.

 

But on the other hand, it'd be nice to fly in FSE.... hmmmm...

Share this post


Link to post
Share on other sites

I'd prefer them to fix bugs on existing Carenado planes before porting more over the X-Plane plataform, like the PC12 (serious lighting issues HSI).

Share this post


Link to post
Share on other sites

I'd prefer them to fix bugs on existing Carenado planes before porting more over the X-Plane plataform, like the PC12 (serious lighting issues HSI).

I keep hearing vague reports of stuff amiss with the HSI, but as of yet (and it's been a while since this plane was published), there has been no serious attempt by anyone experiencing this problem, to narrow it down to a reproducible scenario that I can actually tackle and fix.  As long as that doesn't happen, I don't consider there to be any serious lighting issues, unless we're dealing with isolated cases, where the problem may be related to something completely unrelated.  

Share this post


Link to post
Share on other sites

Hi all,

 I haven't had much time to fly the C404, but four observations...

 

1) When the batt is turned on, most / not all of the interior panel lights already on (The sliders above the throttle quad for example)  instead of completely dark as I load always cold and dark situations. No big deal on that front.

2) The aircraft seems a bit squrllly trying to keep trimmed on descent, when I lower and or raise the throttle....unless this is the way this aircraft behaves. never flown in RL. Again, haven't spent more then a few minutes with her as I had to close the sim due to other obligations, so I may be off a bit here, so please forgive me if so.

Carenado's Caravan used to have a similar issue in FSX a long time ago when first released.   

3) The engine RPM gauge for L /R are reversed. (Right needle reacts to left engine and Left needle reacts to Right engine etc..) 

4) Also, the prop sync switch is on by default when the plane is loaded. Not sure if this is even modeled, but never the less.

 

I think the plane is really nice otherwise. The only couple of nagging things for me is the reversed engine RPM gauge and the reaction to throttle movements.

I hope to get a nice flight in this evening to put her through the paces.

 

Best, Jeff

  • Upvote 1

Share this post


Link to post
Share on other sites

I keep hearing vague reports of stuff amiss with the HSI, but as of yet (and it's been a while since this plane was published), there has been no serious attempt by anyone experiencing this problem, to narrow it down to a reproducible scenario that I can actually tackle and fix.  As long as that doesn't happen, I don't consider there to be any serious lighting issues, unless we're dealing with isolated cases, where the problem may be related to something completely unrelated.  

 

http://forums.x-plane.org/index.php?showtopic=84564&page=30#entry959825

 

Post #299

Share this post


Link to post
Share on other sites

Correction on my earlier post

3) The engine RPM gauge for L /R are reversed. (Right needle reacts to left engine and Left needle reacts to Right engine etc..)  

It's the Manifold Pressure Gauge! Sorry :-(

Anyway, If i get a flight in tonight , I'll report back. Sure others will chime in eventually. 

 

Best, Jeff

Share this post


Link to post
Share on other sites

Thanks Dan!

 You are truly outstanding in the community keeping us informed and handling service.  :-)

 

Best, Jeff

Share this post


Link to post
Share on other sites

This plane is a real pleasure to fly however I don't understand why eat more frames than usual in my case compared to other contemporary Alabeo/Carenado planes.

Share this post


Link to post
Share on other sites

I find this plane extremely heavy on my system as well Alexander. I thought it was just me....it gets worse after time as well. It's strange that I get much better performance with the 777pro / A330 heavies etc... We'll have to wait and see what develops. Love the plane otherwise.

 

Best, Jeff

Share this post


Link to post
Share on other sites

Haven't heard of this phenomenon before... but let's say just for argument's sake, would you be willing to remove some folders from your "custom avionics" folder temporarily, and see if that makes a difference?  (You can actually simply create a subfolder in your "Custom Avionics" folder, and call it "unused", and temporarily place the following items in there, just to get them out of the calculation loop):

 

-A_Popup

-A_Popup_2D

-A_TabSys

-C_Popup

-C_Popup_2D

-C_TabSys

-O_Popup

-O_Popup_2D

-O_TabSys

 

 

I'm wondering whether these might be causing problems on some systems.  Specifically, what I'm looking for is, if you notice slowdown over time, even with these folders removed. (They're the ones that give you the pop-up menus, so you'll be without those for the duration of the test).

Share this post


Link to post
Share on other sites

is Alabeo somehow connected to Carenado? I am extremely happy with every aircraft I bought from the latter, and 404 seems to fit perfectly as twin-props are my favourite. So I could give it a go but can't find any decent review of it  : (

Share this post


Link to post
Share on other sites

is Alabeo somehow connected to Carenado?

 

Alabeo is Careando's little sister.   First came Carenado then came Alabeo 

Share this post


Link to post
Share on other sites

Hi Dan,

Thanks for your suggestion on removing some files, I'll try that later at home, I remember when I power on avionics I lose frames, power off and recover the frames, not sure is this is related to your suggestions. Another thing, is it possible for the next update to make the plane load with all cockpit lights turned off and the radar screen not showing the rainbow test pattern please? (when load the plane in engines running mode).

Many thanks,

Share this post


Link to post
Share on other sites

OK, that'll be reflected for the next release (lights, and test pattern).

 

I've also now put a switch in place to turn off all the lights when the plane starts from cold and dark.  

Share this post


Link to post
Share on other sites

Dan,

Did what you suggested, removed the folders you mentioned from custom avionics to the unused folder (was already there created) and the results were worst, less frames and now the pilots are shown in VC view, so returned the folders to the original location. BTW many thanks for the lights fix for the next update.

Share this post


Link to post
Share on other sites

Ah yes: because one of those folders contains the instructions to hide the pilots when sitting in the pilot's seat.  But you say you got LESS frames... that's strange.

 

Well, at any rate, we're looking into this.

Share this post


Link to post
Share on other sites

Ah yes: because one of those folders contains the instructions to hide the pilots when sitting in the pilot's seat.  But you say you got LESS frames... that's strange.

 

Well, at any rate, we're looking into this.

 

Hey!

Could you tell me which folder/file does that? 

I kind of like the idea of seeing pilot and co-pilot in VC view.

 

Thanks in advance.

Share this post


Link to post
Share on other sites

Saw this on the org today.  Going to be hard to resist, but I've told my wallet it could have a break this month.

 

We'll see how that goes. :smile:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this