Sign in to follow this  
MarkW

Blurry in distance and ring of autogen...any fix?

Recommended Posts

Something that has been really bothering me in P3D v3.2 is the what is happening within the LOD radius and what happens out side of it.  Inside you get very sharp textures and fully populated autogen, outside...blurry flat lands.  It looks really awful with such a sharp demarkation between autogen and then nothing.  I setup a side by side comparison in FSX-SE and I noticed that the distance is also blurry but the autogen is either much smaller or seems to fade evenly in the distance so you don't really notice the abrupt change between autogen and no autogen.

 

Anyway, just wondering if anyone else sees the same thing and is there a fix?  Please note that I have autogen vegetation and buildings in P3D set to "normal" but the effect is the same regardless of level (with exception of off).

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I see the same thing over the rainforest. Just a ring of trees and then nothing. Must be the autogen draw distance.

Share this post


Link to post

I doubt this effect can be completely eliminated, however, it strongly depends on one of the most overlooked P3D variables, i.e. zoom setting. I use a zoom setting of 1.0 in conjunction with Wide-view on, which mitigates the issue considerably. Choosing smaller zoom values makes them more pronounced. At least that's what I observe.

 

Kind regards, Michael

Share this post


Link to post

I doubt this effect can be completely eliminated, however, it strongly depends on one of the most overlooked P3D variables, i.e. zoom setting. I use a zoom setting of 1.0 in conjunction with Wide-view on, which mitigates the issue considerably. Choosing smaller zoom values makes them more pronounced. At least that's what I observe.

 

Kind regards, Michael

Great tip. I will have to mess around with Ezdok to see if I can get that to work

Share this post


Link to post

I use a .90 zoom typically and this effect is still awful. Especially if the sun is low and behind all the houses are lit up then sudden blury darkness at the LOD radius. It almost has me running back to FSX until this improves, but there are so many other great things with P3D I'll live with it.

Share this post


Link to post

Great tip. I will have to mess around with Ezdok to see if I can get that to work

 

Mark I think this helps not sure you are using it - try .3 to .5 and anything in between

 

Place under main category in P3D.CFG file - doesnt matter where as P3D will move it

 

[MAIN]
FIBER_FRAME_TIME_FRACTION=0.35

Share this post


Link to post

I use a .90 zoom typically and this effect is still awful. Especially if the sun is low and behind all the houses are lit up then sudden blury darkness at the LOD radius. It almost has me running back to FSX until this improves, but there are so many other great things with P3D I'll live with it.

Together with Wideview=True? If Wideview=False, there is a corresponding figure to get essentially the same view which last figure depends on the aspect ratio of your montor, though.

 

Would you guys at least agree zoom setting has an influence on autogen/sharp scenery popping or not?

 

Thanks and kind regards, Michael

Share this post


Link to post

Mark I think this helps not sure you are using it - try .3 to .5 and anything in between

 

Place under main category in P3D.CFG file - doesnt matter where as P3D will move it

 

[MAIN]

FIBER_FRAME_TIME_FRACTION=0.35

If you do NOT add this to the config a setting of 0.33 will be used so adding a setting of 0.35 won't make any difference at all.

This setting tells the sim how much time to use for scenery loading. Low numbers will give less time to it, resulting in blurries, and high numbers will give more time to loading, resulting in stutters. I personally don't use the tweak. I also doubt if it helps at all with the mentioned 'ring' because it won't change the LOD in any way.

Share this post


Link to post

I have tried various FFTF but didn't really see any difference.

Share this post


Link to post

Since installing P3D ver 3.23 I've left out the FFTF 

Looking at the mechanics of how it worked in FSX.

 

for a frame rate of 30  which would give 10000/30 = 33.33ms / frame

for a FFTF value of .33 gives a value of 33.33x.33 = 11ms

 

in a 4 core set up

 

core 0 is responsible for fibers

core 1 is responsible for main scheduler

core 2 &3 are responsible for Texture management and object batching

 

therefore the time given for fibers to co-operate with main scheduler is 11ms to render the texture/autogen to cores 3&4.

 

so increasing the FFTF value will give more time and so on.

 

increasing it to .35 = 1000/30 x .35 =11.6 ms

 

I use and good results with

TEXTURE_BANDWIDTH_MULT=33

UPPER_FRAMERATE_LIMIT=33
 
by using the same value means no increase in Texture Loading.
 
I did come across a comment in a posting from 2010 that the reason why the default value of FFTF=.33 was because( after testing )the best time allocation for the Fibers to communicate with the Main scheduler was 10ms.
now this is for FSX back when processors speeds where different.
 
bob

Share this post


Link to post

 

Since installing P3D ver 3.23 I've left out the FFTF 

Looking at the mechanics of how it worked in FSX.

 

for a frame rate of 30  which would give 10000/30 = 33.33ms / frame

for a FFTF value of .33 gives a value of 33.33x.33 = 11ms

 

in a 4 core set up

 

core 0 is responsible for fibers

core 1 is responsible for main scheduler

core 2 &3 are responsible for Texture management and object batching

 

therefore the time given for fibers to co-operate with main scheduler is 11ms to render the texture/autogen to cores 3&4.

 

so increasing the FFTF value will give more time and so on.

 

increasing it to .35 = 1000/30 x .35 =11.6 ms

 

I use and good results with

TEXTURE_BANDWIDTH_MULT=33

UPPER_FRAMERATE_LIMIT=33
 
by using the same value means no increase in Texture Loading.
 
I did come across a comment in a posting from 2010 that the reason why the default value of FFTF=.33 was because( after testing )the best time allocation for the Fibers to communicate with the Main scheduler was 10ms.
now this is for FSX back when processors speeds where different.
 
bob

 

 

Interesting have to try this - found out using those low values such as .1 crashes my sim - thanks 

Share this post


Link to post

You can push trees out a bit further in the cfg and max out the autogen LOD by making the value zero. FFTF and TBM will not increase autogen draw radius.

 

AUTOGEN_BATCH_LOD=2 < 0 draws the maximum autogen

AUTOGEN_TREE_MAX_DRAW_DISTANCE=9500.000000 < this has a hard limit of 12000. or 13000.

AUTOGEN_TREE_MIN_DISTANCE_TO_LOD=2500.000000 < again there is a limit, but can't remember

Share this post


Link to post

 

 


Sorry disagree Fiber works here - blurry without it

Hi Richard, is that your fiber setting "0.35" ?  Thanks

Share this post


Link to post

Hi Richard, is that your fiber setting "0.35" ?  Thanks

 

.4 or .5 works better but tried without and seems the same so maybe it is useless have to test more Lamar

Share this post


Link to post

.4 or .5 works better but tried without and seems the same so maybe it is useless have to test more Lamar

Thanks Rich, will stay tuned.

Share this post


Link to post

Rich,

How did you managed with out blurry?

 

Look at blurry in my screenshot with

FIBER_FRAME_TIME_FRACTION=0.1 and ROD6.5

 

http://imagizer.imageshack.us/v2/800x600q90/923/eVDWqr.jpg

 

Maybe my system and Titan X I dont know but I will tell you one thing that .1 crashes my my p3d every time - I wont try anything below .3 but right now trying without any fiber with these settings

 

TEXTURE_BANDWIDTH_MULT=33
UPPER_FRAMERATE_LIMIT=0
 
Plan on playing with the MULT but so far seems as good as using fiber maybe a bit less scenery blurries 

Share this post


Link to post

I will try . I wonder why 0.1 doesn't  work for you .I have no problem

Share this post


Link to post

I will try . I wonder why 0.1 doesn't  work for you .I have no problem

 

I dont know why either - all I do know is it is terrible here

Share this post


Link to post

 

Maybe my system and Titan X I dont know but I will tell you one thing that .1 crashes my my p3d every time - I wont try anything below .3 but right now trying without any fiber with these settings

 

TEXTURE_BANDWIDTH_MULT=33
UPPER_FRAMERATE_LIMIT=0
 
Plan on playing with the MULT but so far seems as good as using fiber maybe a bit less scenery blurries 

 

 

I didn't see any difference with TBM of 35 but tried 50 just to see and it seemed better.  Not sure what it does exactly but definitely seemed like it blended in better.

Share this post


Link to post

I didn't see any difference with TBM of 35 but tried 50 just to see and it seemed better.  Not sure what it does exactly but definitely seemed like it blended in better.

 

Thanks Mark good place to start I will try that

Share this post


Link to post

I didn't see any difference with TBM of 35 but tried 50 just to see and it seemed better.  Not sure what it does exactly but definitely seemed like it blended in better.

The two work as a multiplier for textures
 
TEXTURE_BANDWIDTH_MULT=66
UPPER_FRAMERATE_LIMIT=33
 66/33=2  ie would double the texture loading
not to sure if this works with unlimited frames. it has been suggested that the TexturemaxLoad value comes into the ball game.
I'm sure when I first installed this latest ver LM have set these two at 30, ie no increase
so I suppose it depends on your system cpu,gpu mem 
bob

Share this post


Link to post

 

The two work as a multiplier for textures
 
TEXTURE_BANDWIDTH_MULT=66
UPPER_FRAMERATE_LIMIT=33
 66/33=2  ie would double the texture loading
not to sure if this works with unlimited frames. it has been suggested that the TexturemaxLoad value comes into the ball game.
I'm sure when I first installed this latest ver LM have set these two at 30, ie no increase
so I suppose it depends on your system cpu,gpu mem 
bob

 

 

Yes the 33 number represents the frame rate setting in sim  0= unlimited - I did not know that till today

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this