Sign in to follow this  
Twenty6

Adjusting course needle on the PFD

Recommended Posts

Hi all,

 

Got a minor annoyance adjusting the course needle on the PFD. CDI=Vor1. Say the current heading is set to 30 degrees and I want to change it to 340 degrees and get there directly (ie: counter clockwise.) Problem is I get stuck on 0 (zero) and am forced to take the long way around to 340 degrees. Starting at 340 degrees and going clockwise past zero works as expected.

 

Anyone (Bert) have the expertise to fix this for Carenado?

 

TIA

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I had never noticed this, but yes, I see the same behavior..

 

Will have a look in the code.

 

Suggest reporting it to Carenado as a bug!

Share this post


Link to post
Share on other sites

OK, found it..

 

If you have my GTN mod installed, go to

 

panel.gtn\EMB505_Gauge\

 

and open autopilot_emb300V4VC.xml with Notepad

 

search for:

 

<!-- Autopilot knobs-->

<Update id="Autopilot_knobs">
    <Script>                
    
    
(L:H850XPCrs1WheelDN, number ) 0 >  if{
    1 (>L:BUFFER_BTN_DIM,number)
    
    (L:CUSTOM_AP_CRS1_KNOB, number) 6 - dnor (>L:CUSTOM_AP_CRS1_KNOB, number)
    (L:G1000_CDISource, enum) 1 ==
    if{  (A:NAV OBS:1,Degrees) --   dnor (>K:VOR1_SET) }
    (L:G1000_CDISource, enum) 2 ==
    if{  (A:NAV OBS:2,Degrees) --  dnor (>K:VOR2_SET) }
         0 (>L:G1000MFDCrsWheelDN, number )
    }        
    
    0 (>L:H850XPCrs1WheelDN, number )
}

 

and add the two missing "dnor"   (no bold text in the xml gauge!)

 

save and you are good to go.

Share this post


Link to post
Share on other sites

... awesome Bert,   one man deep level bug fixer, MOD expert and Product Support (for others aircraft ! )...  if you ever build a plane it would be a cracker.

Share this post


Link to post
Share on other sites

Thanks, but I am like what the Egyptian Tour Guide told us on our visit:

 

"We do not build any cars in Egypt, but we are really good at fixing them..!"

  • Upvote 1

Share this post


Link to post
Share on other sites

 

 


and add the two missing "dnor" (no bold text in the xml gauge!)

 

I really love this place!

 

Thanks Bert. I am in your debt. Starting the second week of my two day reinstall of P3D (new ssd and P3D v3.3.3) and I have not yet included your mods into the Phenom300. But I did find the necessary file and made the changes per your instructions. Works like you knew it would.

 

Again, thanks!

Share this post


Link to post
Share on other sites

 

Suggest reporting it to Carenado as a bug!

LOL good one! I fear these guys moved on quite a while ago.

Share this post


Link to post
Share on other sites

Bert

 

I have version 4.7 of your GTX  installed. I don't see a file labelled autopilot_emb300V4VC.xml in the panel.gtn

 

Did I miss something or am I being real stupid and not looking where I should.

 

Russ

Share this post


Link to post
Share on other sites

Bert

 

I have version 4.7 of your GTX  installed. I don't see a file labelled autopilot_emb300V4VC.xml in the panel.gtn

 

Did I miss something or am I being real stupid and not looking where I should.

 

Russ

 

Should be in the  EMB505_Gauge folder..

Share this post


Link to post
Share on other sites

Bert

 

autopilot_emb300V3VC.xml is there but not ...4...

 

I checked the GTN package you sent and is wasn't there either.

 

Russ

Share this post


Link to post
Share on other sites

Bert

 

I am also missing the autopilot_emb300V4VC.xml. Looks like I am using V3.5.

 

Greg

Share this post


Link to post
Share on other sites

Send me a PM with your email address if you would like the latest version.

Share this post


Link to post
Share on other sites

Hi Bert, I also have added the dnor for the wheelDN, but should it also be added

 

 

to (L:H850XPCrs1WheelUP, number ) 0 >  if{

 

Also?

 

James

Share this post


Link to post
Share on other sites

Hi Bert

 

Reference above topic my input.  I must have had the latest download from Carenado therefor the mod does not apply.

 

I downloaded the Ph300 this week..

Share this post


Link to post
Share on other sites

Hi Bert, I also have added the dnor for the wheelDN, but should it also be added

 

 

to (L:H850XPCrs1WheelUP, number ) 0 >  if{

 

Also?

 

James

 

You can, but it does not make a difference

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this