Jump to content

Sign in to follow this  
VOZ102

Malformed XML

Recommended Posts

Greetings

 

I'm on the latest version etc. I've been trying to get the Feelthere E-Jets v2.0 running in P3D - aircraft works perfect but when I try and save a flight it's always missing some information - no date etc showing except 01/01/01 - please note I don't suspect the problem is unique to the latest version or even V3.

 

i8NCubX.jpg

 

When I try and load the scenario file I get this alert.

CXltIXt.jpg

 

PMDG and other files save fine. Have tried re-installing and flushing the app data etc folders.

 


 

Ofcourse I acknowledge this isn't an aircraft designed for P3D etc but this seems like it has something to do with the way the flight is being saved - not unique to the aircraft .. although I could be wrong.

 

Any thoughts? 

 

It's one of my fav aircraft - would love to get it saving properly.


-Peter Stantin

rb_banner_tech.png

Share this post


Link to post

Thanks for the tip - I also already had it off so that's not it.


-Peter Stantin

rb_banner_tech.png

Share this post


Link to post

Thanks - solved. The ERJ is adding a whole bunch of stuff in the XML - if you amend the XML it fixes it.

 

Left is ERJ - right is PMDG

 

8Ua4gdR.jpg


-Peter Stantin

rb_banner_tech.png

Share this post


Link to post

So, the ERJ is adding their entries below the </SimBase.Documents> closing tag, and appears to be incorrectly formatted as well. :fool:


Fr. Bill    

AOPA Member: 07141481 AARP Member: 3209010556

Interests: Gauge Programming - 3d Modeling for Milviz

Share this post


Link to post

Thanks - solved. The ERJ is adding a whole bunch of stuff in the XML - if you amend the XML it fixes it.

 

 

 

 

What if I don't know how exactly? Any guidelines please?

 

Thanks,

Dirk.

Share this post


Link to post

Hi Voz102.
 

Nowy-3jpg_ahpsepn.jpg bugjpg_ahpnhwa.jpg

 

 

I have similar problem with Sibwings An-2 (FSX also). Could You describe what You do exactly? Did You delete this manually only in each save file with this issue?

 

I see also the data of plane in this save File :

 

Nowy-3JPG_ahrresh.jpg

 

I havent any problems with save with other addons. Just with An-2.


Webmaster of yoyosims.pl.
Yoyosimsbanner.gif
Win 10 64, i9 9900k, RTX 3090 24Gb, RAM32Gb, SSD M.2 NVMe, Predator XB271HU res.2560x1440 27'' G-sync, Sound Blaster Z + 5.1, TiR5 [MSFS, P3Dv5, DCS, RoF, Condor, IL-2 CoD/BoX] VR fly only: HP Reverb v2

Share this post


Link to post

Just copy then delete the </SimBase.Document> and move it to the very last line of the xml and it should work; well it did for the ERJ


-Peter Stantin

rb_banner_tech.png

Share this post


Link to post

Just copy then delete the </SimBase.Document> and move it to the very last line of the xml and it should work; well it did for the ERJ

 

Thanks for quick answer! I did two test, if I delete all data after </SimBase.Document> ([sWAN2] ect....) works ok, no problem with save - or if I take </SimBase.Document> and cut and past in the end (after this datas of airplane) works ok too.

Pity only that is to do manually necessarily but finaly it works! Thank You.


Webmaster of yoyosims.pl.
Yoyosimsbanner.gif
Win 10 64, i9 9900k, RTX 3090 24Gb, RAM32Gb, SSD M.2 NVMe, Predator XB271HU res.2560x1440 27'' G-sync, Sound Blaster Z + 5.1, TiR5 [MSFS, P3Dv5, DCS, RoF, Condor, IL-2 CoD/BoX] VR fly only: HP Reverb v2

Share this post


Link to post

Elaine,

Thank you, fixed my malformed XML file.

Jerry Friz


“The Wright Brothers created the single greatest cultural force since the invention of writing. The airplane became the first World Wide Web, bringing people, languages, ideas, and values together.” – Bill GatesBoeing777_Banner_Pilot.jpg

Share this post


Link to post

Thank you very much Peter, I was going crazy with this problem and I could not solve it in any way, I tried to install and uninstall, then I thought it was the migration tool's fault. I have been going on with this problem for days.

Then the brainstorm!

Just move the </SimBase.Document> line to the end of the XML file. And solved, file loads perfectly.

However every time you save the flight again the file is saved with the same error (it's malformed), is there any way to correct it or is there any tool that can do this conversion job?

Thanks very much for all, you saved my flights!


Riccardo

OS: Windows 10-64 bit, CPU: i7-7700K @4.20 GHz, GPU: Gigabyte GeForce GTX 1080 G1 8GB GDDR5, RAM: Corsair Vengeance DDR4 32GB 3000MHz, MB: MSI Z270

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    34%
    $8,535.00 of $25,000.00 Donate Now
×
×
  • Create New...