Sign in to follow this  
specialist

Video slices as you pan around

Recommended Posts

Has anyone had the problem of looking around your cockpit in P3D v3, and noticing your view slice your aircraft as you pan? My setting work great for me, smooth frame rates, not blurry or stuttering, but for some reason, as I pan my view, a sharp quick split before getting back to normal.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

VSYNC is on, still have the same issue. Never had this problem in FSX. But that G Sync monitor is what I might have to be looking at. Didn't know what the hell it was causing my problem, to discovering what a big difference a G Sync monitor makes, however, they are not cheap.

Share this post


Link to post

VSYNC is on, still have the same issue. Never had this problem in FSX. But that G Sync monitor is what I might have to be looking at. Didn't know what the hell it was causing my problem, to discovering what a big difference a G Sync monitor makes, however, they are not cheap.

 

Nevertheless it seems clear VSYNC isn't activated so you need to figure out why. You can try setting it on in nvidia control panel or nvidia Inspector.

Share this post


Link to post

Not so, Mark. VSYNC is active. It's active in P3Dv3, NVidia control panel, and inspector. I'm using GeForce GTX 970, and driver is up to date, version 372.70. I think Massimo is right, G Sync Monitors is the way to go. I'm looking at one now, preferably one at 165hz, but if not, 144hz.

Share this post


Link to post

I had major issues with screen tearing when I first installed my 4K monitor. Took me a while of fiddling with different settings, but I was eventually able to fix it.  Can't remember exact settings that fixed it, but I think it was a combination of switching my monitor from 60 to 30 mhz and increasing max pre-rendered frames in NVIDIA Control Panel so you might give that a try.

Share this post


Link to post

Not so, Mark. VSYNC is active. It's active in P3Dv3, NVidia control panel, and inspector. I'm using GeForce GTX 970, and driver is up to date, version 372.70. I think Massimo is right, G Sync Monitors is the way to go. I'm looking at one now, preferably one at 165hz, but if not, 144hz.

 

Perhaps we have a semantic issue here. I'm sure you have tried to activate VSYNC but if it was active you would not be getting tearing. That's what it is for.

Share this post


Link to post

Because P3D runs as a borderless window, not true fullscreen mode, you need to be using an aero theme for windows.

Right click your desktop, choose Personalize, and then choose one of the aero themes.

This theme you can then modify to your liking.

 

Using an aero theme makes sure the Desktop Window Manager (DWM) is active, which handles vsync.

Share this post


Link to post

Thanks Peter, when I get home I will try and change my windows theme to aero and see if that helps.

Share this post


Link to post

Thanks Peter, once again. That was it, I changed the theme to aero, and now I'm not getting any screen tear!  You saved me a good $300 to $800, in not having to invest in a new G Sync monitor.

Share this post


Link to post

Because P3D runs as a borderless window, not true fullscreen mode, you need to be using an aero theme for windows.

Right click your desktop, choose Personalize, and then choose one of the aero themes.

This theme you can then modify to your liking.

 

Using an aero theme makes sure the Desktop Window Manager (DWM) is active, which handles vsync.

 

Peter, you solved one of the most annoying things I had in P3D!!  Thanks much for this tip!  (I wasn't running an Aero theme)

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this