Sign in to follow this  
DarrianCZE

P3D V3.3 - Nvidia DSR

Recommended Posts

Hello guys,


 


does anyone of you use DSR like an alternative to Antialiasing, which can be hard on frames. Do you have any recommended settings or tips?


 


Or should I forget it, and use AA instead?


 


I have a pretty powerful GPU (Nvidia GTX980).


Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi there,

 

Your GPU will handle this no problem!

 

I use DSR 2x/33 as my default A.A. platform wide.

 

All of my screen shots has this in play. I have totally deleted all nVidia Inspector files associated with FSX, P3D, but have left for FS9, as you still need it, as DSR does not allow for full screen usage in FS9, (non-native) on W10.

 

WIth using DSR, having any other layer of A.A. or view-clean up by use of the nVidia driver mask, or nVidia Inspector...IMHO,is overkill, and adds non-required burden upon your processing pipe-line.  DSR hands you a superb video visual, by use of itself alone, in playl!!!

 

Set all your nVidia driver masks that reference A.A. to Application Controlled.  Turn on DSR, and set for 1.5x and 2.0x--use the default 33 for smoothing.  Press Apply...and close out the mask. I'd reboot the system.  To use DSR..you DO NOT change your Desk Top resolution before you fire up your sim. If you try 1.5 and 2.0, you will see under your sim resolution (in sim) the two new settings.  You turn them on from there.  Your sim in FULL SCREEN will now be at the new and higher res.

 

When you exit your sim, it will save that resolution setting in your .cfg file.  When next using your sim platform, it will be at your selected DSR resolution.

 

Your Desktop will revert back to your native resolution, after the sim closes. In the case (sometimes) that it does not...THEN, you use the nVidia driver mask and go to Change Desk Top resolution, and then click on your native res. Your Desktop will turn back to that, and then---- you press keep this res...and there you go. Sometimes when using DSR, and after your sim exits, your Desktop will not turn back to native. This is the way you correct that, with no worry about corruption....

 

A good example of DSR 2x-33 (smoothing factor) is my screen shot portfolio for Key West Intl. on the Screen Shots Forum.  Look at the plane, and all ground elements. They are without jag...totally clean. :)  No other A.A. processing or video enhancing element is in play. Good looks, and smooth animation performance to boot!

 

Hope this helps.  :hi:

  • Upvote 1

Share this post


Link to post

This had helped greatly. I've tried it... and AA is great, and I have almost 20 FPS more than previously :D Thanks :-)

Share this post


Link to post

I tried DSR right now, and I cannot get it to anything good looking. The thing ain't working as far as I can tell, if I set it to 2.0, it will give me 3840xsomething resolution, I set that (in the sim of course), go to full screen in the sim, and I have:

1) blurry screen

2) big mouse cursor

4) less fps (I think, it's stuttering more at least...)

5) no better picture (it's worse actually...)

 

Any ideas?

Share this post


Link to post

This resolution is actually 4.0 DSR... not 2.0. DSR to 4.0 setting actually have me big mouse cursor too :-)

Share this post


Link to post

Well, I get that resolution if I set 2.0, don't know how else to explain it better...

I am on the native res 2560x1440, so maybe that's the reason.

If I set to 4.0, I get 5000+ pixels res.

And I tried most of settings, and setting the res in the sim, all produced same blurry image.

Share this post


Link to post

This had helped greatly. I've tried it... and AA is great, and I have almost 20 FPS more than previously :D Thanks :-)

I knew you would love it...and most welcome.

 

DSR (whatever) is all ya need..

 

Happy, beautiful lookin' flights!

 

Mitch

I tried DSR right now, and I cannot get it to anything good looking. The thing ain't working as far as I can tell, if I set it to 2.0, it will give me 3840xsomething resolution, I set that (in the sim of course), go to full screen in the sim, and I have:

1) blurry screen

2) big mouse cursor

4) less fps (I think, it's stuttering more at least...)

5) no better picture (it's worse actually...)

 

Any ideas?

Certainly sounds like something is amiss.   Try 1.5/33 or as someone posted try 25 smoothing.  Did you delete all your other files that would impact the end result?   Did you delete all your nVidia Inspector FSX or P3D files?  You need to also turn your nVidia Inspector GLOBAL settings to all default. You do NOT need to delete that...and don't!

 

You only want DSR to enhance/direct upon your vid output.

 

If you followed my instructions, you should have excellent results.  Of course, you need a powerful GPU card to drive the resolution...

Share this post


Link to post

I also run a 2560x1440 monitor. I have tried DSR 2.25 and get poor results. I get the option to select 3840x2160x32 in the sim which I do.

 

I also see a slightly larger mouse cursor and a slightly blurry view on the screen. Not clear and sharp. I have never installed Inspector and never made changes to the NVidia Global settings. This is a brand new fresh install of Windows 10 and P3D 3.4.9.

 

I also tried DSR 1.5 and 25% smoothing. Which gave an odd 3135x1764x32 resolution option in P3D which subsequently crashed to the desktop. I don't suffer PC crashes well..... :-( :-( :-(

 

Followed Sesquashtoo's tips above to the tee. I guess DSR only works for some. Maybe 1440P monitors don't respond as well as 1080P. Not going to continue experimenting either, not after P3D crashed on me.

Share this post


Link to post

 

 


never made changes to the NVidia Global settings

There is two settings in Nviidia Global settings,you should set Multi Display acceleration to "Single performance mode and Power Management Mode: "Prefer max performance"

Those settings are a must.

Share this post


Link to post

I also run a 2560x1440 monitor. I have tried DSR 2.25 and get poor results. I get the option to select 3840x2160x32 in the sim which I do.

 

I also see a slightly larger mouse cursor and a slightly blurry view on the screen. Not clear and sharp. I have never installed Inspector and never made changes to the NVidia Global settings. This is a brand new fresh install of Windows 10 and P3D 3.4.9.

 

I also tried DSR 1.5 and 25% smoothing. Which gave an odd 3135x1764x32 resolution option in P3D which subsequently crashed to the desktop. I don't suffer PC crashes well..... :-( :-( :-(

 

Followed Sesquashtoo's tips above to the tee. I guess DSR only works for some. Maybe 1440P monitors don't respond as well as 1080P. Not going to continue experimenting either, not after P3D crashed on me.

worked great when i had my 1440p monitor. 25% smoothing at 2.25x

 

it will look 'smoothed', if its too blurry, reduce the smoothing %. if you reduce it too much it looks bad though.

Share this post


Link to post

Remember to tick black out desktop or DSR will not work

 

You know it works when the menu bar and the red info text become smaller

Share this post


Link to post

Guys, Sorry to bring this up, is running 2x dsr with 25% smoothness okay for my monitor which has native resolution of 1920x1200? Just experimenting with settings, that's all. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this