Sign in to follow this  
Keven Menard

[Quick Fix] Aerosoft Airbus

Recommended Posts

Those fixes are temporary. We plan on working with other developers to make ChasePlane compatible without having to modify configuration files.

 

If you are having issues with views on the Aerosoft Airbus, follow these steps:

  1. Launch your simulator and load an Aerosoft Airbus aircraft
  2. Make sure to disable the View System from the First Officer MCDU (Options > Views)
  3. Close the simulator
  4. Navigate to your SimObjects\Airplanes\(Aerosoft Airbus A318_A319 Base|Aerosoft Airbus A320_A321 Base)\Panel_Fallback\AB_Systems folder
  5. Rename the file called "View.xml" to "View-old.xml"
  6. Restart the simulator and test camera switches using ChasePlane

Issues with another aircraft?

http://www.avsim.com/topic/498124-quick-fix-issues-where-cameras-are-not-changing-properly/page-0

  • Upvote 3

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Keven,

 

Thanks for the quick fix and the small updates in a day-time.

Really enjoying this software  :smile:

Share this post


Link to post
Share on other sites

Hi Keven,

 

Your fix seems to fix the problem mentioned, thank you. :)  But somehow the zoom function while setting up the presets does not work with the Aerosoft Airbus. Any ideas?

 

Regards

Timothy

Share this post


Link to post
Share on other sites

But somehow the zoom function while setting up the presets does not work with the Aerosoft Airbus. Any ideas?

 

Is it specific to the Aerosoft Airbus?

If not, feel free to create a new thread

Share this post


Link to post
Share on other sites

Is it specific to the Aerosoft Airbus?

 

It seems to me. Zoom function works flawless for PMDG 737 and 777.

 

Regards

Timothy

Share this post


Link to post
Share on other sites

It seems to me. Zoom function works flawless for PMDG 737 and 777.

 

If you right click while in the cockpit, is the camera set to ChasePlane On-Board or another view?

Share this post


Link to post
Share on other sites

Does this fix the issue that on Airbus X I cannot use ROLL in the CAM? It did not work on PMDG and Airbus X, but works on default planes for me.

Share this post


Link to post
Share on other sites

Does this fix the issue that on Airbus X I cannot use ROLL in the CAM? It did not work on PMDG and Airbus X, but works on default planes for me.

 

the camera roll axis should work regardless of the aircraft

Share this post


Link to post
Share on other sites

With that "Change the line Hotkeyselect=4 to //Hotkeyselect=4" I fixed my outside view in the freeware manfred jahn C-47 and A2A planes.

Outside view works now.

  • Upvote 1

Share this post


Link to post
Share on other sites

Keven,

 

I use the FSLabs A320X in FSX-SE with no problems. Initially, I had a problem with Outside ChasePlane view, but I then commented out all the Hotkeyselect instance in the IAE and CFM aircraft.cfg files.

 

However, in my case these files were in SimObjects\Airplanes\FSLabs A320 CFM\ and SimObjects\Airplanes\FSLabs A320 IAE\, respectively. There are no \Panel_Fallback\AB_Systems in my FSLabs installation.

Share this post


Link to post
Share on other sites

The suggested fix for the Aerosoft Airbus did not work for me.

 

I have found that the Focal camera control works fine if the cockpit view is set to On-Board(ChasePlane) and not Glareshield Main Panel.

I did this by right clicking in the VC view and selecting Cockpit View then On-Board(ChasePlane).

 

 

But, if I set the view to Cinematic, or just exit the sim and come back to the Airbus, the default view is set back to Glareshield Main Panel.

 

Does anyone know how to make the default view On-Board(ChasePlane)? I think that would solve the problem.

 

 

Share this post


Link to post
Share on other sites

Keven,

 

I use the FSLabs A320X in FSX-SE with no problems. Initially, I had a problem with Outside ChasePlane view, but I then commented out all the Hotkeyselect instance in the IAE and CFM aircraft.cfg files.

 

However, in my case these files were in SimObjects\Airplanes\FSLabs A320 CFM\ and SimObjects\Airplanes\FSLabs A320 IAE\, respectively. There are no \Panel_Fallback\AB_Systems in my FSLabs installation.

 

Likewise I do not have the path mentioned in the original post.  I will try by using the paths/files mentioned by SierraDelta

Share this post


Link to post
Share on other sites

Likewise I do not have the path mentioned in the original post.  I will try by using the paths/files mentioned by SierraDelta

 Confirmed that SierraDelta is correct and that his fix works for FSL Airbus.

Share this post


Link to post
Share on other sites

For the Aerosoft Airbus specifically, go into the panel.cfg (for each version) and comment out the line that starts and ends...

 

gauge46 [...] AB_Systems!View,0,0,1,1

 

 

Just put a double slash before it.

 

//gauge46...

 

This should be a better fix without having to tinker mcdu menus and renaming xml files. Also this fix is very easy for Keven to implement in Chaseplane "check" routine, because i highly doubt Aerosoft will ever change anything regarding their view systems (A330 will have the same).

 

Also as a "Check" routine should be implemented a Hotkeyselect conflict finder that scans every aircraft.cfg to remove potential conflicts.

Share this post


Link to post
Share on other sites

We suggest our method because it requires 2 file rename instead of having to find and comment 7 lines in a file located in 7 different folders.

 

This is indeed something we plan on auto-fixing in the very short future.

Share this post


Link to post
Share on other sites

^^^  Good to hear re the Airbus.  I have *temporarily* decided to wait for "the real thing" from the dev, but it is so good to read other experiences and "fixes".  Thanks for a good alternative product.  Regards.

 

M.

Share this post


Link to post
Share on other sites

The suggested fix for the Aerosoft Airbus did not work for me.

 

I have found that the Focal camera control works fine if the cockpit view is set to On-Board(ChasePlane) and not Glareshield Main Panel.

I did this by right clicking in the VC view and selecting Cockpit View then On-Board(ChasePlane).

 

 

But, if I set the view to Cinematic, or just exit the sim and come back to the Airbus, the default view is set back to Glareshield Main Panel.

 

Does anyone know how to make the default view On-Board(ChasePlane)? I think that would solve the problem.

 

 

I am having the same problem it keeps returning to Glareshield Main Panel instead of On-Board(ChasePlane) when i switch between external and internal views.

Share this post


Link to post
Share on other sites

I am having the same problem it keeps returning to Glareshield Main Panel instead of On-Board(ChasePlane) when i switch between external and internal views.

 

I solved it by commenting out all of the Hotkeyselect = statements in the aircraft.cfg file. They now look like this //Hotkeyselect =1.

They are in the // ------------ Internal Camera Defintitions ------------------- section of the aircraft.cfg file for the model you use.

There were many of them. Now it works.

Share this post


Link to post
Share on other sites

I solved it by commenting out all of the Hotkeyselect = statements in the aircraft.cfg file. They now look like this //Hotkeyselect =1.

They are in the // ------------ Internal Camera Defintitions ------------------- section of the aircraft.cfg file for the model you use.

There were many of them. Now it works.

 

 

Lifesaver! thanks for the help man.

Share this post


Link to post
Share on other sites

The zoom doesn´t work for me in the Aerosoft Airbus.

Plus, today upon startup, an update has installed automatically, and therefater, all my control and key bindings were gone or messed up.

Share this post


Link to post
Share on other sites

The zoom doesn´t work for me in the Aerosoft Airbus.

Plus, today upon startup, an update has installed automatically, and therefater, all my control and key bindings were gone or messed up.

 

1: Make sure you use it while in On-Board (ChasePlane) view, otherwise it's not going to work.

2: We have updated the keyboard Control system, forcing a reset of control bindings for keys. Apologies for that.

Share this post


Link to post
Share on other sites

1: Make sure you use it while in On-Board (ChasePlane) view, otherwise it's not going to work.

2: We have updated the keyboard Control system, forcing a reset of control bindings for keys. Apologies for that.

Ok, now it works!

Thanks for the fast answer! ;-)

And, no Problem with the new control system. As long as it won´t change with every single new update! ;-)

Keep up the great work!

Share this post


Link to post
Share on other sites

And, no Problem with the new control system. As long as it won´t change with every single new update! ;-)

 

I think we're done now hahaha

Share this post


Link to post
Share on other sites

I think we're done now hahaha

That´s cool!

Not a biggie anyways! ;-)

I really enjoy your software! It enhances my simulator experience significantally!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this