Sign in to follow this  
Followers 0
piperarrow41

fsx-ms
GTX 1070

10 posts in this topic

I updated my graphics card from a GTX 670 to a GTX 1070 and while I am getting a little better performance it isn't what I expected.  With the Flight1 Mustang in cruise at 36,000 feet I am getting about 30 FPS, on the ground it is 25-30 fps.  Full screen runs smoother than windowed mode, but I get better fps in windowed mode and when put my mouse cursor over the menu bar on the top my frames jump to way over 100 fps.  I have NVidia Inspector setup correctly (at least I think so, nothing seems to make a difference in NI).  Anyone have any suggestions?

 

Thanks,

 

John

0

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

A large factor would be what CPU you have.

 

Before my i5 6600k, I had a 2500k at 4.5ghz and went from a GTX670 to a GTX970; my fps improved slightly (~2-3fps) in normal situations, noticeably in cloudy ones (~3-5), and in intense situations like the PMDG 777 and payware airports I could lock to a solid 30 and only see a dip to 28-29 occasionally.

 

I may be completely wrong as every system is unique, but I get the best results when in the nvidia settings (or NV control panel) I put on Prefer Maximum Performance, Adaptive Half V-Sync, Maximum Pre-rendered Frames to 1, and for some reason Triple Buffering seems to really help smoothness.

 

On the full screen vs windowed mode, you might have to mess with the .cfg and add ForceFullScreenVSync=1 or ForceWindowedVSync=1 in the graphics section and test to see if it makes a differece

0

Share this post


Link to post
Share on other sites

I have tried many different settings and configurations in NI and it just doesn't seem to make any difference.  My processor is a I7 3770K overclocked to about 4.4.  It seems like 30 FPS is all I can get out of it in any plane.  It is very stable at 30 FPS, but I thought it would be better.

0

Share this post


Link to post
Share on other sites

I was under the impression that FSX does not utilise the GPU all that well? If that's the case, then your GTX 1070 is probably reading War and Peace while it waits for an instruction to process.

0

Share this post


Link to post
Share on other sites

With FSX, stability and rapid scenery refresh is what you should expect from a faster GPU (along with visuals like AA, SGSS,  and clouds etc..).

 

The CPU is what provides the 30 fps  (broadly speaking).

0

Share this post


Link to post
Share on other sites

^ Yeah what Bert wrote.

 

I personally feel that as long as you have a ~60hz refresh monitor, a constant 30fps is the best you'll get to be smooth and worth tweaking for... (not sure what you have but I assume similar). I can hold 35-40 fps with no framerate lock with my current rig, but it's stuttery. Maybe if I had a 70hz monitor and did 1/2 v-sync it would work as well as a 60hz monitor and 30fps, but I won't know.

 

I'm beginning to use X-Plane now since it utilizes my hardware well and offers some different features. Your 1070 would do well with it, if you were ever interested. For now, I'll come back to FSX every now and then however all I can really expect is to add more payware or crank up the settings and not see a decrease in performance below 30fps, which is fine with me

0

Share this post


Link to post
Share on other sites

Thanks for the feedback, it is very smooth at 30 fps and will stay locked in even with demanding aircraft and scenery.  I do have XP11 and my frames on that sim are well over 100 with everything maxed out, but I prefer FSX because there are more add-ons available.

 

I have a new problem and am pretty sure it is related to a setting in NI.  I am getting a stutter (about 1 second intervals) with select aircraft, mostly Carenado planes (Chieftain,  Hawker 850) and the Milviz Cessna 310 which is the worst.  Any idea what setting would be causing that?  VSync and triple buffering is off.  It has happened before, but went away with a fresh driver install, I am pretty sure all the tweaking I did today is what caused it, just don't know which one.

 

Regards,

 

John

0

Share this post


Link to post
Share on other sites

I just noticed that the Base Clock Offset option in Nvidia Inspector is set way to the left at about -100.  Shouldn't this be centered on 0 for stock performance?  The GPU is only running at about 50%. 

0

Share this post


Link to post
Share on other sites

I would just set up your fsx and nvidia inspector as for the AVSIM set up guide, The graphics card is not really used that much within FSX, I very rarely hear the fans kick in on my GTX970

0

Share this post


Link to post
Share on other sites

I just noticed that the Base Clock Offset option in Nvidia Inspector is set way to the left at about -100.  Shouldn't this be centered on 0 for stock performance?  The GPU is only running at about 50%. 

My 1070 is the same but the clocks are correct (left side). Most likely NI is not yet compatible with the new hardware architecture. I wouldn't touch that setting with a 10 foot pole unless you want to brick the card. 

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0