Sign in to follow this  
Chock

Problem with Pro ATC X

Recommended Posts

When I set up a flight from Manchester (EGCC) in FSX-SE, I have to start Pro ATC X talking to me by contacting Clearance on 121.750, but the ATC window has Manchester Clearance on 121.700, so if I tune 121.750 I don't get the option to contact Clearance in the ATC window, this means I basically can't start Pro ATC X control for the flight.

 

Anyone know how to fix this?

  • Upvote 1

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Maybe since it gets all scenery info including frequencies when running makerunways, is it possible it needs to be re-run after installing an EGCC scenery?

Share this post


Link to post
Share on other sites

after  each scenery or  airports  you need  to run the   makeways  exe 

Share this post


Link to post
Share on other sites

Cheers for the replies, already tried that one though, made no difference to the freqs.

Share this post


Link to post
Share on other sites

UK 2000 V2 add on. I can work around the issue, but it's still a PITA.

Share this post


Link to post
Share on other sites

You CAN change the frequency in Airport Design Editor if you are familiar with it. But I'd strongly suggest making a backup copy of your original ADEX file in your addon.

Share this post


Link to post
Share on other sites

UK 2000 V2 add on. I can work around the issue, but it's still a PITA.

If you check the options "Contact controllers and confirm instructions" and "Serve COM radio" in Options/In-Flight....Copilot Support, you will not need to worry about frequencies as ProATC will change them automatically. 

Share this post


Link to post
Share on other sites

Already dong that, but it's still a bit kak that I'm forced into using that option with a product that costs fifty quid. :-)

Share this post


Link to post
Share on other sites

The real-life EGCC Clearance frequency is 121.70.  To eliminate confusion, can you tell us exactly what is prompting you to tune 121.75?

Share this post


Link to post
Share on other sites

You can edit the frequency within ProatcX options, also if the flight doesn't meet criteria, clearance will not be given ie runway length not suitable for aircraft at airport...all can be edited in ProtcX...the best option for help is their forums, help/support is always given

Share this post


Link to post
Share on other sites

The real-life EGCC Clearance frequency is 121.70.  To eliminate confusion, can you tell us exactly what is prompting you to tune 121.75?

 

Pro Atc x on initial load asks you to contact clearance on 121.75, which as far as I'm aware is incorrect and it should be 121.70, so unless I use the auto menu option to have the Pro Atc x co-pilot make contact and read back, then I can't contact Clearance because when I tune the radio myself manually to that frequency, Pro Atc x screws up. I have tried editing the frequency in Pro Atc x, but it still asks me to contact 121.75 upon loading into FSx.

Share this post


Link to post
Share on other sites

Pro Atc x on initial load asks you to contact clearance on 121.75, which as far as I'm aware is incorrect and it should be 121.70, so unless I use the auto menu option to have the Pro Atc x co-pilot make contact and read back, then I can't contact Clearance because when I tune the radio myself manually to that frequency, Pro Atc x screws up. I have tried editing the frequency in Pro Atc x, but it still asks me to contact 121.75 upon loading into FSx.

 

 

Just a thought  - but have you aligned your scenery and airac in ProatcX and run the runways.exe to realign your sceneries. I make a point of doing this once a week just to make sure everything is in sync with ProatcX

Share this post


Link to post
Share on other sites

What airplane are you using and does its radios use standby frequencies?

I found that I fly with ProatcX, if the airplane is not equipped with standby frequencies (such as the CS 727) it often will never connect to the required clearance frequency even if I manually dial it, or even if I have the co-pilot "always serve the comm radios".

I finally solved it by using FSUIPC to map a key to the function "swap radio frequencies".  When I hit that key then the frequencies magically work.

I don't have a problem with any airplane that uses comm radios that have standby frequencies.

Dutch

Share this post


Link to post
Share on other sites

The problem occured on various 737s, including PMDG and iFly, so it's not aircraft specific, and of course both those have standby and active frequency selectors on both sides of the pedestal.

Share this post


Link to post
Share on other sites

The previous version of PROATC/X required you to go through it's preflight checklist to activate ATC coverage, even if you were on the proper frequency. With the latest version this seems to be more spotty. Sometimes I have to do the checklist, sometimes, I just need to manually set the comm freq. Try running though the PATC preflight checklist and see if that activates it.

Share this post


Link to post
Share on other sites

I find I have to do the first check list before I can contact any clearance delivery etcetera

Share this post


Link to post
Share on other sites

Already dong that, but it's still a bit kak that I'm forced into using that option with a product that costs fifty quid. :-)

 

I'm using ProATC/X all the time and Manchester is my 'home' airport so I fly from there a lot, and I have never yet come across any such discrepancy. Are you using an add-on Manchester, or the default? The latter may indeed have incorrect frequencies. I don't know.

 

The difference between what ProATC/X says it wants and what it really wants seems very odd. I don't know where it would get two different values for the same facility from. 

 

Your best bet is certainly to pose this problem on the ProATC/X support forum. It is very good and responsive these days. Just make sure you attach a log from a flight with this problem, and sign your real name.

 

Pete

Share this post


Link to post
Share on other sites

I have the freeware version of UK2000 EGCC installed and ProATC/X uses 121.70 for clearance on my setup.  I suspect that either your scenery is not aligned correctly or you have duplicate AFCAD layouts for EGCC.

 

  • I recommend that you open ProATC/X and go to Data >  Airports > Airports in database.
  • Type EGCC in the "Airport Code" field and press the open button.
  • The current Clearance frequency should be displayed in the frequency box at the lower right.
  • If it doesn't correctly show 121.70, press the "Re-Align with scenery" button at the lower left.

If that still doesn't fix it, you may need to search your install for duplicate AFCADs (sometimes third-party airports include multiple AFCAD or AFX files that occasionally cause alignment issues).

Share this post


Link to post
Share on other sites

Firstly, the ProATC-X Flight Information dialogue box shows you what comms frequency it wants set.

 

Secondly, I have had this problem although I can't recollect which payware airport it was.  I do have the full version of UK2000 Manchester, so it's likely that's it.  I merely got the required frequency from 1) above and tuned it and it worked, so I don't know why you are having difficulty.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this