Sign in to follow this  
Airbus

Lear 35A Version 2.8 spoilers not working

Recommended Posts

I must have done something wrong.  I can't deploy spoilers.  All other control surfaces work fine.  I even fired up my F1 Mustang and spoilers worked.  Is there a switch or setting that I missed?

 

Thanks for any help!

 

Airbus

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi there Airbus,

 

Here's Lear and the spoilers are working on my side with v2.8. However they won't react to the default / key

But with this key on the console:

 

sp.jpg

 

 

spoiler.jpg

Share this post


Link to post

Flysimware has provided special assignments for those who wish to control the AP and other L35A functions with keys or buttons instead of the mouse. From the latest Flysimware L35 manual:

 

“G1000_MFD_SOFTKEYS” assignments.
Full list:
G1000_PFD_SOFTKEY1 = HDG
G1000_PFD_SOFTKEY2 = 1/2 BNK
G1000_PFD_SOFTKEY3 = NAV
G1000_PFD_SOFTKEY4 = BC
G1000_PFD_SOFTKEY5 = LVL
G1000_PFD_SOFTKEY6 = TST
G1000_PFD_SOFTKEY7 = ENG
G1000_PFD_SOFTKEY8 = SFT
G1000_PFD_SOFTKEY9 = SPD
G1000_PFD_SOFTKEY10 = V/S
G1000_PFD_SOFTKEY11 = GS
G1000_PFD_SOFTKEY12 = ALTSEL
G1000_MFD_SOFTKEY1 = ALTHLD
G1000_MFD_SOFTKEY2 = Steer Lock On
G1000_MFD_SOFTKEY3 = Steer Lock Off
G1000_MFD_SOFTKEY4 = Yaw Damper Primary (Power mode must be on.)
G1000_MFD_SOFTKEY5 = Yaw Damper Secondary (Power mode must be on.)
G1000_MFD_SOFTKEY6 = Spoiler Switch (Default switch is disabled. There is no arming as well.)
 

So, for example, to assign the "/" key to operate the spoilers, go into FSX Settings-Controls and under the Keyboard column, assign the "/" key to the Event called G1000_MFD_SOFTKEY6 . This assumes the "/" key, or whatever other key you wish to use for the Spoilers toggle, is not being used for something else. You can, of course, also operate the spoilers using the mouse by clicking on the spoiler switch located just to the right of the throttles (and under the protective metal ring) as shown in the picture above .

 

Al

  • Upvote 1

Share this post


Link to post

Thanks for your help!

 

Never thought there was a spoiler switch for this aircraft!  Thanks for the picture! I have the spoiler assigned to a button on my CH yoke which always worked for other aircraft. The Lear is the first aircraft I use that uses a switch and disables the button on my yoke.  I am going to set up my keyboard to use the G1000 softkeys.

 

Airbus

Share this post


Link to post

 

 


I have the spoiler assigned to a button on my CH yoke which always worked for other aircraft. The Lear is the first aircraft I use that uses a switch and disables the button on my yoke. I am going to set up my keyboard to use the G1000 softkeys.

 

Note that you can choose to assign the same button on your yoke that you have always used for the spoilers to the G1000_MFD_SOFTKEY6. Key or button -- it's your call.

Al

Share this post


Link to post

Hi Al:

 

I just tried my first assignment for the spoilers and it did not work.

 

I noticed that the line for G1000_PFD_SOFTKEY6 in my FSX-Settings Controls in the first column actually appears like this:

 

G1000 MFD SOFTKEY 6 (activate)

 

There are no underlines just spaces and there is the word activate in parenthesis.  All the lines for the G1000 have this same format.  Why is the word activate there and what does it mean?

 

I tried assigning keyboard / first and the spoilers deployed but would not retract on the next keypress.  I then tried assigning yoke button 02 and that did not work at all. 

 

So...I am at a loss on this one.  Until I can figure this out I will have to use the toggle switch on the pedestal.

 

Please let me know if you if have any ideas and thanks again for responding :smile:

 

Al

Share this post


Link to post

I am curious as well.  I previously used a button on my CH throttle to deploy speedbrakes.

Share this post


Link to post

I tried assigning keyboard / first and the spoilers deployed but would not retract on the next keypress. I then tried assigning yoke button 02 and that did not work at all.

 

Hi Al,

 

Regarding the underscores and the word (activate), or lack thereof,  in the name for the G1000 softkey, I don't believe that is an issue, One is the name that Flysimware uses in their key assignment programming, and the other is the name FSX uses in the Event list. I just tried setting up the spoilers toggle using both the / key and a yoke button (Saitek) using the G1000 MFD SOFTKEY 6 (activate) assignment, and both worked. So we need to figure out what is happening with your setup. I assume controlling the spoilers 'directly' using the mouse works, and you are not using FSUIPC to make assignments. BTW, what sim are you using (I use standard FSX)?

 

A couple of things to check/try:

 - make sure the Enable Controller(s) check box is checked under the Calibration tab under Settings-Controls

- when setting up the yoke button under BUTTONS/KEYS, make sure the name of your yoke is displayed in the Controller type: drop down box which is directly under the BUTTONS/KEYS tab.

- after making and saving the assignment(s), close and restart FSX.

 

BTW, you should be able to have both a key and button assigned at the same time if you so choose.

 

At the moment I don't understand why you could get the spoilers to deploy but not retract. While I'm thinking about that, try the above.

At some point if nothing helps it may be worth a shot to uninstall and then reinstall the L35.

 

Maybe someone else has some ideas to try as well.

 

Al

Share this post


Link to post

Hi Al:

 

OK, I got it working for the spoilers!  What I did, as you mentioned, was after setting the key and the yoke button for the softkey 6 event, I EXITED FSX and RESTARTED.  That was it!  I have never had to exit the sim and restart to get my assignments to work.  LIVE AND LEARN!!!  Hopefully the assignment will stick.

 

I am now ready to program the other keys to assign the autopilot events.  What specific keyboard keys do you use? For example, SOFTKEY 1 for HDG.  Use the #1 key? Use the letter H? Do you have all the events assigned to keys?

 

Meanwhile I am going to do some Lear 35A practice. :smile:

Thanks again tor your help!

 

Al

Share this post


Link to post

Hi Al,

 

Glad you got it working!

 

What keys to assign to what is a personal thing -- what will be easy for you to remember and convenient to use?  One approach would be to use the function keys across the top of your keyboard to mimic the AP key layout in the L35. Or you could just use the mouse for the AP keys -- some say reaching up with the mouse is like reaching up with your finger in the real cockpit. Another approach is to just use keys for some of the most used AP functions. I rarely use 1/2 BNK, BC, LVL, TST and SFT, and if I do need them occasionally I use the mouse. And note that by default the Z key will toggle the ENG button, so no need to assign another key to that. That leaves 7 AP functions to assign keys to if you prefer that over using the mouse.

 

I think you will find that you want to assign buttons or keys to some of the other functions that Flysimware has generously made available -- especially Steer Lock On and Off. 

 

Al

Share this post


Link to post

G1000_MFD_SOFTKEY6 = Spoiler Switch (Default switch is disabled. There is no arming as well.)

 

So, for example, to assign the "/" key to operate the spoilers, go into FSX Settings-Controls and under the Keyboard column, assign the "/" key to the Event called G1000_MFD_SOFTKEY6

 

Unfortunately, I am unable to reliably deploy or retract the spoilers in 2.8?

 

I have assigned / key and my Saitek button (button always worked before 2.8) but the spoilers only work one time out of ten? I would suspect a faulty button or joystick input, however the / key doesn't work either.

 

How can I revert back to 2.7, just for this one control? Assigning the spoilers to G1000_MFD_SOFTKEY6, doesn't make sense to me?

Other than this, 2.8 is fine.

 

Regards

David.

Share this post


Link to post

David,

This sounds like some kind of control conflict to me. Make sure the / key and Saitek button are not assigned to anything else. They both can only be assigned to the G1000 softkey. BTW, these new L35 assignments are just using the G1000 softkeys as a matter of convenience because they are likely avaiable (unused) . Flysimware has written special code so keys or buttons assigned to these softkeys will operate the specified L35 functions instead of actual G1000 functions.

Al

Share this post


Link to post

Hi Folks,

 

While not as bad as bad as David - noticed intermittent function of the new spoiler switch as well...

 

Just stops working from time to time...

 

Regards,

Scott

Share this post


Link to post

Scott,

I only tested the spoilers - G1000 softkey approach briefly since I am setup to use Lua scripts, but it seemed to work fine. I use FSX. I believe you use P3D. If David uses P3D also I wonder if there might be a P3D related problem?

Al

Share this post


Link to post

Hi Al,

 

I didn't have a tea deal of time to test - but - it seemed to stop working most often when I was playing around with the reverse thrusters - I've got to get more time with it for anything conclusive... Yep - I'm using P3D..,

 

Regards,

Scott

Share this post


Link to post

Hi Al,

I didn't have a tea deal of time to test - but - it seemed to stop working most often when I was playing around with the reverse thrusters - I've got to get more time with it for anything conclusive... Yep - I'm using P3D..,

Regards,

Scott

Yes I am on P3dv3.4hf2. (Latest)

 

And...guess what? Using the spoilers upon landing appears to be the problem and I do use reverse thrust. But having come out of reverse, the spoilers still won't activate, no up or down?

 

Tomorrow I will re check for key conflicts, could be the / key assigned somewhere else?

 

Regards,

 

David

Share this post


Link to post

Hi David,

 

Since we both have different assignments with the same symptoms - suspect it's something to do with the G1000 keys - worked fine previously with Al's LUA...

 

I only get time to mess with this on the weekends - so I'm of no help before then...

 

Regards,

Scott

Share this post


Link to post

OK I have the G1000_MFD_SOFTKEY6 = (Spoiler Switch) mapped to my X55 throttle button 29.
 
 
 
I have the spoilers arm mapped to Shift + /.  (Controls settings, for other aircraft)
 
The spoilers extend/retract toggle mapped to /. ( controls settings for other aircraft)
 
I have nothing programmed in the Saitek X55 programmed buttons.
 
To cut a long story short. I have partial success with the spoiler function after landing. Using the The G1000_MFD_SOFTKEY6  mapped only to  Button 29 throttle stick.
 
I believe that there is a conflict in the bowels of P3d controls.
 
I f I press and hold the / key, the spoilers will extend after about 20 seconds of holding the / key. If this has been disabled in the 2.8 code, then there is still a function there. This seems incorrect and may be conflicting with the G1000_mfd_softkey6.   That's my guess!

 

 

The annoying thing is, its intermittent! A horrible fault in an aircraft!  Will it work this time, or not?  Errm?   :Devil: But it does raise the tension on landing and is perfectly in keeping with the real world reports on this aircraft. It was a hairy beast at the best of times. So well done FSW you modelled another quirk into the simulation! :wink:  I still love this little simulation? 

 

Cheers

 

David

Share this post


Link to post

Hint: The key control mod for 2.7 still works in 2.8.

Share this post


Link to post

 

 


The annoying thing is, its intermittent!

This intermittent thing may be due to the way FSW chose to implement their key assignments. AFAIK, they'll only work if you're view is in the VC. Exterior views cause the assignments to 'lose focus' (for lack of a better term). Regaining control when you return to the VC may also lag for a few seconds/keystrokes. You might try a few tests to see if your view is what's causing the intermittent behaviour you're seeing.

Share this post


Link to post

Yep, gauges added to the VC section in the panel.cfg will only work in that view.

Share this post


Link to post

Hi Folks,

 

Ahh - that could be my issue - I may have been jumping between views...

 

Thanks...

 

Regards,

Scott

Share this post


Link to post

Hi Folks,Ahh - that could be my issue - I may have been jumping between views...Thanks...Regards,Scott

Ditto.

 

I will check again.

 

Cheers

 

David

Share this post


Link to post

I just discovered that as well about the softkey assignments, they only work when in the VC.  I was testing with an external view so I could see the spoilers and it wasn't working.  Fortunately I tried in the VC as well and noticed the issue.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this