Sign in to follow this  
flyguycaa

747v3 Autopilot disconnect when flaps are moved

Recommended Posts

This related to the 747v3 for P3D.  I have my flaps mapped through FSUPIC (paid version) to a 3 way switch on my HOTAS joystick.  The positions are mapped to Flap Incr and Flap Decr.  Whenever I either extend a notch or retract a notch the autopilot disengages.  This happens throughout the flap range.  I also have the 777 for FSX and the NGX for FSX and I don't have this issue on them.  In fact, this is the only aircraft that I have that has this issue.  Any idea why this would happen only on the 747v3 for P3D?  I would rather not have to submit a ticket.  Thanks in advance.

 

John Croft

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Your controls are not centered John. AP operation has nothing to do with flaps. The same button used for flaps is perhaps affecting elevator and/aileron position. Give away is strikeout in the FMA pitch and/or roll mode prior to AP disconnect.

 

There is an option in the menu that instructs AP to ignore control inputs.

Share this post


Link to post
Share on other sites

Your controls are not centered John. AP operation has nothing to do with flaps. The same button used for flaps is perhaps affecting elevator and/aileron position. Give away is strikeout in the FMA pitch and/or roll mode prior to AP disconnect.

 

There is an option in the menu that instructs AP to ignore control inputs.

 

OK, I turned off control inputs with AP on and it still disconnects every time I either increase or decrease the flaps, so no, that wasn't the issue.  As I said, I have this set up exactly the same on the 777 and NGX and neither has this problem.

 

John Croft

Share this post


Link to post
Share on other sites

Check to ensure that you do not have a conflicting button command somewhere.

 

You may also want to pull your FSUIPC.ini out of the modules folder (into the root sim folder, temporarily, as an example). If the problem goes away, there is a problem with your .ini file.

Share this post


Link to post
Share on other sites

Check to ensure that you do not have a conflicting button command somewhere.

 

You may also want to pull your FSUIPC.ini out of the modules folder (into the root sim folder, temporarily, as an example). If the problem goes away, there is a problem with your .ini file.

I don't have the flap commands set up as key commands, they are mapped to the FSUPIC "Flap incr" and "Flap Decr", so to the best of my knowledge FSUPIC isn't sending a key command for the flaps.  So I'm not sure how there could be a conflict with AP disconnect, which is mapped to a key command.  I will try moving the FSUPIC out of the modules folder when I finish my flight.

Share this post


Link to post
Share on other sites

Maybe double key command (eg. trim at the same time as flaps one through fsuipc the other through FSX) 
As FSX has a habbit of setting keys to your controls upon reconnect. 

Share this post


Link to post
Share on other sites

OK, I got it figured out.  Apparently when I updated to the latest version of P3D it replaced the file that has control mapping in it, so my joystick had mappings in P3D and FSUPIC.  I had cleared them all out of P3D previously, but apparently I need to check that every time I do a client update.  Thanks for the suggestions, I appreciate it!

Share this post


Link to post
Share on other sites

OK, I got it figured out.  Apparently when I updated to the latest version of P3D it replaced the file that has control mapping in it, so my joystick had mappings in P3D and FSUPIC.  I had cleared them all out of P3D previously, but apparently I need to check that every time I do a client update.  Thanks for the suggestions, I appreciate it!

That is one possibility, although I'm not sure a client update will do that.  I've noticed that assignments can be changed by simply running the program with the controller unplugged.  This is a real problem in FSX and I think P3D does it as well.

Share this post


Link to post
Share on other sites

I did the latest P3D hotfix and the same thing happened to me. Except my gear down command in FSUIPC was also mapped to mixture cutoff in P3D. I established on the LOC for a nighttime approach in IMC and got the biggest surprise of my life when I dropped the gear.

Share this post


Link to post
Share on other sites

I can't seem to keep the autopilot engaged for more than a few seconds also (Prepar3D / PDMG 747 latest).  Tried disconnecting the joystick/throttle combo, and the pedals too and it didn't make any difference.  Also removed the FSUIPC4.ini file.  No change.  I looked in Prepar3D buttons menu and I see the usual Autopilot assignments, but nothing else besides those are mapped to these keys.  Also, I'm getting both strikeouts over the Attitude Indicator in all of these situations - what other prerequisites are required to properly engage the Autopilot?

 

Oh and I have switched the FMC option to non-realistic engagement of the AP as well.

 

Any ideas?

 

Mark Trainer


OK - I think I have solved this (for me anyhow).  For one, I don't think the FMC Option for "realistic AP engagement" operates as I expected it to- I thought that when it is set to "OFF" that it would ignore any flaky inputs coming from the joystick/throttle/rudders.  But I don't think this is the case as I went into FSUIPC and looked at the Joystick Calibration Tab "center" values for Ailerons and Elevator, which used to be 0, are now reading a significant non-zero value (over 2K now days...).  I recalibrated the "center" position to the new 2K value for both and that seems to have resolved the problem.

 

Still not sure how I had the issue even when I unplugged these during flight.  Maybe PDMG was still reading the controllers as off center since that is how they probably appeared at the moment they were unplugged?   Not sure.

 

These joysticks are old and probably need to be replaced.  This Saitek X36F/X35T combo must be 15 years old, sad to see that they have reached the end of their life span.  I got a lot of use out of them!

 

I ordered the crosswinds pedals last month, looking forward to the day they arrive.  Looks like I'll need to go joystick shopping soon as well.

 

Mark Trainer

Share this post


Link to post
Share on other sites

For one, I don't think the FMC Option for "realistic AP engagement" operates as I expected it to- I thought that when it is set to "OFF" that it would ignore any flaky inputs coming from the joystick/throttle/rudders. 

I believe the option you were looking for was actually "CTL input with AP on," not "realistic AP engagement."

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this