loafer87gt

Adaptive Half Refresh Rate V-Sync no longer working

Recommended Posts

I am just wondering if anyone has any idea why my Adaptive Half Refresh Rate vsync is no longer working in Prepar3d. Normally, I could just enable the feature in my Nvidia control panel and I would have a really smooth 30FPS with the in game VSync enabled and unlimited frame rate setting. Now, it seems like the sim is ignoring my Nvidia settings, and is running anywhere from 40 to 55 FPS, and there are noticeable stutters. I checked my Prepar3d application profile with both Nvidia Inspector and the Nvidia Control panel program listing, and everything is at their default values. Just wondering if anyone has any suggestions as to how to get this feature back working again, as it was so fluid before with the frame rate capped at my half refresh rate. I am running Prepar3d V3.4 with Hotfix 3.


Please note that I am running the game fullscreen, not in a window.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

First I would check the driver version, windows 10 is forcing Nvidia drivers updates. Secondly, you shouldn't touch nvidia control panel because it will override IS. 

Share this post


Link to post

I have tried both the newest Nvidia 378 driver, and the older 376 drivers from last year. Adaptive Half Refresh Rate does not seem to be working with either of them as my FPS are around 50 on the tarmac.

Share this post


Link to post

Please note that I am running the game fullscreen, not in a window.

 

 

Fullscreen or window matters nothing in P3D, as it is not full screen exclusive mode. It is a borderless window. This is important as it is NOT the same as FSX, FSX uses exclusive full screen mode, which if memory serves allows vsync to be on or off because the game has exclusive control of the display.  That was taken out of P3D some time ago I think in V2?

 

That being the case it is now dependent on your OS whether Vsync is on or not. If you are using Windows 7 and you have a basic theme ( Windows Aero not running ) then vsync will be off. To enable Aero pick a different theme other than basic. 

 

From Windows 8 and onward it is on all the time and can't be disabled.

 

Edit: have you tried changing the "global" setting in Nvidia control panel to force it to your liking? Maybe that will do it.

Share this post


Link to post

Thanks for the replies. Yes, I have my global Vsync set to Adaptive Half Refresh rate. In every other game I have tested, this translates into 30FPS in game as I am running a 60 Hz monitor. Prepar3d also used to be locked at 30 FPS when this setting was enabled. Now, the program seems to be ignoring my Vsync settings. I have tried removing all my Nvidia drivers, cleaning out all my previous settings with Display Driver Uninstaller, and checking the clean install option and trying drivers back November of last year, but none of these seem to let my Vsync work again. I'm stumped.

Share this post


Link to post

Are you running Windows 10, Capt Speirs? I am wondering if it is maybe an OS update that has broken this functionality?

Share this post


Link to post

Are you running Windows 10, Capt Speirs? I am wondering if it is maybe an OS update that has broken this functionality?

Windows 7 Ultimate

Share this post


Link to post

Half refresh has never worked in p3d due to reasons stated above regarding true full screen. Any effect you think you had from it was placebo.

Share this post


Link to post

If you are looking for smoothing out, like it was possible with FSX, you might try running 31-32fps locked in the sim + vsync+tb enabled, 30,5 locked in the NI, and FFTF of 0.01 in prepar3d.cfg.

Additionally single display, maximum performance and shader cache off are recommended.

Share this post


Link to post

Half refresh has never worked in p3d due to reasons stated above regarding true full screen. Any effect you think you had from it was placebo.

This is correct.

 

Cheers,

Mark

Share this post


Link to post

OK, thanks guys. Maybe I did indeed have a frame rate limiter enabled under Inspector in the past. Was just wondering if something was up with my system!

 

Cheers!

Share this post


Link to post

Same here, this issue is driving my nuts!

 

I use NI to set 1/2 synch for x plane 11 all is good rock steady at 30 fps.

 

Next day boot up PC start Xplane and frame rate is from 30 upwards so stutters everywhere..just cannot find a solution anywhere.

 

Seems WIN 10 just overwrites the nvidia settings, the only way to correct is uninstall the drivers then reinstall then reset NI. Of course next day back to square one....also happened when I used p3d.

 

So very frustrating

 

Cheers Mark

Share this post


Link to post

Got rid of the problem by rolling back the nVidia driver.

Share this post


Link to post

What are you talking about? 1/2 Refresh Rate Vsync never ever worked in P3D.

Share this post


Link to post
On 2/19/2017 at 4:01 AM, GHarrall said:

Half refresh has never worked in p3d due to reasons stated above regarding true full screen. Any effect you think you had from it was placebo.

Funny enough, it was in fact working for me until recently (few months ago). And nope, it wasnt a placebo effect as it was showing stable 30 fps (measured by external FPS counter) with 1/2 adaptive vsync set in Nvidia CP and unlimited frames in P3D on a 60hz screen. 

I'm wondering if its related to the DSR issues some people reported a while ago...

Share this post


Link to post
13 minutes ago, woozie said:

Funny enough, it was in fact working for me until recently (few months ago). And nope, it wasnt a placebo effect as it was showing stable 30 fps (measured by external FPS counter) with 1/2 adaptive vsync set in Nvidia CP and unlimited frames in P3D on a 60hz screen. 

I'm wondering if its related to the DSR issues some people reported a while ago...

But that's technically impossible since P3D doesn't run in true fullscreen mode and 1/2 refresh rate vsync only works in true fullscreen. I'm not sure what caused your situation but I'm pretty sure it wasn't 1/2 refresh rate vsync.

Share this post


Link to post
5 hours ago, 0Artur0 said:

But that's technically impossible since P3D doesn't run in true fullscreen mode and 1/2 refresh rate vsync only works in true fullscreen. I'm not sure what caused your situation but I'm pretty sure it wasn't 1/2 refresh rate vsync.

Yes. Must have had an external limiter running somwewhere

Share this post


Link to post

And also stop calling it adaptive vsync, it's "1/2 refresh rate vsync", nothing adaptive about it. It's only the tear control that you can set to adaptive.

And yes, 1/2 rate refresh vsync has never worked in P3D, it needs true full screen mode.

Share this post


Link to post
20 minutes ago, neumanix said:

And also stop calling it adaptive vsync, it's "1/2 refresh rate vsync", nothing adaptive about it. It's only the tear control that you can set to adaptive.

And yes, 1/2 rate refresh vsync has never worked in P3D, it needs true full screen mode.

well, my NVIDIA CP says:

Adaptive (half refresh rate)

 

I hope you dont mind if i keep calling it adaptive Vsync...

Share this post


Link to post
7 hours ago, 0Artur0 said:

But that's technically impossible since P3D doesn't run in true fullscreen mode and 1/2 refresh rate vsync only works in true fullscreen. I'm not sure what caused your situation but I'm pretty sure it wasn't 1/2 refresh rate vsync.

 

2 hours ago, GHarrall said:

Yes. Must have had an external limiter running somwewhere

I know that it requires exclusive full screen mode, but i also know for sure that it was working for me until a few months ago. And no, i dont use an external FPS limiter as i never had any positive experience with external FPS limiters and P3D. 

Share this post


Link to post
22 minutes ago, woozie said:

 

I know that it requires exclusive full screen mode, but i also know for sure that it was working for me until a few months ago. And no, i dont use an external FPS limiter as i never had any positive experience with external FPS limiters and P3D. 

As you said, it requires exclusive full screen mode. P3D doesn't have it so it simply can't work. As I said, something else was causing your situation not 1/2 refresh rate vsync. It's just not possible. That's also the reason why people are buying monitors capable of 30Hz because it produces similar results as 1/2 refresh rate vsync used to in FSX. If you'd have working 1/2 rt vsync in P3D it would legitimately count as a miracle :smile:

Share this post


Link to post
7 minutes ago, 0Artur0 said:

As you said, it requires exclusive full screen mode. P3D doesn't have it so it simply can't work. As I said, something else was causing your situation not 1/2 refresh rate vsync. It's just not possible. That's also the reason why people are buying monitors capable of 30Hz because it produces similar results as 1/2 refresh rate vsync used to in FSX. If you'd have working 1/2 rt vsync in P3D it would legitimately count as a miracle :smile:

Given how many headaches P3D gave me already it was about time for a miracle ;)

But yes, its strange that it was working for some time. I'm wondering if its related to the blackout desktop setting which has an influence on how P3D's fullscreen mode is working. 

Share this post


Link to post
2 hours ago, woozie said:

Given how many headaches P3D gave me already it was about time for a miracle ;)

But yes, its strange that it was working for some time. I'm wondering if its related to the blackout desktop setting which has an influence on how P3D's fullscreen mode is working. 

no its not related. P3D does not have any ability to run in true full screen regardless of any settings, blackout or otherwise. 1/2 refresh does not work in anything other than true full screen. Its a limitation of the drivers. There have been many attempts at getting it to work with a multitude of settings tried. Without the true full screen its not possible

Share this post


Link to post

@Woozie - the ONLY time it oculd have worked would have been a year or so ago BEFORE LM introduced the "psuedo" full screen mode. After they made that change, it is just impossible for it to work. Whatever you saw was due to something else NOT the HRR. Since there is no full screen, the blackout setting has no effect.

You saw something change but we can assure you it had NOTHING to do with 1/2 refresh rate.

 

Vic

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now