OfficialLiovo

Missing Textures EVERYWHERE!

Recommended Posts

Hey!

For a few weeks now, I've been having some major issues with FSX. The screenshot just explains it all:

fsx-missing-ground-textures_10661bcffdda

 

As you can see, all of my textures are black, with auto gen on top. This happens where grass and/or water is supposed to be. This screenshot was below medium settings. If I put it above medium settings, all of the black gets replaced with water. I have an AMD A6 processor, with Radeon R4 graphics. This happened when I woke up and turned on my PC. It was working fine the night before.

HELP!

 

Signed,

Liovo

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Any updates taking place and installing during your shutdown last night or during power up this

morning?   They can be sneaky, especially the Graphics updates.

Share this post


Link to post
Share on other sites
31 minutes ago, OfficialLiovo said:

No, there was no updates.

Must be the "dreaded" computer gremlins!:laugh:  If you didn't make any changes, something did!  I did see a post a while ago where someone's kids or grandkids got up in the middle of the night, turned on the computer and downloaded a bunch of games and other garbage and made changes to his flight Sim.

Share this post


Link to post
Share on other sites

This happens when you have UTX installed.  Just start up the utility, let it do its thing and then close it.  Run FSX.

Best regards,

Jim

Share this post


Link to post
Share on other sites

I'm not using either UTX or any other scenery/texture addons.

@charliearon :D It couldn't have been, there was no-one in the house that night except me and my mother, and she doesn't even know how to use a computer. (and we didn't get robbed) :D

Share this post


Link to post
Share on other sites
2 minutes ago, OfficialLiovo said:

I'm not using either UTX or any other scenery/texture addons.

@charliearon :D It couldn't have been, there was no-one in the house that night except me and my mother, and she doesn't even know how to use a computer. (and we didn't get robbed) :D

You don't need anyone to be in the house. If Windows it set to auto update then it will do it on its own. I'd suggest you turn off Windows update from automatic to manual. If it was fine before bed and not working correctly the next day, then there is really no other explanation. Probably downloaded and installed new video drivers.

Share this post


Link to post
Share on other sites

@cmpbellsjc My windows wouldn't have updated in the night, as when I turned on my PC in the morning, it would say like "configuring updates", and it didn't. And, my windows always says I have the most up to date drivers.

Share this post


Link to post
Share on other sites
3 minutes ago, OfficialLiovo said:

@cmpbellsjc My windows wouldn't have updated in the night, as when I turned on my PC in the morning, it would say like "configuring updates", and it didn't. And, my windows always says I have the most up to date drivers.

Don't know then. Obviously something changed in either your FSX, Window or driver configuration or you wouldn't be where you are now. Don't have any other ideas except to try deleting your FSX shader cache (not shader files in FSX folder) and deleting your FSX.cfg and letting it rebuild when you start FSX.

Typically what you see is caused by UTX but you said that you don't have that or if the terrain.cfg gets corrupted.

Share this post


Link to post
Share on other sites

I've reinstalled FSX FULLY 5 times, not worked. And I've deleted the shader cache loads of times.

Share this post


Link to post
Share on other sites

OfficialLiovo,


Please navigate to  C:\ProgramData\Microsoft\FSX   open the Scenery.cfg  with MS notepad,
This is the active scenery.cfg

At the top of the config you should see [Area.001]

There should be an entry under this heading for   Texture_ID=1   as shown below.

If this entry is not present, just add it exactly as sample below, save the scenery.cfg then test your sim.

[Area.001]
Title=Default Terrain
Local=Scenery\World
Texture_ID=1
Layer=1
Active=TRUE
Required=TRUE
 

Share this post


Link to post
Share on other sites

Shouldn't it be in C:\Program Files (x86)\Steam\steamapps\common\fsx

 

In where you said, I opened it, and I had:

[General]
Title=FS9 World Scenery
Description=FS9 Scenery Data
Clean_on_Exit=TRUE
[Area.001]
Local=C:\Program Files (x86)\FS Real Time\TzFiles04
Active=TRUE
Required=FALSE
Layer=102
Texture_ID=1
Title=World Timezones

Share this post


Link to post
Share on other sites

O..M..F..G , it's working! I've made FIVE, yes FIVE, threads on this, and you're the only person who could fix. I could legit come round to your house and hug you right now. :D

Thanks so much,

Jacob

Share this post


Link to post
Share on other sites

Jacob,

I'm glad the solution worked for you, it appears you have the entry   Texture_ID=1

But the other entries are completely wrong for [Area.001] 
Did you end up changing the whole [Area.001] entry to the same as my sample.
(I wonder what other layers are corrupted within your Scenery Areas. 
Your initial problem causing the Scenery.cfg corruption and therefore (black areas) may have stemmed from the installation of "FS Real Time".

(These ones look wrong to me)

Local=C:\Program Files (x86)\FS Real Time\TzFiles04
Required=FALSE
Layer=102
Title=World Timezones

 

If your happy that your Scenery is now displaying properly, and all your layers are correctly placed, then leave things as they are and continue enjoying your sim.

But.................

I fear that you have a corrupt Scenery.cfg  somehow your layering is also incorrect (102).
It might be worthwhile renaming this Scenery.cfg   to   Scenery.cfg.Black 

Restart your sim and allow FSX to create a fresh Scenery.cfg  This will restore the FSX Default core layers to their correct positions.

Once you have done this, return to the active Scenery.cfg  and make sure that  Texture_ID=1  has been entered into [Area.001]  You might at this time open your FSX Scenery Library to check the Default layering.  These are essential to any addons that you may later install.

You may also need to open your FSX Scenery Library to ad back any addon sceneries and airports that you may have installed, or rerun their installers.......

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now