NickFlightX

P3D v4 Blurry Panels

Recommended Posts

Anyone else having and issue where their panels in the PMDG are blurry in the VC, but are crisp and clear in the pop up window? So far, its working great in P3D v4 except for that! Anyone have suggestions how to fix this?

  • Upvote 1

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I have the same problem.

I unticked "Mipmap VC Cockpit". It's now better, but not good.

FXAA is off.

Share this post


Link to post
Share on other sites
On 6/4/2017 at 4:44 AM, NickFlightX said:

Anyone else having and issue where their panels in the PMDG are blurry in the VC, but are crisp and clear in the pop up window? So far, its working great in P3D v4 except for that! Anyone have suggestions how to fix this?

Yeah been having the same issue. What i did is  disabled "Mipmap VC Cockpit" and FXXA and pushed up AA to x4 on both. The problem is sorted, might open a ticket with PMDG for this. 

Share this post


Link to post
Share on other sites

Gents,

This is 100% everything to do with how P3D renders things, and nothing we can do to control it. You can clearly see the displays are not blurry in the 2D. We clearly know how to make the displays not blurry. What we cannot control is your use/settings of:

  • Anti-aliasing
  • Sampling
  • Mip-mapping; and usually the worst offender
  • HDR

Share this post


Link to post
Share on other sites
2 hours ago, scandinavian13 said:

Gents,

This is 100% everything to do with how P3D renders things, and nothing we can do to control it. You can clearly see the displays are not blurry in the 2D. We clearly know how to make the displays not blurry. What we cannot control is your use/settings of:

  • Anti-aliasing
  • Sampling
  • Mip-mapping; and usually the worst offender
  • HDR

So mip-mapping should be off? I thought this was a pro in regards to keeping textures sharp without a large footprint on pc horsepower. I will gladly disable it if so. 

Share this post


Link to post
Share on other sites

What setting should we use?

I unticked Mipmap VC Cockpit (Displays are crisp now)

I use 4x SSAA

I use HDR

more to change?

 

I know, PMDG knows how to make cockpits, they look great. This has something to do with P3Dv4. With v3 the cockpit looks crisp, even with ticked Mipmap VC Cockpit.

Oh, I have the same Problem with the 717 from Tfdi.

 

Thanks

Share this post


Link to post
Share on other sites

I have noticed this as well.  P3d offers many additional visual improvements but they blurr cockpit textures.  In fsx  where these options are absent, the pmdg cockpit vc textures are razer sharp.

Share this post


Link to post
Share on other sites

Full names on all posts here please.

I have very sharp and crisp displays, but much depends on your monitor too.  Using an inexpensive Samsung 4K TV on a HDMI cable and a GTX980Ti my display look awesome with FXAA off, 2xMSAA, 16xAnsio texture filtering and 4096 textures. Mipmapping is off for PMDG products.

Share this post


Link to post
Share on other sites

I had the same issue and noticed that my texture setting was set to nothing in the sim. Changed it back to 4096x4096(this is my setting for my system) and it fixed my problem. Don't know why it had reset after the last update that I did. Anywho, all good now and hope this helps.

Thanks,

Joshua Pemberton 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now