drdickie

747 P3Dv4 Landing Lights

Recommended Posts

I cannot get the landing lights to work using "ctrl+L."  Switches do not move and lights do not appear in external model (spot view).  Not a game-breaker but wondered if anyone else sees this?

Thanks.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

2 hours ago, drdickie said:

I cannot get the landing lights to work using "ctrl+L."  Switches do not move and lights do not appear in external model (spot view).  Not a game-breaker but wondered if anyone else sees this?

Thanks.


You will have to enable "Dynamic Lighting" under the "Lighting" tab in P3D Options. Then you will see the light splash.

Share this post


Link to post
Share on other sites

Does clicking them do anything? I don't remember them ever responding to keyboard commands even in FSX, and I assumed it was because you can move each switch individually.

Share this post


Link to post
Share on other sites

Both the FSX and P3D versions on my system responded to "CTRL+L" as they had in the past.

After a uninstall/reinstall of the 747, they are now working.  Operation of the switches has got nothing to do with the lighting options.

Share this post


Link to post
Share on other sites
On 4/6/2017 at 7:23 PM, calzonister said:


You will have to enable "Dynamic Lighting" under the "Lighting" tab in P3D Options. Then you will see the light splash.

Hi, I've the problem with the light splash. it's only visible with the dynamic lighting on, but the lights should iluminate the ground without the dynamic light option too, just like the defaults P3D airplanes. I think this is a PMDG's issue. I hope they fix it, because I'm not using the dynamic lighting, so I'm in the dark right now ;)

Share this post


Link to post
Share on other sites
1 hour ago, abdelsa said:

Hi, I've the problem with the light splash. it's only visible with the dynamic lighting on, but the lights should iluminate the ground without the dynamic light option too, just like the defaults P3D airplanes. I think this is a PMDG's issue. I hope they fix it, because I'm not using the dynamic lighting, so I'm in the dark right now ;)

This is not an issue. This is how it is supposed to work. The default planes use the old method. We're using the new method. They cannot co-exist.

Share this post


Link to post
Share on other sites
4 hours ago, scandinavian13 said:

This is not an issue. This is how it is supposed to work. The default planes use the old method. We're using the new method. They cannot co-exist.

Well I'm afraid I'm gonna be in the dark for a long time then, because this dynamic lighting is too much for my actual GPU. :blush:

  • Upvote 1

Share this post


Link to post
Share on other sites
20 hours ago, abdelsa said:

Well I'm afraid I'm gonna be in the dark for a long time then, because this dynamic lighting is too much for my actual GPU. :blush:

Change your graphics settings, or change your GPU. If it's too much for your GPU, then I'm guessing it's rather old, or you're trying to drive your settings too high.

Nothing wrong with an old car that runs, but I'm not taking an old car out on a track day.

Share this post


Link to post
Share on other sites
1 hour ago, scandinavian13 said:

Change your graphics settings, or change your GPU. If it's too much for your GPU, then I'm guessing it's rather old, or you're trying to drive your settings too high.

Nothing wrong with an old car that runs, but I'm not taking an old car out on a track day.

Kyle I have a quite new system (gen 6 i7, gtx 970, DDR5) but using dynamic lightning on the 747 kills my FPS from 40-50 to 10. I could not compare that to other addons as the 747 is all I actually have on v4 so I won't say that it's PMDG's fault but it's unusable for some people as I read on several forums.. maybe LM will be able to fix it, we're on 4.0 ^^ oooor it will be up to PMDG :D

  • Upvote 1

Share this post


Link to post
Share on other sites

I don't really have knowledge about what goes on behind the scenes, but I have a feeling that dynamic lights needs some optimization from LM. Will probably come in future updates. Just like shadows was heavily optimized during the lifetime of P3D 3.X :smile:

  • Upvote 1

Share this post


Link to post
Share on other sites
3 hours ago, scandinavian13 said:

Change your graphics settings, or change your GPU. If it's too much for your GPU, then I'm guessing it's rather old, or you're trying to drive your settings too high.

Nothing wrong with an old car that runs, but I'm not taking an old car out on a track day.

Hi Kyle,

I've a 2011 Alienware Aurora, good CPU, RAM, etc, but a GTX580 with 1.5GB. My P3D settings are in the middle to low, and I can get around 30 to 40 fps on the QOTS and FB KSFO. But when I turn on the dynamic lights, the frames go down to 12-15 fps... Yeah, probably I should update my GPU...

Share this post


Link to post
Share on other sites
1 hour ago, abdelsa said:

Yeah, probably I should update my GPU...

Can't tell if this is sarcasm or not, but that card is now 7 years old. Might be worth considering.

Share this post


Link to post
Share on other sites
32 minutes ago, scandinavian13 said:

Can't tell if this is sarcasm or not, but that card is now 7 years old. Might be worth considering.

No, it is not sarcasm. I know I've to upgrade my GPU. I've to find a video card compatible with my system, and of course consider the economical matter. I'm not a sarcasm guy by the way.

 

Best,

Share this post


Link to post
Share on other sites
On 6/7/2017 at 1:13 AM, scandinavian13 said:

This is not an issue. This is how it is supposed to work. The default planes use the old method. We're using the new method. They cannot co-exist.

If they cant coexist then what is every default plane in V4 doing to make it happen? All those plane have dynamic lighting when you turn the setting on but old style lighting with it off.

Kade Bellaney

Share this post


Link to post
Share on other sites
7 minutes ago, kcgb said:

If they cant coexist then what is every default plane in V4 doing to make it happen? All those plane have dynamic lighting when you turn the setting on but old style lighting with it off.

Because those are default planes, and ours are not.

We have, for a very long time, hacked around the default implementation of the lighting to get it to function more like lights actually behave, and not the default behavior of the sim. Our lighting was custom coded before. It can't coexist, reasonably, with the new methods.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now