Sign in to follow this  
MPartlett

Memory Leak Discovered P3D V4?

Recommended Posts

My P3D V3 install (after working perfectly for months) developed a severe memory leak whereby the VAS gradually increased to OOM when just sitting  at the gate especially severe with A2A 182 and Comanche.

This occurred (maybe just a coincident) after reverting config file back to original after experimenting with the PTA tool and on starting the sim ChasePlane updated but instead of displaying VAS it displayed a smiley face.

Explored all the recommended fixes without success including a lengthy reinstall.

Without solving the problem with V3 I installed P3D V4 (thinking it would be worth the time building the sim again all be it waiting for developers to release V4 versions) and on opening ChasePlane I noted the smiley face I had seen previously.

I have continued to try and repair/solve the problem with P3D V3 (sitting idle after load) and observed the continuous consumption of memory in Task Manager I then did the same with P3D V4 (sitting idle after load) and observed the very same continuous consumption of memory.

All the other apps I use with P3D (ChasePlane, Active Sky) when sitting idle remain constant in memory use, as does all the Adobe products, Photoshop, Illustrator and Dreamweaver.

Does anyone know what’s going on here and can offer a solution, this happened prior to the Windows10 update which I installed later in the vain hope that it might fix the problem all relevant drivers have been updated.

I need HELP, any suggestions?

MickP

System Specs:
Intel i7 4.0 GHZ OC:4.5GHZ
msi Z170A Gaming Pro Carbon
16GB DDR-4-3000 RAM
Nvidia GTX 1080
Windows10

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi,

I had a similar problem with v3 a while back, and after Googling I found some discussion about certain newer Nvidia graphics driver versions causing this problem. I ended up rolling back my driver to a version someone recommended and it actually solved the problem. If you're going to keep using v3 I suggest looking into that. Not guaranteed, obviously, but worth a try.

This might've been the thread:
http://www.prepar3d.com/forum/viewtopic.php?t=123508

-R

  • Upvote 1

Share this post


Link to post

Memory leaks can be caused by addons so it may not be the sim.

Regards
bs

 

Share this post


Link to post

I have tried the Nvidia driver route without success, the driver was the same before and after the leak.

The same is true of the addons nothing was added its the exact same before and after, except an update to ChasePlane which is so universally used surely others would have experience the same leak problem V3 and V4.

This is very puzzling does anyone have a methodology for pinpointing the problem?

MickP

  • Upvote 1

Share this post


Link to post

The last driver set that conclusively didn't leak VAS was 353.xx. Besides, I'd like to see a test where someone demonstrated that that a default P3d install with no add-ons and a 353.xx driver leaked VAS.

Share this post


Link to post
2 hours ago, jabloomf1230 said:

The last driver set that conclusively didn't leak VAS was 353.xx. Besides, I'd like to see a test where someone demonstrated that that a default P3d install with no add-ons and a 353.xx driver leaked VAS.

I think it was 376.53? Or .33. But that's the one that cured the VAS leak in v3 for me. If the same thing is happening in v4 it's obviously not been fixed yet, but we won't really have to worry about it coz in reality you're not going to run out of VAS in v4.

Share this post


Link to post
28 minutes ago, RancidViper said:

but we won't really have to worry about it coz in reality you're not going to run out of VAS in v4.

That was sort of my reaction to this thread. Who cares? Leak all the VAS you want.

  • Upvote 2

Share this post


Link to post
54 minutes ago, RancidViper said:

376.53

Yes my mistake. 353 would been from 1972 or so 🙃

  • Upvote 1

Share this post


Link to post

I guess the issue is if you still want to use v3. I was running 376.53 for the last several months because of the VAS leak. But even with most of my addons not working in v4 I find i'm spending a lot more in time in there, so I decided to update my drivers to the latest and have pretty much stopped flying in v3 now.

If you want to use v3 for awhile longer I'd suggest not updating to the latest drivers. :)

Share this post


Link to post

oom is a old issue-forget it once and for all invest in V4

Share this post


Link to post
11 hours ago, MPartlett said:

16GB DDR-4-3000 RAM

Upgrade RAM time. 16 should be enough, but if you want that extra buffer, RAM is relatively cheap today. 

Your better off to have a vanilla installation to see if its actually v4 core leaking VAS.  Combinations of addons of any sort could conceivably cause a leak so best to leave them out of it for now to pinpoint the issue.

Share this post


Link to post

If as you say "in P3D V4 not to be concerned about leaking memory" surely eventually a continuous leak will use up all available resources and result in a system crash of some sort?

  • Upvote 1

Share this post


Link to post

I have discovered the cause of my Memory Leak in both P3D V3 and V4.

It was Traffic; by simply turn All Traffic OFF I now have stable VAS usage in P3D V3 and of less significance, leaking memory in V4.

Thanks for all the suggestions and advice its all extending my knowledge base of the quirks and quarks of P3D.

MickP

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this