Archived

This topic is now archived and is closed to further replies.

bkeske

mfc70.dll problem...and more...Any Help/Suggestions?

Recommended Posts

Just recently I was flying and called up my kneeboard...heard a 'ding' and realized FS had froze. I control-alt-delete'd out of the program back to the desktop, and there was a message regarding a fault in the mfc70.dllThinking this may be a Reality RXP gauge issue, I restarted FS and tried bringing up the kneeboard in the default Cessana. Same thing. It seems everything else works except that button/command (as I knew of at the time).The first thing I tried was backing up my fs.cfg and allowing a new one to be built, but FS would not boot fully without it (??). Never had that happen before.Then I started removing some 3rd party modules I do not use enough to keep. I also removed FSM Moving Map, thinking it may have been the issue with the kneeboard. Nothing.Finally, I went into the #1 disc and replaced all the .dll's in my FS root directory with the defaults. No go.Retried to re-build the fs.cfg again...still would not boot-up.So...I said, 'well, I'm going to just not use the kneeboard till I figure this out', and at the end of my flight last evening I got a new fault with the (I'm trying to remember here...) 'atc.dll', or something similar to that.Anyone have any clue what is going on here?I'm smelling another fresh re-install, and I'm not looking forward to that....again.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Lol, I'm having the exact same problem with the exact same dll. being reported as the culprit. Each time I hit F10 to bring up the kneeboard the sim crashes.... Doesn't impair any other functions of the sim, though.ricardo

Share this post


Link to post
Share on other sites

>Lol, I'm having the exact same problem with the exact same>dll. being reported as the culprit. Each time I hit F10 to>bring up the kneeboard the sim crashes.... Doesn't impair any>other functions of the sim, though.>>ricardoWell, at least I'm not the only one! ;)

Share this post


Link to post
Share on other sites

Ok, no expert on this, but did a search on google for mfc70.dll. and found this (a lot more info available):"The mfc70.dll library is required for windows to operate. It provides a number of classes and code functions that are used in a wide variety of programs written using the Visual ,Net programming language. If mfc70.dll is unavailable, any software that relies on the functions that it provides will crash and/or become unstable."This seems to suggest that the dll needs to be reinstalled/got corrupted? Probably a good idea to wait for more knowledgeable folks to chime in on this. ricardo

Share this post


Link to post
Share on other sites

As I also looked into this (on-line), I also found that some of these .dll's can be slightly different. I did download one (thinking it may be corrupt) and installed it into the FS root directory.After reading, I figured that may not be a good idea, thus went into the FS #1 CD and replaced it with the default. Still didn't work....yea ricardo, this .dll stuff can get way beyond me, so I'll hope for from help by a more knowedgable person...I hope.Oh, and if it helps anyone, I did save a 'drwatson' log file wich shows in more detail these faults happening. I can't make heads or tails from it, but if anyone wants to look at it, let me know.

Share this post


Link to post
Share on other sites

It would be most helpfull for anyone trying to help you solve your problem to know ALL of the programs that may be related to FS that you were running. Also if it was an add on aircraft or default.

Share this post


Link to post
Share on other sites

As I said, it happened to both a payware and default aircraft.Here is what I use most often:1) FS Autostart (I think that is the name of it) starts 2-5 All the time.2) AI Seperation3) Active Sky v64) FS Screen (image capture)5) Flight Assistant6) Aircraft; typically use EG *Cirrus (20/22), *DF Bonanza, F1 172, *Carenado Cessna 206/210, and Carenado Piper 180/236*aircraft I have been flying most often recently.I use Reality RXP 430's in all, RXP FLT gauges in some, and recently installed the Sandel 3308 in the Cessna's7) Scenery: Nothing really special regarding scenery other than FSGenesis Mesh/landclass pretty much everywhere. Third party freeware airport sceneries when I come upon them, but no payaware scenery sets.I can't see how sceneries could effect this issue, but what do I know? ;)That is pretty much it.

Share this post


Link to post
Share on other sites

Just tried replacing all my default modules as well. There were many that had been replaced prior, but I'm not sure if these were actually replaced in the 'update FS .exe'Regardless, still the same problem exists.

Share this post


Link to post
Share on other sites

ricardo, Did you didn't by chance install the beta version of the new MS IE Internet Explorer (V7)?I did this past weekend to check it out against foxfire, and I'm thinking that was the problem.I reinstalled FS9 (backed up all my critical files) and still kept getting the same problem, and still could not re-boot without my old fs.cfg.Finally, for the first time, I did a system restore as I could not figure out how to get rid of the new IE Explorer Beta. MS would not allow me to back track to V6, but System Restore did the trick.....And finally I could get the issue of the kneeboard to work again. I could also re-build my fs.cfg, which I could not do even after an FS re-install.I'm reloading all my back-up folders now back into FS, hopefully I can get everything functioning as it was without too much problems/reinstalling all my add-on's.

Share this post


Link to post
Share on other sites

hey there i am now having that same problem, and yes i did too install the new iexplorer which i love!!! so i am going to uninstall the explorer and see if that is the issue

Share this post


Link to post
Share on other sites

I HAVE THE ANSWER!!!! just got off the phone with windows support and they said to in the main fs9 folder to find the dll file named oleacc.dll to oleacc.old.and thats it!! there u go!

Share this post


Link to post
Share on other sites

I seriously think this topic needs to be made sticky, and pinned at the top,how many mose simmers have to go through this before the responsible folks at Avsim show how responsible, and thoughtful of the simming community they are, and make this available to all, and stop these cries for help constantly disappearing on to other pages.who would think that after going over to IE7 they would have problems with FS9, I certainly didn't?

Share this post


Link to post
Share on other sites

This is all well and fine, but exactly what functions of FS9 are affected by the removal of oleacc.dll file?Lee

Share this post


Link to post
Share on other sites

Is this a confirmed fix?

Thanks

Ghiom

 

 

Posted 08 June 2006

 

Do you think the OP will come back?

Share this post


Link to post
Share on other sites

sorry, what's OP?

I just had the problem twice. Stack hash error and MFC70.dll the module. FS9.1 on Win 7.

Share this post


Link to post
Share on other sites

This thread is about as old as you have been a member. You have FS9 ? This forum is FSX. what you need is the CTD (crash to desktop) forum here @ Avsim.

BTW OP= original post(er)

Share this post


Link to post
Share on other sites

This is an automatic message.

 

This topic has been moved from "MS FSX Forum" to "Crash To Desktop (CTD) Forum". This move has been done for a number of possible reasons.

  • The most likely reason is that the post was off topic.
  • The topic could also have contained images or a video that were not appropriate to the original forum it was posted in.
  • The images might not have been "illustrative" or "explanatory" in nature.
  • The topic could have been moved because we deemed it to be more appropriately placed elsewhere.
Please ensure that your posts are "on topic" and contain illustrative images or videos as appropriate. Do not post videos or images just for entertainment purposes anywhere but in the screen shot or video forums. See our image posting rules here.

 

Members who continue to post off topic posts can be denied entry to specific forums in order to reduce and remove the practice. Your cooperation is appreciated.

Share this post


Link to post
Share on other sites