Falconfly

Shimmering P3D V4

12 posts in this topic

Hey! 

I've tried everything including a full windows reinstall, rollbacked to a few Nvidia drivers, running 8SGAA both in Sim and through Nvidia inspector. Currently running 8SSAA in Sim and NI. 16x.

I just can't get the shimmering to stop. Its like lines running on the screen left to right and in the night orbx ftx global night lights sparkle real badly. It looks terrible! 

I'm on the latest driver from. Nvidia. Gtx 1060 6GB 6600k 16GB ram and 1080p

Is this a known issue? I've seen a few videos online and haven't seen such bad shimmering. 

Any ideas? 

0

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

8xSGSSAA in NI MUST be paired with 8xMSAA in P3D not with SSAA. SGSSAA enhance multi sampling not super sampling.

 

Just set 8xSGSSAA in NI, nothing else from AA settings and set 8xMSAA in P3D.

Anyway, 8xSGSSAA will kill your performance in heavy clouds scenario. With my GTX1080 I was able to set 4xSGSSAA in heavy clouds as maximum. For better performance I recomend swith to 4k resolution, turn off SGSSAA and just use 2-4xMSAA. It will be less performance hit than SGSSAA.

0

Share this post


Link to post
Share on other sites

Having the same problem here with shimmering/sparkling, its mainly in urban areas, tried everying OP has to no avail. It's driving me nuts.

Might give your suggestions a go Jiri.

I'm running a i7-7700k stock with GTX1080, 16 gig ram plus Asus Strix Z270 Gaming mobo.

0

Share this post


Link to post
Share on other sites
6 minutes ago, Dags said:

Having the same problem here with shimmering/sparkling, its mainly in urban areas, tried everying OP has to no avail. It's driving me nuts.

Might give your suggestions a go Jiri.

I'm running a i7-7700k stock with GTX1080, 16 gig ram plus Asus Strix Z270 Gaming mobo.

Thank God I'm not the only one! I hope a driver revision fixes the issue.

 

1 hour ago, Jiri Kocman said:

8xSGSSAA in NI MUST be paired with 8xMSAA in P3D not with SSAA. SGSSAA enhance multi sampling not super sampling.

 

Just set 8xSGSSAA in NI, nothing else from AA settings and set 8xMSAA in P3D.

Anyway, 8xSGSSAA will kill your performance in heavy clouds scenario. With my GTX1080 I was able to set 4xSGSSAA in heavy clouds as maximum. For better performance I recomend swith to 4k resolution, turn off SGSSAA and just use 2-4xMSAA. It will be less performance hit than SGSSAA.

I'll try this and report back. Thanks Jiri.

0

Share this post


Link to post
Share on other sites

One day they will fix this i hope, you shouldn't have to run in 4k just to get rid of shimmering/ sparkling.

 

 

0

Share this post


Link to post
Share on other sites

I have the same issue using a 1080Ti and 2 x SSAA.  Not using NI

0

Share this post


Link to post
Share on other sites

If nothing else works, using NI >> Texture Filtering-->Negative LOD bias ----> sett to "clamp".

0

Share this post


Link to post
Share on other sites

Ok got rid of quite a bit of shimmering/sparkling. What i did was put 2 x SSAA in NI, and in the sim i put in 8 x MSAA. Geez we shouldnt have to resort to these kinds of practices.

Now i just have to sort out this autogen popping, its bloody annoying as well.

Lets hope in some soonish patches these things are addressed, hey like most of you guys i'm not holding my breathe.

1

Share this post


Link to post
Share on other sites

For some reason my P3D doesn't want to start now. All i did was install pro atc X along with some A2A aircrafts. It just starts, shows a scenery loading screen for a split sec and then closes, it still shows in task manager. Very strange, i guess another windows reinstall :blush:

 

2 hours ago, Dags said:

Ok got rid of quite a bit of shimmering/sparkling. What i did was put 2 x SSAA in NI, and in the sim i put in 8 x MSAA. Geez we shouldnt have to resort to these kinds of practices.

Now i just have to sort out this autogen popping, its bloody annoying as well.

Lets hope in some soonish patches these things are addressed, hey like most of you guys i'm not holding my breathe.

Will try this when i get P3D up.

Thanks for all the support.

0

Share this post


Link to post
Share on other sites

You shouldn't have to use SSAA. In fact Nvidia never intended for it to be a proper AA mode in the first place.

Let me ask how many other games exhibit  this behavior? Very few if any....

Better yet ORBX and some other devs need to fix their models. If you fly with default P3D shimmering is almost non existant on default autogen and simobjects. 

I have posted on the issue in their forms in the past and result is always same a) must be bad driver b) must be your video card c) Something is wrong with your system.

Then the fan boys pile on and say how its not happening on their system.

Sadly I've had 3  different systems, videocards and endless driver updates. It's safe to say it ISN'T that.

I think it's because the mipmapping or something is off or missing.

I suspect they use some method to try to keep details at far distances but the result is shimmering. Again it's a guess but a search on Google about shimmering textures in 3d models almost always points at mipmaps.

0

Share this post


Link to post
Share on other sites