Mejjo

Blurry ground textures

Recommended Posts

Hi everyone,

I've noticed in V4 my ORBX ground textures are taking what seems like a long time to focus, They appear blurry and its a good few minutes before they sort themselves out and appear clear. I've tried many different settings to try and fix this. Does anyone know of a way to help this issue?

I have a i7 @ 4.8ghz and 8gb GTX 1070 so i don't think it would be a hardware loading issue. 

Thank you. 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I noticed that in one of froogle's videos the other day. Occasional blurries was about the only reason I had to move from FSX to P3D.

Share this post


Link to post

I've heard about that - How do i do that? Someone said the ShadersHLSL folder but i did a test and moved them out and tried to restart P3D and it gave me errors about not finding shaders etc. Was that not the right way to delete shaders?

Share this post


Link to post

Local Disk (C:) ► Users ► You ► AppData ► Local ► Lockheed Martin ► Prepar3D ►  Shaders

Delete the shaders folder, launch P3D and it will be rebuilt.

Do not delete from HLSL because the sim won't load, as you found.

  • Upvote 1

Share this post


Link to post

I also get blurry ground textures anytime there's photo textures also. Please let me know if deleting your shaders fixed the problem.

  • Upvote 1

Share this post


Link to post

This is the one thing that frustrates me more than anything. I run a 6700@4.5Ghz with a GTX1070 and also get quite bad texture blurries. The odd thing is, it doesn't matter what my settings are in P3d or whether I rebuild the cfg or delete the shaders, they are always there. Sometimes moreso than others. This is the first time I am considering XP over P3D V4. I thought this would have been sorted out by LM with a 60 bit sim.

Share this post


Link to post
On 8/1/2017 at 9:45 PM, captain420 said:

I also get blurry ground textures anytime there's photo textures also. Please let me know if deleting your shaders fixed the problem.

Hi there

Well, i think deleting the shaders has done something. I have not have blurry ground textures anymore yet. Fingers crossed that has fixed it. 

Thank you for the help! 

  • Upvote 1

Share this post


Link to post
On 8/1/2017 at 4:38 PM, sidfadc said:

Local Disk (C:) ► Users ► You ► AppData ► Local ► Lockheed Martin ► Prepar3D ►  Shaders

Delete the shaders folder, launch P3D and it will be rebuilt.

Do not delete from HLSL because the sim won't load, as you found.

Thank you for pointing me in the right direction. Yes i did learn that removing the files from that folder is a no no... 

Share this post


Link to post

Glad you fixed your blurry textures problem! I have yet to delete my shaders, I will give that a shot to see if that fixes it for me as well! Thanks! :)

Share this post


Link to post
Just now, captain420 said:

Glad you fixed your blurry textures problem! I have yet to delete my shaders, I will give that a shot to see if that fixes it for me as well! Thanks! :)

Hopefully it fixes it for you too. I think i also changed my LOD radius too. Might be worth a try if the shaders doesn't work? :) 

  • Upvote 1

Share this post


Link to post
5 minutes ago, captain420 said:

What LOD radius are you using?

I'm on 6.5 now. For some reason it was changed down to 3.5, I have no idea what caused that. 

Since raising that up and deleting the shaders things are looking much better. I still seem to have slow loading autogen but i think P3D are aware there is an issue with that. 

Share this post


Link to post
21 hours ago, Rockliffe said:

This is the first time I am considering XP over P3D V4. I thought this would have been sorted out by LM with a 60 bit sim.

I wonder why the switch to 64bit should have changed anything on the blurry question? BTW: I do not see any blurries in 90% of my flights. Only Switzerland Professional X (kind of a photo scenery) seems to be prone for blurries when flying low and fast with my current settings. Did you add the "TEXTURE_SIZE_EXP=9" line to your config? Maybe you should try this once.

Share this post


Link to post
47 minutes ago, AnkH said:

I wonder why the switch to 64bit should have changed anything on the blurry question? BTW: I do not see any blurries in 90% of my flights. Only Switzerland Professional X (kind of a photo scenery) seems to be prone for blurries when flying low and fast with my current settings. Did you add the "TEXTURE_SIZE_EXP=9" line to your config? Maybe you should try this once.

Hi, I assumed LM would have done a lot of work to the sim in the same way when they initially changed the original coding and put a lot more processing onto the GPU. It would seem not. I have also read reports from guys saying they no longer have blurries since going to V4, so it remains a mystery to me. The "TEXTURE_SIZE_EXP=9" is a new one to me. What does this do? Cheers.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now