Pubby Pumqin

PMDG 737 HUD problem

Recommended Posts

Help AVSIM continue to serve you!
Please donate today!

Float a ticket to PMDG support. They'll send you the correct entries to copy and past to your dll.xml.  that solved the same issue for me last week. Smart bunch of guys they are.

  • Upvote 1

Share this post


Link to post
Share on other sites

fixed it guys. thanks for the suggestions.

I looked into my dll.xml file and I noticed the PMDG HUD interface code thing isn't there, so I went to to my backup file for the dll.xml and I found the code written in there, so I replaced my current dll.xml with the backup file and reinstalled addon manager.

  • Upvote 1

Share this post


Link to post
Share on other sites

The 737 installer for FSX is bugged in that it doesn't add the DLL.xml entry as it's supposed to. The installer will need to be updated to fix this. (The P3D version modifies the P3D DLL.xml just fine.) No it's not a permissions problem or the result of any other issue - I've confirmed this 3 separate times.

Molly Norris

Share this post


Link to post
Share on other sites
2 hours ago, molleh said:

The 737 installer for FSX is bugged in that it doesn't add the DLL.xml entry as it's supposed to. The installer will need to be updated to fix this. (The P3D version modifies the P3D DLL.xml just fine.) No it's not a permissions problem or the result of any other issue - I've confirmed this 3 separate times.

I just uninstalled the products, manually removed the entry from the DLL.xml, and then re-ran the installer and it's back. I'd be interested to see what other people are seeing, as I'm not seeing what you are.

It would be prudent to stay your accusations of something until you have a little confirmation, by the way. Just because it isn't working on your single computer doesn't mean that it's immediately an issue in our code. It may very well be, but it not working on your own computer immediately points to a lack of permission issues and a code issue? Sorry, no. There's more that needs to occur here.

  • Upvote 1

Share this post


Link to post
Share on other sites

I had to search this forum for the dll.xml enteries.  I had the same problem on a clean install of FSX-SE and NGX (latest version).

Share this post


Link to post
Share on other sites

Kyle, I have seen numerous posts over the past few weeks with the exact same issue with the FSX installer.

edit: I think you may have gotten a mistaken impression from my post, it wasn't "accusatory" or negative in any way. You're right though, it may be some other factor impacting (like Windows 10 with a certain update, for example.) All I can say is since the major updates, I've actually done 3 clean, full installations (including OS install) and ran into the HUD DLL issue all three times, the last time being the very latest installer, after the couple of tiny updates that came out after the major one.

Molly Norris

Share this post


Link to post
Share on other sites
18 minutes ago, molleh said:

Kyle, I have seen numerous posts over the past few weeks with the exact same issue with the FSX installer.

The only ones I've seen have been related to the 777 installer, and FSX:SE specifically. This is an entirely different issue (one in which it cannot find the dll.xml file at all).

So no, this is not the exact same issue.

Share this post


Link to post
Share on other sites
11 minutes ago, scandinavian13 said:

The only ones I've seen have been related to the 777 installer, and FSX:SE specifically. This is an entirely different issue (one in which it cannot find the dll.xml file at all).

So no, this is not the exact same issue.

I swear I saw a couple more as well, but the Avsim search functionality always seems a bit wonky for me.

Molly Norris

edit: Ultimately, we would just be going around in fruitless circles unless you (or somebody else in the PMDG testing team) can do a truly fresh clean install on FSX-SE and report what they find.

Share this post


Link to post
Share on other sites

I just noticed the same issue.  Just did a complete rebuild of my FS PC (new hardware).  Re-installed FSX-SE and the NGX and noticed a blank HUD.  Sure enough, the DLL entry was not added to the dll.xml file.  Thankfully I took a backup of the appdata_fsx folder before the rebuild so I still had the parameters.  And, no, my dll.xml file is definitely not corrupt.

Cheers.

Share this post


Link to post
Share on other sites

Uninstall everything, download new installers (after clearing your downloads folder of any PMDG-related files), and then install.

Share this post


Link to post
Share on other sites

So I did the download again, full uninstall and re-install of the NGX and still no joy on it adding the HUD entry in the DLL.XML file.  I tried twice.

Cheers.

Share this post


Link to post
Share on other sites
2 minutes ago, ViperXBR said:

So I did the download again, full uninstall and re-install of the NGX and still no joy on it adding the HUD entry in the DLL.XML file.  I tried twice.

Cheers.

FSX, FSX:SE, or P3D?

Also, did you delete all PMDG-related downloads from your download folder prior to re-downloading?

Share this post


Link to post
Share on other sites
2 minutes ago, scandinavian13 said:

FSX, FSX:SE, or P3D?

Also, did you delete all PMDG-related downloads from your download folder prior to re-downloading?

FSX-SE on Win10 Pro.  I had nothing in relation to these files previously in my download folder.  I have a NAS that store all my installation files.  In this case I didn't even touch the NAS doing this install.

BTW, on a side note, after upgrading my hardware, and installing the OS, FSX and PMDG, I have not experienced any CTD's when exiting the SIM as I had before.  I will keep a lookout for this as I add more add-ons.

Cheers.

Share this post


Link to post
Share on other sites

Probably AS2016 messed up your dll.xml. There should be a backup called "dll.xml.ASbackup"

Go to C:\Users\[Your Name]\AppData\Roaming\Lockheed Martin\Prepar3D v4\dll.xml and copy the HUD interface content back (start with launch.addon)

Wing H W Cheung

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now