Recommended Posts

Help AVSIM continue to serve you!
Please donate today!

Quote

 

Just did a quick circle around San Diego before Blindspot comes on NBC. Smooth and FPS are staying up well,  Oculus Rift is steady at 90, Tray Tool gives a solid 90 fps with 97% headroom.

Share this post


Link to post
Share on other sites
Quote

Beta 7

Flight Model notes:

BATTERY improvement for ELECTRIC airplanes, such as quad-rotors or other e-craft:

Open an airplane with an ELECTRIC engine in Plane-Maker. Now go to the STANDARD menu, SYSTEMS item. In that window: Go to the ELECTRICAL 1 tab and enter your battery watt-hours. Go to the LIMITS 2 tab and enter your nominal battery voltage and max amperage… these numbers multiplied are the max power output of the battery. Go to the ELECTRICAL 2 tab and simply drag the curve up and down as you like: This is the available power at each state of charge! Drag the curve to be accurate as needed for your battery. We default to a standard asymptote but you can set as perfect for your battery design.

Clearing a flight plan from a plugin now also clears departure and destination airport selections.

New dataref requests:

sim/flightmodel/engine/descent_speed_ratio float

sim/flightmodel/engine/vortex_ring_state float

sim/aircraft/autopilot/vvi_step_ft

sim/aircraft/autopilot/alt_step_ft

sim/aircraft/autopilot/radio_altimeter_step_ft

sim/graphics/view/viewport int

sim/operation/override/override_ground_trucks

XPD-8107 Fixed QPAC panel scroll position (again).

XPD-8116 X-Plane crashes when calling GNS430 commands without a GNS430 being installed.

XPD-8200 Distant clouds showing in front of plane.

XPD-8271 Override to get rid of ground trucks.

XPD-8378 Icons don’t appear in OS High Sierra.

XPD-8395 Fixed wrong cursor in floating widgets when main monitor is right-hand monitor.

XPD-8396 Plugin access to viewport from draw callbacks.

XPD-8398 Generic lights bumped to 128, instrument rheostats bumped to 32.

XPD-8405 make_panel_previews – crashes with G1000.

XPD-8407, XPD-8406 New datarefs for access to prop wash for rotors.

XPD-8419 Removed one more instance of forced-focus-taking.

XPD-8420, XPD-8308, XPD-8421, XPD-8411, XPD-8475, XPD-8535: art resources updated.

XPD-8426 Facade definition crashes X-plane.

XPD-8433 Drawing order with clouds in cockpit.

XPD-8434 Aircraft menu icons made with 11.10b are too big.

XPD-8480 viewing replays where a networked plane with weapons is blown up will no longer crash.

XPD-8506 Blue channel in .ter files normal map seems inoperative.

XPD-8508 Time to traverse the navigation database now tenfold.

XPD-8510 We now make it very clear that launching the installer will quit X-Plane.

XPD-8511, XPD-8507 Fix screwy manipulators on b6.

XPD-8515 Fix for our internal “short names” for aircraft interfering with lookup of aircraft by full path.

XPD-8516 Support for the X-Plane side of forcing even GUI-backed plugins to *ask* for focus.

XPD-8521 Directional gyro alignment popup optional.

XPD-8527 Fixed log spam from geoid test.

XPD-8530 Datarefs to control autopilot altitude / vertical speed steps.

XPD-8536 Propeller feather after shutdown when they shouldn’t.

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Well, seems like a good time to jump on the beta wagon.  :happy:

My most important wish has come true - no more ground shakes. Fantastic!

Share this post


Link to post
Share on other sites

I'm having major graphical glitches in Mac OS High Sierra with this update (or it could just be the OS update). Anyone else on Mac having problems with the new OS?

Share this post


Link to post
Share on other sites
3 hours ago, tonywob said:

 Anyone else on Mac having problems with the new OS?

Yes. Its a well known bug. Many games have problems with the compatibility of High Sierra.

Share this post


Link to post
Share on other sites
7 hours ago, tonywob said:

I'm having major graphical glitches in Mac OS High Sierra with this update (or it could just be the OS update). Anyone else on Mac having problems with the new OS?

No issues here.  On the latest versions of both XP11 and OS.

Share this post


Link to post
Share on other sites

Strange issue here with Beta 7: I have updated a full X11 and a separate demo X11. Both show the same: I have two screens with X-Plane running on one and whatever else on the second. If I switch out of X-Plane to something on the 2nd screen and back to X-Plane the screen goes black and it crashes directly or I have to kill it. 

This did not happen with any of the Betas before. 

Now, there is of course a possibility that something on my Windows 10 has changed in between that I need to find and fix. So I wonder: is Beta 7 working ok for everybody in that regard? 

Share this post


Link to post
Share on other sites
9 hours ago, AnsorgJ said:

Strange issue here with Beta 7: I have updated a full X11 and a separate demo X11. Both show the same: I have two screens with X-Plane running on one and whatever else on the second. If I switch out of X-Plane to something on the 2nd screen and back to X-Plane the screen goes black and it crashes directly or I have to kill it. 

This did not happen with any of the Betas before. 

Now, there is of course a possibility that something on my Windows 10 has changed in between that I need to find and fix. So I wonder: is Beta 7 working ok for everybody in that regard? 

Did you recently update Windows 10 to the Creators Fall Edition?  This seems slow down the performance of games dramatically in some cases. I even went back to Windows 8.1 because of it. It was affecting not only X-Plane which went from a normal +/- 40 fps to 15 fps but nearly all my other games such as BF4 which became totally unplayable. There are many stories on this you can find with Google. Just a thought,  it may be something totally different.

Share this post


Link to post
Share on other sites
47 minutes ago, Glenn_C said:

Did you recently update Windows 10 to the Creators Fall Edition?  This seems slow down the performance of games dramatically in some cases. I even went back to Windows 8.1 because of it. It was affecting not only X-Plane which went from a normal +/- 40 fps to 15 fps but nearly all my other games such as BF4 which became totally unplayable.

Make sure that in the X-Box app DVR is off:

https://support.steampowered.com/kb_article.php?ref=6239-DZCB-8600

The Windows update switches it on (if it was off before), and this can have a noticable performance impact.

Share this post


Link to post
Share on other sites
11 hours ago, Glenn_C said:

Did you recently update Windows 10 to the Creators Fall Edition?  This seems slow down the performance of games dramatically in some cases. 

No such issues with W10 so far, running even (Slow) Insider since ages.

10 hours ago, MarioDonick said:

Make sure that in the X-Box app DVR is off:

https://support.steampowered.com/kb_article.php?ref=6239-DZCB-8600

The Windows update switches it on (if it was off before), and this can have a noticable performance impact.

Weird, I even used that to record videos from the running X-Plane. At least before the Fall Creators Update. Have not used it since ... 

Probably something else on my system then. Will check drivers and stuff ... 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now