Jump to content

Sign in to follow this  
Johnny19

P3D 4.1 CTD near Labrador

Recommended Posts

Heh.

 

Anyway, glad to see a potential fix in place as well developers listen to customers and offer help.  I’ll have to try the fix out myself soon.


Kyle Weber (Private Pilot, ASEL; Flight Test Engineer)
Check out my repaints and downloads, all right here on AVSIM

Share this post


Link to post

Umberto, do you recall telling us only a few months ago that this issue has zero to do with GSX? 

Share this post


Link to post
8 hours ago, Bardia said:

Umberto, do you recall telling us only a few months ago that this issue has zero to do with GSX? 

Hands down, you've just made the most constructive comment in here.

Truthfully though, regardless of whether GSX is or isn't the problem, a fix has been offered so just enjoy the good customer service and keep flying.....

  • Upvote 1

Johnny Crockett
7700K @5ghz | Asus GTX 1070 | G.Skill 16GB 3600 | P3D V4

Share this post


Link to post

Unfortunately it crashed like clockwork this evening. LSZH-KBOS QW787 coming up over newfoundland/labrador. NTDLL.dll. Brand new clean fresh install of GSX.

Share this post


Link to post

This reminds me of the ntdll crash that occurred at a NDB @LOWI in FS9 or was it FSX ? Anyway it was never fixed, and always had to avoid Austria. There was a similar problem at Brussels too, Makes me wonder if it is a rouge Navaid.


System: MSFS2020-Premium Deluxe, P3D 5.0, ASUS Maximus XI Hero,  Intel i7-8086K o/c to 5.0GHz, Corsair AIO H115i Pro, Corsair Spec Omega Case,Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, 32Gb Corsair Vengeance DDR4 3200Mhz RAM, EVGA 850+ Gold PSU,Win 10 Pro 64-bit, Samsung 43 UHD TV, LG 43UD79 43" 4K IPS Panel., Logitech X56 Hotas Stick and Throttle, Logitech/Saitek Flight Yoke System, Multi, Radio, Switch Panels

 

Share this post


Link to post
58 minutes ago, av8r172 said:

Unfortunately it crashed like clockwork this evening. LSZH-KBOS QW787 coming up over newfoundland/labrador. NTDLL.dll. Brand new clean fresh install of GSX.

Using fsreal time?? 


 
 
 
 
v63vq9-5.png

Share this post


Link to post
7 hours ago, ZKOKQ said:

This reminds me of the ntdll crash that occurred at a NDB @LOWI in FS9 or was it FSX ? Anyway it was never fixed, and always had to avoid Austria. There was a similar problem at Brussels too, Makes me wonder if it is a rouge Navaid.

 

I have to agree and I believe that this is something inherent to the sim or to the combination of the add-ones. Wrong NAVAID in the NavDataBase could be a trigger also or incorrect AI placement between AI sectors. The only way to test is to have a naked default P3D and fly transatlantic constantly adding add-ones progressively. Unfortunately, this method is extremely time-consuming.

Here is my solution for transatlantics that has worked so far for all my instances (PDMG, both 777 and 747) and I have never had this error since them.

1. Once you're at your initial FL, kill GSX completely.

2. As soon as you leave Shanwick ARTCC fire up X16 (anyway, it's absolutely nothing to do while you're over the pond) and go back to normal once you enter Boston ARTCC. That's all, even thought VATSIM folks won't like my approach, I know that.

3. At the TOD, reactivate GSX

Also, since I'm able to avoid this error while using X16 acceleration I have my own theory that incorrect AI placement between in-sim AI zones could play it's role. In case you're unaware, once you hit anything faster than x8 acceleration, P3D internal engine suppresses any AI activity. Hence, those of you who fly in a normal time tend to face an error with greater probability.

Edited by G-YMML1
  • Like 1

Share this post


Link to post
7 hours ago, tooting said:

Using fsreal time?? 

Nope, and not using any type of AI whatsoever

Share this post


Link to post
7 minutes ago, av8r172 said:

Nope, and not using any type of AI whatsoever

As I posted above, I suspect a NDB or VOR (default ) is the culprit. Does the NTDLL crash occur when your aircraft comes into range......?

Like everyone else, just surmising. It is exactly the same occurrence I mentioned above, ie the RTT NDB at LOWI. Had to avoid being in range of it.


System: MSFS2020-Premium Deluxe, P3D 5.0, ASUS Maximus XI Hero,  Intel i7-8086K o/c to 5.0GHz, Corsair AIO H115i Pro, Corsair Spec Omega Case,Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, 32Gb Corsair Vengeance DDR4 3200Mhz RAM, EVGA 850+ Gold PSU,Win 10 Pro 64-bit, Samsung 43 UHD TV, LG 43UD79 43" 4K IPS Panel., Logitech X56 Hotas Stick and Throttle, Logitech/Saitek Flight Yoke System, Multi, Radio, Switch Panels

 

Share this post


Link to post

One way of testing my theory is to run "Make Runways" and find the bgl files for the navaids in the area of the crash and disable them.

For example: New Brunswick and St John  is Scenery\0301/scenery\APX30150.bgl and disable it. That bgl covers a wide area right down to Maine in the US.

Anyway, I could be talking out my rear end.

Edited by ZKOKQ

System: MSFS2020-Premium Deluxe, P3D 5.0, ASUS Maximus XI Hero,  Intel i7-8086K o/c to 5.0GHz, Corsair AIO H115i Pro, Corsair Spec Omega Case,Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, 32Gb Corsair Vengeance DDR4 3200Mhz RAM, EVGA 850+ Gold PSU,Win 10 Pro 64-bit, Samsung 43 UHD TV, LG 43UD79 43" 4K IPS Panel., Logitech X56 Hotas Stick and Throttle, Logitech/Saitek Flight Yoke System, Multi, Radio, Switch Panels

 

Share this post


Link to post
1 minute ago, av8r172 said:

Currently on a fresh p3d install that does not have it. I'm going to try it.

 No, please don't. 

What do you mean "fresh install"? Just naked P3d? Did you get your ntdll.dll error in the naked sim without GSX, FSDT sceneries? If so, then the answer might be leading to *bgl failure that only LM could fix. 

Share this post


Link to post
13 minutes ago, G-YMML1 said:

 No, please don't. 

What do you mean "fresh install"? Just naked P3d? Did you get your ntdll.dll error in the naked sim without GSX, FSDT sceneries? If so, then the answer might be leading to *bgl failure that only LM could fix. 

Fresh install meaning no default nav database update. I've been getting this crash for a long time now. Always with Gsx installed, but clearly that doesn't seem to be the culprit for me as it crashed even with the latest version that disables it in cruise.

I'm not really inclined to start disabling add-ons that I paid lots of money for just to be able to fly routes that I can easily avoid.

 

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    34%
    $8,535.00 of $25,000.00 Donate Now
×
×
  • Create New...