Johnny19

P3D 4.1 CTD near Labrador

Recommended Posts

Guys,

I don't get CTD often, i am usually using my sim on short haul routes, long hauls a bit less, but it seems that is can't cross the Atlantic westbound without a program stoped working error. It is not a first time that a sim crashes near the Labrador peninsula, right about when exiting the NAT track. I haven't had issues flying over Greenland westobun, or NAT eastbound. Also no crashes on long hauls in other parts of the sim world. Addons using are pmdg 747 and 777, orbx global, vector, north america, Europe, active sky. I am thinking about reinstalling my system today.  Any thoughts would be really appriciated.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

So, there is no AppCrashView or Event Viewer report (see AVSIM CTD Guide - link in my signature)?  At the beginning of the guide it discusses the Event Viewr and AppCrashView.  What you are looking for is the faulting module.  Although the faulting module may not pinpoint exactly what happened, it provides a clue that can be used to research further. 

In the CTD Guide, page 9 (?) has a long discussion on how to fix most P3DV4.1 crashes or freezes.  You start out by renaming your P3D.cfg to P3D.cfg.off, then renaming the two dll.xml's to dll.xml.off, and lastly, renaming the scenery.cfg to scenery.cfg.off or opening your Addon Organizer and disabling every addon.  High settings (performance) are now the major culprit for CTD's in P3DV4.  When your simulator is calling up textures and scenery objects and AI and many other things, if the settings are too high (i.e., P3D and Display Driver), the sim will crash.  It cannot handle all of the calls.  So, disabling all of the addons might disclose it is an addon because, if there is no crash, then it is the fault of one of your addon sceneries. We knew that when the problems with running out of VAS went away with 64-bit apps, members would be maxing their settings and causing performance issue crashes. It could also be a corrupted addon.xml as it might not be encoded properly and cannot be read.

You should not reinstall Windows.  As I stated on page 25 of the guide, you should run the Windows Repair program that will repair Windows for you!

Hope this helps.

Best regards,

Jim

  • Upvote 1

Share this post


Link to post

Jim, fist thank you. I did read the avsim guide. And there is an event recorded in the event viewer report.  What puzzels me that i can do long hauls everywhere and with no crashes except when a flight path takes the flight over the Labrador peninsula. The only addon in that area would be Vector and north america LC. I do remeber however, that i used to get VAS warnings in previous p3d versions around the same area.

Share this post


Link to post

Back in the "day" and, as stated in the AVSIM CTD Guide, I got CTD's and freezes at exactly the same spot in my flight plan.  It resulted in an ntdll.dll error every time.  When I ran Process Monitor, as described in the CTD Guide, I was able to figure out what was loading at the time of the CTD/Freeze.  MyTrafficX!  Disabled MyTrafficX in the scenery.cfg and the crashes stopped.  Turns out there was an AI w/o a flight plan and the sim was calling for it.  Started to report it to the developer but found a couple of other members beat me to it and they upgraded MyTrafficX from 5.2b to 5.2c and a bit later on to MyTrafficX6a.  Then suddenly everyone was getting a crash at the same location again and we all suspected it was MyTrafficX again so we all disabled it and sure enough, the crashes stopped.  Some brilliant member figured out it was military AI and disabled mytrafficmil.bgl and that fixed the problem.  I wasn't getting those crashes so figured the brilliant member was totally wrong as I was flying over military bases in the Wash DC area and no crashes.  Then, when I upgraded to P3DV4.1, I starting flying a route from KSFO to Orbx KSAN every day in the PMDG 747.  As I was descending to the approach and about 8nm from the turn into the approach RW 9L approach, the sim crashed and the error report showed the G3D.dll was the cause.  Tried it several times and kept getting a G3D error at the same point.  I figured there was an object put into the scenery by Orbx that was causing the crash so disabled Orbx SoCal and KSAN and flew the same route again.  Another CTD at the same point!  This is it!  I'm throwing this computer out the window.  I'm fed up with flight simming and especially P3DV4.1.  Then I remembered there were many Marine and Navy bases near San Diego so got to thinking about not disabling the mytrafficmil.bgl.  Still I had flown all around this area before checking out Orbx SoCal and their release of KSAN and no crashes but, what the hay, figured I would disable mytrafficmil.bgl.  Tried the flight again and this time total success!  Bottom line - if you are getting a crash at the same location all of the time, disable any AI program.

In your case, thousands of members live in Quebec and Canada and fly in this area without any problems.  So far it has just been you reporting this CTD.  Do you have a flight plan you use to replicate this error so others can try?  If others get this error at this same spot, then maybe we can pinpoint exactly the cause.  Personally I would be following my guidance in the CTD Guide setting up the Process Monitor so only P3D and P3D addons are loading.  Then when the crash occurs I can look to see what was loading when it happened.  There's another new way that might be easier for some who have Windows 10.  Click on the Windows key and R and type resmon in the Run command.  The resource monitor will show up.  Start up P3D and enable just P3D in the resource monitor.  Then click on the Disk tab and then look down and open up Disk Activity where it will show you everything loading in P3D as you are starting up or loading the flight and during the flight.  I have two monitors but only use my 34 inch monitor for flight simming.  My 24 inch is used for programs like Resource Monitor so I can be monitoring the action as I'm flying.  If you do not have a second monitor, you can put P3D into Windowed Mode and the resource monitor to the side of the P3D Screen.  Might help you in investigating this. 

Although the resource monitor might help, it does not load as many processes as Process Monitor.  Process Monitor loads approximately 100,000 process every 30 seconds.  If it is loading MyTrafficX (if you have that installed), it will show it loading a lot as it processes another AI in the area so you have to make sure you close it down as fast as possible (ctrl+E) to get as near as possible to the time the crash occurred.  I usually write down the system time and that will get me within a minute of the log.  In one minute, thousands of entries will appear. 

But, then again, an even easier process is to open up the Addon Organizer and disable every addon.  If there is no crash, then it is one of the Addons and you will have to enable addons 4-5 sceneries at a time until the crash reappears.  It's a tedious process but you know the problem is one of them and you are getting closer.

Share this post


Link to post

Same for me, 4.1, Vector, NA LC, PMDG.  P3D always crashing while approaching Canada from Europe over Labrador also.  No mytraffic installed.  There is some kind of conflict in that area....I still can't nail it down though.

Share this post


Link to post

Same here. Only happens in P3Dv4, P3Dv3.0 worked flawlessly

Share this post


Link to post

Happy to know i am not alone with this issue. Jim, I don't use MyTraffic or any kind of AI programs for that matter. All of my AI is custom, AIG flightplans. And as you mentioned here is the flightplan from FRA to IAD (OBOKA UZ29 TINIK UZ291 BREDA REFSO UL980 LAM UL179 CPT UL9 STU UN546 BAKUR DOGAL 550000N/0200000W 570000N/0300000W 580000N/0400000W 570000N/0500000W HOIST ANCER YSC ALB HYPER7). Crash happened just before HOIST with PMDG 747, AS, ASCA, Vector, NA LC. Again, I have read all of what you wrote here, and again, i do have a lot of knowledge how software works and what is happening under the hood. I do suspect however, that the AI flightplan could be a culprit here, although this need further testing and free afternoon.

Share this post


Link to post

Unfortunately I do not have the time to test the flight plan but sure someone else will.  Good luck in finding the problem and fixing it!!  I'll move this to the P3D Forum so more "experts" can take a look. 

Share this post


Link to post

Crossed three times over that route in last three days....so far so good....I remember before I found on one of the Forums, Area 100nm around YYZ was memory eater, but that was on FSX and indeed monitoring VAS above that area, specially with heavy clouds really resulted in high memory usage. Personally I didn't had any CTD even than using same add-ons as you guys. But again, that was FSX. Ever since MS "abandoning" 32 bit and me switching to v4 I fly mostly that route....EDDF/EDDM/LOWW/EGLL... to CYYZ and KIAD/KORD/KBOS as well.....since I am currently at EDDF I will fly to KIAD using same route tomorrow and report....

In terms of settings I am everywhere at High except distance ULTRA...but that's it. And yes I use again, same add-ons, ORBX, ASP4 now...etc

P.S. I don't have any AI software though, but planing getting UT just released....maybe.

  • Upvote 1

Share this post


Link to post

I’ve also had repetitive crashes both approaching Labrador and over Greenland...it’s like a flightsim Bermuda Triangle.  I generally don’t fly between Europe and the US west coast anymore...too risky.

I know others have run into similar situations, where an otherwise stable sim is crashing in these locations only.  It would be interesting if there was a way for anyone who encounters a CTD in this area to log it on a map using the last/long coordinates at the point of CTD.  Not sure if such a tool exists?  That might help shed some light on the exact location causing the CTD (if there is one).  

My money’s on something weird buried deep down in the default scenery in these areas.

Share this post


Link to post

A few months ago, I was getting a CTD event at the same location near Hudson Bay such as on EGLL-KSFO flights.  I removed the Navigraph's Simlink module and problem went away.  I've not allowed it to install in spite of their almost weekly updates to their Charts application.

Share this post


Link to post

Hmmm..you really have to have experience to figure this.....Thanks for the tip....:happy:

Share this post


Link to post

I found AI to be quite often the culprit for crash.  Try repeat the same flight, but setting all AI to off.  If the crash is gone you know it's somewhere in the AI routines.

Share this post


Link to post

Anyone using the big AI ships package should reduce their ship AI to 0% and see what happens. If that gets rid of the CTD, look through the Scenery folder and remove the .bgl for that particular geographic locality. I've stopped a couple of CTD's (off Marseilles and American Samoa) in that way.

Share this post


Link to post

Will try flying today after work. Although the route is more southern today than it was two days ago. FRA - IAD (SOBRA Y180 NISIV UY180 DIK UN857 GIMER UT300 EVX UT300 SENLO UN502 JSY UN160 LIZAD UL739 GAPLI SOMAX NATF ELSIR N322A TOPPS ENE BAF HYPER7), this time the route goes over the Newfoundland. And will try flying with no ai aircraft.

Share this post


Link to post
Guest
This topic is now closed to further replies.